summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-misc/connect
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-misc/connect')
-rw-r--r--net-misc/connect/Manifest2
-rw-r--r--net-misc/connect/connect-1.100.ebuild35
-rw-r--r--net-misc/connect/connect-1.103.ebuild35
-rw-r--r--net-misc/connect/metadata.xml22
4 files changed, 94 insertions, 0 deletions
diff --git a/net-misc/connect/Manifest b/net-misc/connect/Manifest
new file mode 100644
index 000000000000..a76bfd2c23b9
--- /dev/null
+++ b/net-misc/connect/Manifest
@@ -0,0 +1,2 @@
+DIST connect-1.100.tar.bz2 21588 SHA256 e34be67caefc38f9b48fba1b5cbce9b0978fc4d33e2640d5d287789a14cb9ccd SHA512 e0bb106ae7270ff0352c2c5167fd47d6d9ac787f08b3019fd9dabe0636606709bc1caf696f6c87699e146eee0cb81db229f9202654f006c12321208c22832108 WHIRLPOOL af15bf382f84742618df9d42de14410f9ca4f6a888835cf4a28f2f5f20d2ec962b52f188a787fb9244f95e5b41f9bcfe6b465a1a5a7dd456d0592bbcd69b1b23
+DIST connect-1.103.tar.bz2 37980 SHA256 d4ea2e1c2831f7578c264196bfeb6285618cc1d50660aa923b91145282ac3155 SHA512 6de32aa48171b1528abe12c1044e1d498cd10c3ef7b4652318402b7bc12bbb50ce0f9eab10408dc3cc26c1c0d56804bd088fbedae688f921c84c40d1aa0ae4d9 WHIRLPOOL 2007c2bcf9460d948554f1b53a389c7f70f2135647b629290c9cd21f11f5f3a647c5d28389b7c20f7e8f4d7c4b9e1c1eec82d7306db3831c31eb1728a9dc79cc
diff --git a/net-misc/connect/connect-1.100.ebuild b/net-misc/connect/connect-1.100.ebuild
new file mode 100644
index 000000000000..6c1d0093c828
--- /dev/null
+++ b/net-misc/connect/connect-1.100.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=3
+
+inherit toolchain-funcs
+
+IUSE=""
+DESCRIPTION="network connection relaying command (proxy)"
+HOMEPAGE="https://bitbucket.org/gotoh/connect"
+HG_COMMIT_ID="7c036cbffb61" # bitbucket commit id
+#SRC_URI="https://www.bitbucket.org/gotoh/connect/get/${PV}.tar.bz2 -> ${P}.tar.bz2"
+SRC_URI="http://bitbucket.org/gotoh/connect/get/${HG_COMMIT_ID}.tar.bz2 -> ${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+DEPEND=""
+RDEPEND=""
+S="${WORKDIR}/gotoh-connect-${HG_COMMIT_ID}"
+
+src_compile() {
+ $(tc-getCC) ${CFLAGS} ${LDFLAGS} -o ${PN} ${PN}.c || die "compilation failed"
+}
+
+src_install() {
+ dobin ${PN}
+}
+
+pkg_postinst() {
+ einfo
+ einfo "There is no manpage."
+ einfo "Please see https://bitbucket.org/gotoh/connect/wiki/Home for details."
+ einfo
+}
diff --git a/net-misc/connect/connect-1.103.ebuild b/net-misc/connect/connect-1.103.ebuild
new file mode 100644
index 000000000000..e1ba3ae9ab7d
--- /dev/null
+++ b/net-misc/connect/connect-1.103.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=3
+
+inherit toolchain-funcs
+
+IUSE=""
+DESCRIPTION="network connection relaying command (proxy)"
+HOMEPAGE="https://bitbucket.org/gotoh/connect"
+HG_COMMIT_ID="ee1fbc21da4b" # bitbucket commit id
+#SRC_URI="https://www.bitbucket.org/gotoh/connect/get/${PV}.tar.bz2 -> ${P}.tar.bz2"
+SRC_URI="http://bitbucket.org/gotoh/connect/get/${HG_COMMIT_ID}.tar.bz2 -> ${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+DEPEND=""
+RDEPEND=""
+S="${WORKDIR}/gotoh-connect-${HG_COMMIT_ID}"
+
+src_compile() {
+ $(tc-getCC) ${CFLAGS} ${LDFLAGS} -o ${PN} ${PN}.c || die "compilation failed"
+}
+
+src_install() {
+ dobin ${PN}
+}
+
+pkg_postinst() {
+ einfo
+ einfo "There is no manpage."
+ einfo "Please see https://bitbucket.org/gotoh/connect/wiki/Home for details."
+ einfo
+}
diff --git a/net-misc/connect/metadata.xml b/net-misc/connect/metadata.xml
new file mode 100644
index 000000000000..5938ebe814ca
--- /dev/null
+++ b/net-misc/connect/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>wschlich@gentoo.org</email>
+ <name>Wolfram Schlich</name>
+ <description>Primary maintainer</description>
+ </maintainer>
+ <longdescription>
+connect is the simple relaying command to make network connection via
+SOCKS and https proxy. It is mainly intended to be used as proxy
+command of OpenSSH.
+</longdescription>
+ <longdescription lang="ja">
+Connect は SOCKS 経由のネットワーク接続と HTTP プロクシを実現する単純な
+中継用コマンドです。主に OpenSSH のプロクシ・コマンドとして利用されるこ
+とを想定してます。
+</longdescription>
+ <upstream>
+ <remote-id type="bitbucket">gotoh/connect</remote-id>
+ </upstream>
+</pkgmetadata>