summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-misc/tcpsound/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-misc/tcpsound/files')
-rw-r--r--net-misc/tcpsound/files/tcpsound-0.3.1-makefile.patch52
-rw-r--r--net-misc/tcpsound/files/tcpsound-0.3.1-misc.patch22
2 files changed, 74 insertions, 0 deletions
diff --git a/net-misc/tcpsound/files/tcpsound-0.3.1-makefile.patch b/net-misc/tcpsound/files/tcpsound-0.3.1-makefile.patch
new file mode 100644
index 000000000000..83f694878376
--- /dev/null
+++ b/net-misc/tcpsound/files/tcpsound-0.3.1-makefile.patch
@@ -0,0 +1,52 @@
+--- a/Makefile
++++ b/Makefile
+@@ -1,32 +1,35 @@
+ # Makefile for tcpsound
+
+-prefix = /usr/local
++prefix = $(DESTDIR)/usr
+
+ bindir = $(prefix)/bin
+-wavdir = $(prefix)/share/sounds
++wavdir = $(prefix)/share/tcpsound
+ includedir = $(prefix)/include
+ libdir = $(prefix)/lib
+-mandir = $(prefix)/man
++mandir = $(prefix)/share/man/man1
+ MAN = tcpsound.1
+ MANGZ = $(MAN:.1=.1.gz)
+-MKTOOL = ./mktool
+-CFLAGS = -c -v -g -W1 -I$(includedir) -L$(libdir) -lSDL -lmba -lpthread
+-CC = $(MKTOOL)
++MKTOOL = install
++CFLAGS += -I$(includedir)
++LIBS = -lSDL -lmba -lpthread
+
+ .SUFFIXES: .1 .1.gz
+
+-tcpsound: mktool src/tcpsound.c src/sound.h src/sound.c src/parse.h src/parse.c
+- @$(CC) $(CFLAGS) src/sound.c src/parse.c src/tcpsound.c -o tcpsound
+-play: mktool src/play.c
+- @$(CC) $(CFLAGS) src/play.c -o play
++tcpsound: src/tcpsound.c src/sound.h src/sound.c src/parse.h src/parse.c
++ $(CC) $(LDFLAGS) $(CFLAGS) src/sound.c src/parse.c src/tcpsound.c -o tcpsound $(LIBS)
++play: src/play.c
++ $(CC) $(LDFLAGS) $(CFLAGS) src/play.c -o play $(LIBS)
+
+ mktool:
+ cc -g -o mktool mktool.c
+
+-install: mktool
+- $(MKTOOL) -i -m 0755 tcpsound $(bindir)
+- $(MKTOOL) -i wavs/*.wav $(wavdir)
+- -$(MKTOOL) -i docs/man/*.1.gz $(mandir)/man1
++install: tcpsound
++ $(MKTOOL) -d $(bindir)
++ $(MKTOOL) -d $(wavdir)
++ $(MKTOOL) -d $(mandir)
++ $(MKTOOL) -m 0755 tcpsound $(bindir)
++ $(MKTOOL) -m 0644 wavs/*.wav $(wavdir)
++ -$(MKTOOL) -m 0644 docs/man/tcpsound.1.gz $(mandir)
+ @echo
+ @echo installation successful
+ uninstall: mktool
diff --git a/net-misc/tcpsound/files/tcpsound-0.3.1-misc.patch b/net-misc/tcpsound/files/tcpsound-0.3.1-misc.patch
new file mode 100644
index 000000000000..7c7136fb954e
--- /dev/null
+++ b/net-misc/tcpsound/files/tcpsound-0.3.1-misc.patch
@@ -0,0 +1,22 @@
+--- a/src/tcpsound.c
++++ b/src/tcpsound.c
+@@ -16,7 +16,7 @@
+ #include "parse.h"
+ #include "sound.h"
+
+-static const char *DEFAULT_CONF = "searchpath = /usr/share/sounds:/usr/local/share/sounds\n\nsnd.default = 1,0,0,generic.wav\nsnd.icmp = 3,0,0,sonar.wav\nsnd.dns = 2,53,53,warning.wav\nsnd.http.in = 2,0,80,pop.wav\nsnd.http.out = 2,80,0,info.wav\nsnd.win.nam = 2,137,137,cuckoo.wav\n";
++static const char *DEFAULT_CONF = "searchpath = /usr/share/tcpsound\n\nsnd.default = 1,0,0,generic.wav\nsnd.icmp = 3,0,0,sonar.wav\nsnd.dns = 2,53,53,warning.wav\nsnd.http.in = 2,0,80,pop.wav\nsnd.http.out = 2,80,0,info.wav\nsnd.win.nam = 2,137,137,cuckoo.wav\n";
+
+ /* struct packet {
+ * unsigned long time;
+--- a/elaborate.conf
++++ b/elaborate.conf
+@@ -7,7 +7,7 @@
+ # to searchpath).
+ #
+
+-searchpath = /usr/share/sounds:/usr/local/share/sounds
++searchpath = /usr/share/tcpsound
+
+ snd.default = 1,0,0,generic.wav
+ snd.icmp = 3,0,0,sonar.wav