summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAntonio Quartulli <a@unstable.cc>2017-10-10 22:08:07 +0800
committerPatrice Clement <monsieurp@gentoo.org>2017-10-28 00:42:35 +0200
commit277d3f4e063bbc2d3071afa0f49844504d7d9685 (patch)
tree231efa8b0789da0441cdf9fc917649762c63db9a /net-misc
parentnet-misc/axel: fix typ0 in portage usage instructions. (diff)
downloadgentoo-277d3f4e063bbc2d3071afa0f49844504d7d9685.tar.gz
gentoo-277d3f4e063bbc2d3071afa0f49844504d7d9685.tar.bz2
gentoo-277d3f4e063bbc2d3071afa0f49844504d7d9685.zip
net-misc/axel: update 9999 ebuild with latest URI, flags and instructions.
Signed-off-by: Antonio Quartulli <a@unstable.cc> Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/axel/axel-9999.ebuild17
1 files changed, 12 insertions, 5 deletions
diff --git a/net-misc/axel/axel-9999.ebuild b/net-misc/axel/axel-9999.ebuild
index 70eda56e3f0d..d4a43d0094fd 100644
--- a/net-misc/axel/axel-9999.ebuild
+++ b/net-misc/axel/axel-9999.ebuild
@@ -6,9 +6,9 @@ EAPI=6
inherit autotools git-r3
DESCRIPTION="Light Unix download accelerator"
-HOMEPAGE="https://github.com/eribertomota/axel"
+HOMEPAGE="https://github.com/axel-download-accelerator/axel"
SRC_URI=""
-EGIT_REPO_URI="https://github.com/eribertomota/axel.git"
+EGIT_REPO_URI="https://github.com/axel-download-accelerator/axel.git"
LICENSE="GPL-2"
SLOT="0"
@@ -38,12 +38,19 @@ src_prepare() {
src_configure() {
econf \
$(use_enable nls) \
- $(use_with ssl openssl)
+ $(use_with ssl)
}
pkg_postinst() {
- einfo 'To use axel with portage, try these settings in your make.conf'
+ einfo 'To use axel with portage, create a script in'
+ einfo '/usr/local/bin/fetchwrapper.sh with the following content:'
einfo
- einfo ' FETCHCOMMAND='\''axel -a -o "\${DISTDIR}/\${FILE}.axel" "\${URI}" && mv "\${DISTDIR}/\${FILE}.axel" "\${DISTDIR}/\${FILE}"'\'
+ einfo ' #!/bin/bash'
+ einfo ' set -e'
+ einfo ' /usr/bin/axel -o "$1.axel" "$2"'
+ einfo ' mv "$1.axel" "$1"'
+ einfo
+ einfo 'and then add the following to your make.conf:'
+ einfo ' FETCHCOMMAND='\''/usr/local/bin/fetchwrapper.sh "\${DISTDIR}/\${FILE}" "\${URI}"'\'
einfo ' RESUMECOMMAND="${FETCHCOMMAND}"'
}