summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorViorel Munteanu <ceamac@gentoo.org>2024-01-11 11:17:15 +0200
committerViorel Munteanu <ceamac@gentoo.org>2024-01-11 11:18:14 +0200
commit2e1685a2359f4be6b09c42cb356e6a6e65984f8b (patch)
tree3de23e1d6fbb5d46bfc7a92e638f9bfe69d3244a /net-nds
parentsci-physics/lammps: add openmp and extra iuse flags, fix hip configure (diff)
downloadgentoo-2e1685a2359f4be6b09c42cb356e6a6e65984f8b.tar.gz
gentoo-2e1685a2359f4be6b09c42cb356e6a6e65984f8b.tar.bz2
gentoo-2e1685a2359f4be6b09c42cb356e6a6e65984f8b.zip
net-nds/phpldapadmin: add 1.2.6.7
Signed-off-by: Viorel Munteanu <ceamac@gentoo.org>
Diffstat (limited to 'net-nds')
-rw-r--r--net-nds/phpldapadmin/Manifest1
-rw-r--r--net-nds/phpldapadmin/phpldapadmin-1.2.6.7.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/net-nds/phpldapadmin/Manifest b/net-nds/phpldapadmin/Manifest
index 86043af17342..45d9f235d654 100644
--- a/net-nds/phpldapadmin/Manifest
+++ b/net-nds/phpldapadmin/Manifest
@@ -1 +1,2 @@
DIST phpldapadmin-1.2.6.6.tar.gz 1132820 BLAKE2B e153d9ac3e844a1a08235c43a096a7418a2d67128bc216fe09f7a00c4f4bdf39e7646842d0c0189c5c42beb3a7823959c7d5fa21b8721f96d0204f87e9b16aad SHA512 398bb6c36a3c9b64016bebc6debeaf8048c4b6b9ebdc7a2bfa8acfa4d4458990a0a59d4e32a2abef772baba667dd495309eff2d68e39847f25a50ad79a06984d
+DIST phpldapadmin-1.2.6.7.tar.gz 1133418 BLAKE2B f1f19c52694f1c6299b2f52fef73702ae330cfc1276bacbfeeb70989505e33548e9bb01d0cd2814cdcea363da4ed54210c6c38642defd752b63511410d7248dd SHA512 4a0ea1cb5bfeeb6a6a242b29137cdd26c014788d771ce9cf5dcef771756b38575a2fd3e04d00cd3ff5181bf8891037bc347d4f933c67958376d2246fa72752c7
diff --git a/net-nds/phpldapadmin/phpldapadmin-1.2.6.7.ebuild b/net-nds/phpldapadmin/phpldapadmin-1.2.6.7.ebuild
new file mode 100644
index 000000000000..c8007c7d88d4
--- /dev/null
+++ b/net-nds/phpldapadmin/phpldapadmin-1.2.6.7.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit webapp
+
+MY_PN="phpLDAPadmin"
+DESCRIPTION="phpLDAPadmin is a web-based tool for managing all aspects of your LDAP server"
+HOMEPAGE="https://github.com/leenooks/phpLDAPadmin"
+SRC_URI="https://github.com/leenooks/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+RDEPEND="
+ >=dev-lang/php-8.0[hash(+),ldap,session,xml,nls]
+ dev-libs/openssl
+ virtual/httpd-php
+"
+BDEPEND="
+ media-libs/libpng
+"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.2.1.1-fix-magic-quotes.patch"
+ "${FILESDIR}/${PN}-1.2.6.4-getDN-htmlspecialchars.patch"
+)
+
+need_httpd_cgi
+
+src_prepare() {
+ mv config/config.php.example config/config.php || die
+ default
+ # fix QA notice about broken IDAT window length
+ pngfix --out=network.png htdocs/images/default/network.png; [[ $? -lt 16 ]] || die
+ pngfix --out=document.png htdocs/images/default/document.png; [[ $? -lt 16 ]] || die
+ mv -f network.png document.png htdocs/images/default/ || die
+}
+
+src_install() {
+ webapp_src_preinst
+
+ dodoc INSTALL.md
+
+ # Restrict config file access - bug 280836
+ chown root:apache "config/config.php"
+ chmod 640 "config/config.php"
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r *
+
+ webapp_configfile "${MY_HTDOCSDIR}/config/config.php"
+ webapp_postinst_txt en "${FILESDIR}"/postinstall2-en.txt
+
+ webapp_src_install
+}