summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2021-05-09 21:18:17 +0200
committerDavid Seifert <soap@gentoo.org>2021-05-09 21:18:17 +0200
commit23eeb325a763fa382ddb6e52f7572d610fb0f860 (patch)
tree7a253c645786bdfbc22f8dd06e3134c6ff58b51c /sci-astronomy
parentsci-libs/primegen: Respect AR/RANLIB (diff)
downloadgentoo-23eeb325a763fa382ddb6e52f7572d610fb0f860.tar.gz
gentoo-23eeb325a763fa382ddb6e52f7572d610fb0f860.tar.bz2
gentoo-23eeb325a763fa382ddb6e52f7572d610fb0f860.zip
sci-astronomy/xfitsview: Respect AR
Closes: https://bugs.gentoo.org/725292 Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sci-astronomy')
-rw-r--r--sci-astronomy/xfitsview/files/xfitsview-2.2-build_system.patch15
-rw-r--r--sci-astronomy/xfitsview/xfitsview-2.2-r2.ebuild20
2 files changed, 26 insertions, 9 deletions
diff --git a/sci-astronomy/xfitsview/files/xfitsview-2.2-build_system.patch b/sci-astronomy/xfitsview/files/xfitsview-2.2-build_system.patch
index 12eaacf4e244..ca45aa7ba39a 100644
--- a/sci-astronomy/xfitsview/files/xfitsview-2.2-build_system.patch
+++ b/sci-astronomy/xfitsview/files/xfitsview-2.2-build_system.patch
@@ -1,9 +1,22 @@
* Fix parallel build
* Respect LDFLAGS
* Fix build with gmake 3.82
+* Respect AR
-http://bugs.gentoo.org/show_bug.cgi?id=337479
+https://bugs.gentoo.org/337479
+https://bugs.gentoo.org/725292
+--- a/lib/Makefile
++++ b/lib/Makefile
+@@ -44,7 +44,7 @@
+
+ # build fitssub library
+ $(ARCH)/libfitsLib.a: ${OBJECTS}
+- ar rv $(ARCH)/libfitsLib.a ${OBJECTS}
++ ${AR} rv $(ARCH)/libfitsLib.a ${OBJECTS}
+ ${RANLIB} $(ARCH)/libfitsLib.a
+
+ clean:
--- a/Makefile.in
+++ b/Makefile.in
@@ -61,26 +61,26 @@
diff --git a/sci-astronomy/xfitsview/xfitsview-2.2-r2.ebuild b/sci-astronomy/xfitsview/xfitsview-2.2-r2.ebuild
index ff1ebd1455cc..32762bcf8728 100644
--- a/sci-astronomy/xfitsview/xfitsview-2.2-r2.ebuild
+++ b/sci-astronomy/xfitsview/xfitsview-2.2-r2.ebuild
@@ -1,7 +1,9 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
+
+inherit toolchain-funcs
MY_PN=XFITSview
MY_P=${MY_PN}${PV}
@@ -9,26 +11,28 @@ MY_P=${MY_PN}${PV}
DESCRIPTION="Viewer for astronomical images in FITS format"
HOMEPAGE="http://www.nrao.edu/software/fitsview/"
SRC_URI="ftp://ftp.cv.nrao.edu/fits/os-support/unix/xfitsview/${PN}${PV}.tgz"
+S="${WORKDIR}/${MY_PN}"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE=""
DEPEND=">=x11-libs/motif-2.3:0"
RDEPEND="${DEPEND}"
-S=${WORKDIR}/${MY_PN}
-
-DOCS=( README changes notes.text )
PATCHES=( "${FILESDIR}"/${P}-build_system.patch )
src_prepare() {
default
- find "${S}" -name '*old.c' -delete || die
+ find -name '*old.c' -delete || die
+}
+
+src_configure() {
+ tc-export AR
+ default
}
src_install() {
dobin XFITSview
- einstalldocs
+ dodoc README changes notes.text
}