summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-biology/infernal
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-biology/infernal')
-rw-r--r--sci-biology/infernal/Manifest1
-rw-r--r--sci-biology/infernal/files/infernal-1.0.2-ldflags.patch15
-rw-r--r--sci-biology/infernal/files/infernal-1.0.2-overflows.patch15
-rw-r--r--sci-biology/infernal/files/infernal-1.0.2-parallel-build.patch31
-rw-r--r--sci-biology/infernal/files/infernal-1.0.2-perl-5.16-2.patch147
-rw-r--r--sci-biology/infernal/infernal-1.0.2-r1.ebuild47
-rw-r--r--sci-biology/infernal/metadata.xml5
7 files changed, 261 insertions, 0 deletions
diff --git a/sci-biology/infernal/Manifest b/sci-biology/infernal/Manifest
new file mode 100644
index 000000000000..ab636b70040d
--- /dev/null
+++ b/sci-biology/infernal/Manifest
@@ -0,0 +1 @@
+DIST infernal-1.0.2.tar.gz 15205421 SHA256 c4f89ac2e865c8b04a53a647703d88f96c31bb1d47d3e06f4b6090d7d15643ad SHA512 0399be14c17f053574e95d8c5b9eaf990545795a9268e20f0940e11a8e78fc49beb4b23994e9ea427764fbb29e9b39f6da9cb1d85eb4b56d354057b48515c4af WHIRLPOOL c4fa3326eb1b36252ce41ca1aeca68bed4373061ca6bc2bfc0af62c0805bfa1747272fbf223b8d47194853ae5cbe7af11d47493c258264503ea6aa7b142a6b60
diff --git a/sci-biology/infernal/files/infernal-1.0.2-ldflags.patch b/sci-biology/infernal/files/infernal-1.0.2-ldflags.patch
new file mode 100644
index 000000000000..5bc5bd008ff6
--- /dev/null
+++ b/sci-biology/infernal/files/infernal-1.0.2-ldflags.patch
@@ -0,0 +1,15 @@
+Respect LDFLAGS
+
+http://bugs.gentoo.org/show_bug.cgi?id=338177
+
+--- src/Makefile.in
++++ src/Makefile.in
+@@ -86,7 +86,7 @@
+ all: $(PROGS)
+
+ $(PROGS): @EXEC_DEPENDENCY@ $(OBJS) ${HDRS}
+- $(CC) $(CFLAGS) $(DEFS) $(MYLIBDIR) -o $@ $@.o $(OBJS) $(MYLIBS) $(LIBS) $(MPILIBS)
++ $(CC) $(LDFLAGS) $(CFLAGS) $(DEFS) $(MYLIBDIR) -o $@ $@.o $(OBJS) $(MYLIBS) $(LIBS) $(MPILIBS)
+
+
+ #################################################################
diff --git a/sci-biology/infernal/files/infernal-1.0.2-overflows.patch b/sci-biology/infernal/files/infernal-1.0.2-overflows.patch
new file mode 100644
index 000000000000..b9791fa1ca2e
--- /dev/null
+++ b/sci-biology/infernal/files/infernal-1.0.2-overflows.patch
@@ -0,0 +1,15 @@
+Fix buffer overflow
+
+http://bugs.gentoo.org/show_bug.cgi?id=338179
+
+--- easel/esl_getopts.c
++++ easel/esl_getopts.c
+@@ -1270,7 +1270,7 @@
+ "Arg looks like option? Use %.24s%.24s if you really mean it.",
+ g->opt[opti].name, *ret_optarg);
+ } else
+- ESL_FAIL(eslESYNTAX, "Option %.24s requires an argument", g->opt[opti].name);
++ ESL_FAIL(eslESYNTAX, g->errbuf, "Option %.24s requires an argument", g->opt[opti].name);
+
+ g->optstring = NULL; /* An optchar that takes an arg must terminate an optstring. */
+ }
diff --git a/sci-biology/infernal/files/infernal-1.0.2-parallel-build.patch b/sci-biology/infernal/files/infernal-1.0.2-parallel-build.patch
new file mode 100644
index 000000000000..004742546f00
--- /dev/null
+++ b/sci-biology/infernal/files/infernal-1.0.2-parallel-build.patch
@@ -0,0 +1,31 @@
+Fix parallel build
+
+http://bugs.gentoo.org/show_bug.cgi?id=311919
+
+--- Makefile.in
++++ Makefile.in
+@@ -82,9 +82,10 @@
+ all: core
+
+ core:
+- (cd easel; make CC="$(CC)" CFLAGS="$(CFLAGS)"; make)
+- (cd src; make CC="$(CC)" CFLAGS="$(CFLAGS)"; make module)
+- (cd testsuite; make CC="$(CC)" CFLAGS="$(CFLAGS)")
++ $(MAKE) -C easel
++ $(MAKE) -C src
++ $(MAKE) -C src module
++ $(MAKE) -C testsuite
+
+ #.PHONY: $(RIGFILTERS)
+ #$(RIGFILTERS): core
+--- easel/Makefile.in
++++ easel/Makefile.in
+@@ -132,7 +132,7 @@
+ esl_wuss.o
+
+ all: libeasel.a
+- (cd miniapps; make)
++ $(MAKE) -C miniapps
+
+ .c.o:
+ ${CC} -I. ${CFLAGS} ${SIMDFLAGS} ${DEFS} -c $<
diff --git a/sci-biology/infernal/files/infernal-1.0.2-perl-5.16-2.patch b/sci-biology/infernal/files/infernal-1.0.2-perl-5.16-2.patch
new file mode 100644
index 000000000000..c96dcae7b296
--- /dev/null
+++ b/sci-biology/infernal/files/infernal-1.0.2-perl-5.16-2.patch
@@ -0,0 +1,147 @@
+ benchmarks/cmsearch-rmark/sre.pl | 4 +---
+ easel/devkit/autodoc | 4 ++--
+ easel/devkit/esl-dependencies | 4 ++--
+ easel/devkit/sqc | 7 +++----
+ easel/testsuite/coverage_report.pl | 4 ++--
+ easel/testsuite/driver_report.pl | 4 ++--
+ easel/testsuite/valgrind_report.pl | 4 ++--
+ 7 files changed, 14 insertions(+), 17 deletions(-)
+
+diff --git a/benchmarks/cmsearch-rmark/sre.pl b/benchmarks/cmsearch-rmark/sre.pl
+index 9136717..e4df233 100644
+--- a/benchmarks/cmsearch-rmark/sre.pl
++++ b/benchmarks/cmsearch-rmark/sre.pl
+@@ -6,8 +6,6 @@
+
+ package SRE_perlstuff;
+
+-require "importenv.pl";
+-
+ # Function: tempname
+ #
+ # Returns a unique temporary filename.
+@@ -26,7 +24,7 @@ require "importenv.pl";
+ #
+ sub main'tempname {
+ local ($dir, $name);
+- if ($TMPDIR) { $dir = $TMPDIR; } else {$dir = "/tmp";}
++ if ($ENV{TMPDIR}) { $dir = $ENV{TMPDIR}; } else {$dir = "/tmp";}
+
+ foreach $suffix ("aa".."zz") {
+ $name = "$dir/sre$suffix$$";
+diff --git a/easel/devkit/autodoc b/easel/devkit/autodoc
+old mode 100755
+new mode 100644
+index 045ce36..22268f6
+--- a/easel/devkit/autodoc
++++ b/easel/devkit/autodoc
+@@ -49,8 +49,8 @@
+ #
+ # SRE, Tue Nov 30 19:43:47 2004
+
+-require "getopts.pl";
+-&Getopts('n:t');
++use Getopt::Std;
++getopts('n:t');
+ $cfile = shift;
+
+ if ($opt_t) { $show_api_table = 1; }
+diff --git a/easel/devkit/esl-dependencies b/easel/devkit/esl-dependencies
+old mode 100755
+new mode 100644
+index a4dc126..b61fa7a
+--- a/easel/devkit/esl-dependencies
++++ b/easel/devkit/esl-dependencies
+@@ -13,8 +13,8 @@
+ # SRE, Mon Jun 11 11:15:31 2007
+ # SVN $Id$
+
+-require "getopts.pl"
+-&Getopts('1afr');
++use Getopt::Std;
++getopts('1afr');
+
+ if ($opt_1) { $show_summary_table = 1; }
+ if ($opt_a) { $list_augfiles = 1; }
+diff --git a/easel/devkit/sqc b/easel/devkit/sqc
+old mode 100755
+new mode 100644
+index 81d03de..6201d3d
+--- a/easel/devkit/sqc
++++ b/easel/devkit/sqc
+@@ -176,12 +176,11 @@
+ # SRE, Tue Aug 6 11:16:39 2002
+ # SVN $Id: sqc 1796 2007-01-03 22:36:44Z eddys $
+
+-require "getopts.pl";
+-require "importenv.pl";
++use Getopt::Std;
+
+ # Parse our command line
+ #
+-&Getopts('mp:r:v');
++getopts('mp:r:v');
+ if ($opt_m) { $do_memtest = 1; }
+ if ($opt_p) { push @prepdirs, $opt_p; }
+ if ($opt_r) { push @olddirs, $opt_r; }
+@@ -510,7 +509,7 @@ check_ccmalloc_status
+ #
+ sub tempname {
+ my ($dir, $name, $suffix);
+- if ($TMPDIR) { $dir = $TMPDIR."/"; } else {$dir = "";}
++ if ($ENV{TMPDIR}) { $dir = $ENV{TMPDIR}."/"; } else {$dir = "";}
+
+ foreach $suffix ("aa".."zz") {
+ $name = "$dir"."esltmp".$suffix.$$;
+diff --git a/easel/testsuite/coverage_report.pl b/easel/testsuite/coverage_report.pl
+old mode 100755
+new mode 100644
+index 9c77791..024ed34
+--- a/easel/testsuite/coverage_report.pl
++++ b/easel/testsuite/coverage_report.pl
+@@ -16,9 +16,9 @@
+ #
+ # SRE, Thu Mar 1 19:22:57 2007 (Janelia)
+ # SVN $Id: coverage_report.pl 231 2008-03-25 14:43:57Z eddys $
+-require "getopts.pl";
++use Getopt::Std;
+ $have_sloccount = 1;
+-&Getopts('cs');
++getopts('cs');
+ if ($opt_c) { $do_recompile = 1; }
+ if ($opt_s) { $have_sloccount = 0; }
+
+diff --git a/easel/testsuite/driver_report.pl b/easel/testsuite/driver_report.pl
+old mode 100755
+new mode 100644
+index d1b4a9a..db4378f
+--- a/easel/testsuite/driver_report.pl
++++ b/easel/testsuite/driver_report.pl
+@@ -19,8 +19,8 @@
+ # SRE, Fri Mar 2 10:01:44 2007 (Janelia)
+ # SVN $Id: driver_report.pl 231 2008-03-25 14:43:57Z eddys $
+
+-require "getopts.pl";
+-&Getopts('c');
++use Getopt::Std;
++getopts('c');
+ if ($opt_c) { $do_recompile = 1; }
+
+ if ($ENV{'CC'} ne "") { $CC = $ENV{'CC'}; } else { $CC = "gcc"; }
+diff --git a/easel/testsuite/valgrind_report.pl b/easel/testsuite/valgrind_report.pl
+old mode 100755
+new mode 100644
+index 186a392..07026a0
+--- a/easel/testsuite/valgrind_report.pl
++++ b/easel/testsuite/valgrind_report.pl
+@@ -10,8 +10,8 @@
+ #
+ # SRE, Fri Mar 2 08:37:48 2007 [Janelia]
+ # SVN $Id: valgrind_report.pl 231 2008-03-25 14:43:57Z eddys $
+-require "getopts.pl";
+-&Getopts('c');
++use Getopt::Std;
++getopts('c');
+ if ($opt_c) { $do_recompile = 1; }
+
+ if ($ENV{'CC'} ne "") { $CC = $ENV{'CC'}; } else { $CC = "gcc"; }
diff --git a/sci-biology/infernal/infernal-1.0.2-r1.ebuild b/sci-biology/infernal/infernal-1.0.2-r1.ebuild
new file mode 100644
index 000000000000..3c0ca9aa7b12
--- /dev/null
+++ b/sci-biology/infernal/infernal-1.0.2-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils
+
+DESCRIPTION="Inference of RNA alignments"
+HOMEPAGE="http://infernal.janelia.org/"
+SRC_URI="ftp://selab.janelia.org/pub/software/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="mpi"
+KEYWORDS="amd64 x86"
+
+DEPEND="mpi? ( virtual/mpi )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-parallel-build.patch \
+ "${FILESDIR}"/${P}-overflows.patch \
+ "${FILESDIR}"/${P}-perl-5.16-2.patch \
+ "${FILESDIR}"/${P}-ldflags.patch
+}
+
+src_configure() {
+ econf \
+ --prefix="${D}/usr" \
+ $(use_enable mpi)
+}
+
+src_install() {
+ default
+
+ pushd documentation/manpages > /dev/null
+ for i in *;
+ do newman ${i} ${i/.man/.1}
+ done
+ popd > /dev/null
+
+ insinto /usr/share/${PN}
+ doins -r benchmarks tutorial intro matrices
+ dodoc 00README* Userguide.pdf documentation/release-notes/*
+}
diff --git a/sci-biology/infernal/metadata.xml b/sci-biology/infernal/metadata.xml
new file mode 100644
index 000000000000..f17a827e3101
--- /dev/null
+++ b/sci-biology/infernal/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-biology</herd>
+</pkgmetadata>