summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2022-06-19 20:04:31 +0200
committerDavid Seifert <soap@gentoo.org>2022-06-19 20:04:31 +0200
commit4de3a1e7db21aa87998de78257a767004750f415 (patch)
tree41e7afef494adba333e964f9bbe24ecf66712d2b /sci-biology
parentsci-biology/primer3: update EAPI 6 -> 8 (diff)
downloadgentoo-4de3a1e7db21aa87998de78257a767004750f415.tar.gz
gentoo-4de3a1e7db21aa87998de78257a767004750f415.tar.bz2
gentoo-4de3a1e7db21aa87998de78257a767004750f415.zip
sci-biology/rebase: update EAPI 6 -> 8
Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/rebase/rebase-1901-r1.ebuild (renamed from sci-biology/rebase/rebase-1901.ebuild)22
1 files changed, 11 insertions, 11 deletions
diff --git a/sci-biology/rebase/rebase-1901.ebuild b/sci-biology/rebase/rebase-1901-r1.ebuild
index f85a4b1698bb..a993a8c2c44a 100644
--- a/sci-biology/rebase/rebase-1901.ebuild
+++ b/sci-biology/rebase/rebase-1901-r1.ebuild
@@ -1,32 +1,32 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
-MY_PV=${PV#1}
+MY_PV="${PV#1}"
DESCRIPTION="A restriction enzyme database"
HOMEPAGE="http://rebase.neb.com"
SRC_URI="https://dev.gentoo.org/~jlec/distfiles/${P}.tar.xz"
-SLOT="0"
LICENSE="public-domain"
+SLOT="0"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris ~x86-solaris"
IUSE="emboss minimal"
-
-RDEPEND="emboss? ( >=sci-biology/emboss-5.0.0 )"
-DEPEND="${RDEPEND}"
-
RESTRICT="binchecks strip"
+BDEPEND="emboss? ( sci-biology/emboss )"
+REPEND="${BDEPEND}"
+
src_compile() {
if use emboss; then
- echo; einfo "Indexing Rebase for usage with EMBOSS."
+ einfo
+ einfo "Indexing Rebase for usage with EMBOSS"
mkdir REBASE || die
EMBOSS_DATA="." rebaseextract -auto -infile withrefm.${MY_PV} \
-protofile proto.${MY_PV} -equivalences \
- || die "Indexing Rebase failed."
- echo
+ || die "Indexing Rebase failed"
+ einfo
fi
}