summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2020-08-03 18:54:35 +0200
committerDavid Seifert <soap@gentoo.org>2020-08-03 18:54:35 +0200
commit774908698f411d554226b066ec933a64afca0c4f (patch)
tree7cb0d255965079c92d4ce0f70b1167e14bcaa984 /sci-biology
parentsci-biology/HTSeq: Bump to 0.12.4 (diff)
downloadgentoo-774908698f411d554226b066ec933a64afca0c4f.tar.gz
gentoo-774908698f411d554226b066ec933a64afca0c4f.tar.bz2
gentoo-774908698f411d554226b066ec933a64afca0c4f.zip
sci-biology/HTSeq: Sync live ebuild
Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/HTSeq/HTSeq-9999.ebuild14
1 files changed, 8 insertions, 6 deletions
diff --git a/sci-biology/HTSeq/HTSeq-9999.ebuild b/sci-biology/HTSeq/HTSeq-9999.ebuild
index 18a07a7b9f9f..1f5693d9a139 100644
--- a/sci-biology/HTSeq/HTSeq-9999.ebuild
+++ b/sci-biology/HTSeq/HTSeq-9999.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-PYTHON_COMPAT=( python3_6 )
+PYTHON_COMPAT=( python3_{6..9} )
inherit distutils-r1
@@ -12,9 +12,11 @@ HOMEPAGE="https://htseq.readthedocs.io/"
if [[ ${PV} == *9999 ]]; then
inherit git-r3
- EGIT_REPO_URI="https://github.com/simon-anders/htseq.git"
+ EGIT_REPO_URI="https://github.com/htseq/htseq.git"
else
- SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ SRC_URI="https://github.com/htseq/htseq/archive/release_${PV}.tar.gz -> ${P}.tar.gz"
+
+ S="${WORKDIR}"/htseq-release_${PV}
KEYWORDS="~amd64"
fi
@@ -25,7 +27,7 @@ RDEPEND="
dev-python/numpy[${PYTHON_USEDEP}]
dev-python/matplotlib[${PYTHON_USEDEP}]
sci-biology/pysam[${PYTHON_USEDEP}]"
-DEPEND="
- ${RDEPEND}
+DEPEND="${RDEPEND}"
+BDEPEND="
>=dev-lang/swig-3.0.8
dev-python/cython[${PYTHON_USEDEP}]"