summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2017-02-26 20:16:40 +0100
committerDavid Seifert <soap@gentoo.org>2017-02-26 20:18:38 +0100
commitd7aab918caf0a3dc9e599a8407df20df8db38d4d (patch)
tree33dbd35912c711562f3cf4de956ca8e47fe8edb5 /sci-biology
parentmedia-video/parole: Bump to 0.9.1 (bugfix) (diff)
downloadgentoo-d7aab918caf0a3dc9e599a8407df20df8db38d4d.tar.gz
gentoo-d7aab918caf0a3dc9e599a8407df20df8db38d4d.tar.bz2
gentoo-d7aab918caf0a3dc9e599a8407df20df8db38d4d.zip
sci-biology/ariadne: Modernise to EAPI 6
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/ariadne/ariadne-1.3-r3.ebuild47
-rw-r--r--sci-biology/ariadne/files/ariadne-1.3-gcc4.patch4
2 files changed, 49 insertions, 2 deletions
diff --git a/sci-biology/ariadne/ariadne-1.3-r3.ebuild b/sci-biology/ariadne/ariadne-1.3-r3.ebuild
new file mode 100644
index 000000000000..8be74e1353cb
--- /dev/null
+++ b/sci-biology/ariadne/ariadne-1.3-r3.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="Protein sequences and profiles comparison"
+HOMEPAGE="http://www.well.ox.ac.uk/ariadne/"
+SRC_URI="http://www.well.ox.ac.uk/${PN}/${P}.tar.Z"
+
+LICENSE="ARIADNE"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs"
+
+DEPEND=">=sci-biology/ncbi-tools-0.20041020-r1"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/SRC-${PV}
+
+PATCHES=(
+ "${FILESDIR}"/${P}-gcc4.patch
+ "${FILESDIR}"/${P}-implicits.patch
+)
+
+src_prepare() {
+ default
+ sed -i -e "s/\$(CFLAGS)/\$(LDFLAGS) &/" Makefile || die #359045
+ sed -e "s/blosum62/BLOSUM62/" -i prospero.c || die
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" OPTIMISE="${CFLAGS}"
+}
+
+src_install() {
+ dobin Linux/{ariadne,prospero}
+
+ use static-libs && dolib.a Linux/libseq.a
+
+ insinto /usr/include/${PN}
+ doins Include/*.h
+
+ einstalldocs
+}
diff --git a/sci-biology/ariadne/files/ariadne-1.3-gcc4.patch b/sci-biology/ariadne/files/ariadne-1.3-gcc4.patch
index 0192efd4db5e..8bda75cb4f3a 100644
--- a/sci-biology/ariadne/files/ariadne-1.3-gcc4.patch
+++ b/sci-biology/ariadne/files/ariadne-1.3-gcc4.patch
@@ -1,5 +1,5 @@
---- cl.c.old 2006-09-12 17:13:02.000000000 -0400
-+++ cl.c 2006-09-12 17:13:34.000000000 -0400
+--- a/cl.c
++++ b/cl.c
@@ -658,6 +658,7 @@
fclose(fp);
if ( ! stat( filename, &buf ) )