summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-chemistry/elem
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-chemistry/elem')
-rw-r--r--sci-chemistry/elem/Manifest1
-rw-r--r--sci-chemistry/elem/elem-1.0.3-r1.ebuild32
-rw-r--r--sci-chemistry/elem/elem-1.0.3-r2.ebuild35
-rw-r--r--sci-chemistry/elem/metadata.xml8
4 files changed, 76 insertions, 0 deletions
diff --git a/sci-chemistry/elem/Manifest b/sci-chemistry/elem/Manifest
new file mode 100644
index 000000000000..49bd992fc961
--- /dev/null
+++ b/sci-chemistry/elem/Manifest
@@ -0,0 +1 @@
+DIST elem-src-1.0.3-Linux.tgz 58364 SHA256 a570736165b939841a9dbf273110a6c01ddfd77559e5b020574aad8e3f5af296
diff --git a/sci-chemistry/elem/elem-1.0.3-r1.ebuild b/sci-chemistry/elem/elem-1.0.3-r1.ebuild
new file mode 100644
index 000000000000..386caa804b61
--- /dev/null
+++ b/sci-chemistry/elem/elem-1.0.3-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit toolchain-funcs
+
+DESCRIPTION="periodic table of the elements"
+HOMEPAGE="http://elem.sourceforge.net/"
+SRC_URI="mirror://sourceforge/elem/${PN}-src-${PV}-Linux.tgz"
+LICENSE="GPL-2"
+KEYWORDS="amd64 sparc x86"
+SLOT="0"
+IUSE=""
+
+DEPEND="x11-libs/xforms"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -e 's:\(^LIBS = .*\):\1 -lXpm:' -i Makefile || die "sed failed"
+}
+
+src_compile () {
+ emake COMPILER="$(tc-getCC)" FLAGS="${CFLAGS}" all || die "Build failed."
+}
+
+src_install () {
+ into /usr
+ dobin elem elem-de elem-en
+ dohtml -r doc/*
+}
diff --git a/sci-chemistry/elem/elem-1.0.3-r2.ebuild b/sci-chemistry/elem/elem-1.0.3-r2.ebuild
new file mode 100644
index 000000000000..c52107340659
--- /dev/null
+++ b/sci-chemistry/elem/elem-1.0.3-r2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit toolchain-funcs
+
+DESCRIPTION="periodic table of the elements"
+HOMEPAGE="http://elem.sourceforge.net/"
+SRC_URI="mirror://sourceforge/elem/${PN}-src-${PV}-Linux.tgz"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~sparc ~x86"
+SLOT="0"
+IUSE=""
+
+DEPEND="x11-libs/xforms"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -e 's:\(^LIBS = .*\):\1 -lXpm:' \
+ -e "s:\${FLAGS} -o elem:\$(LDFLAGS) &:" \
+ -i Makefile || die #336190
+ sed -e "/string.h/ i #include <stdlib.h>" \
+ -i elem_cb.c || die #implicit exit()
+}
+
+src_compile () {
+ emake COMPILER="$(tc-getCC)" FLAGS="${CFLAGS}" all || die "Build failed."
+}
+
+src_install () {
+ dobin elem elem-de elem-en || die
+ dohtml -r doc/* || die
+}
diff --git a/sci-chemistry/elem/metadata.xml b/sci-chemistry/elem/metadata.xml
new file mode 100644
index 000000000000..841c9b22af92
--- /dev/null
+++ b/sci-chemistry/elem/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-chemistry</herd>
+ <upstream>
+ <remote-id type="sourceforge">elem</remote-id>
+ </upstream>
+</pkgmetadata>