summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-chemistry/elem')
-rw-r--r--sci-chemistry/elem/Manifest1
-rw-r--r--sci-chemistry/elem/elem-1.0.3-r1.ebuild32
-rw-r--r--sci-chemistry/elem/elem-1.0.3-r2.ebuild35
-rw-r--r--sci-chemistry/elem/metadata.xml8
4 files changed, 76 insertions, 0 deletions
diff --git a/sci-chemistry/elem/Manifest b/sci-chemistry/elem/Manifest
new file mode 100644
index 000000000000..49bd992fc961
--- /dev/null
+++ b/sci-chemistry/elem/Manifest
@@ -0,0 +1 @@
+DIST elem-src-1.0.3-Linux.tgz 58364 SHA256 a570736165b939841a9dbf273110a6c01ddfd77559e5b020574aad8e3f5af296
diff --git a/sci-chemistry/elem/elem-1.0.3-r1.ebuild b/sci-chemistry/elem/elem-1.0.3-r1.ebuild
new file mode 100644
index 000000000000..386caa804b61
--- /dev/null
+++ b/sci-chemistry/elem/elem-1.0.3-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit toolchain-funcs
+
+DESCRIPTION="periodic table of the elements"
+HOMEPAGE="http://elem.sourceforge.net/"
+SRC_URI="mirror://sourceforge/elem/${PN}-src-${PV}-Linux.tgz"
+LICENSE="GPL-2"
+KEYWORDS="amd64 sparc x86"
+SLOT="0"
+IUSE=""
+
+DEPEND="x11-libs/xforms"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -e 's:\(^LIBS = .*\):\1 -lXpm:' -i Makefile || die "sed failed"
+}
+
+src_compile () {
+ emake COMPILER="$(tc-getCC)" FLAGS="${CFLAGS}" all || die "Build failed."
+}
+
+src_install () {
+ into /usr
+ dobin elem elem-de elem-en
+ dohtml -r doc/*
+}
diff --git a/sci-chemistry/elem/elem-1.0.3-r2.ebuild b/sci-chemistry/elem/elem-1.0.3-r2.ebuild
new file mode 100644
index 000000000000..c52107340659
--- /dev/null
+++ b/sci-chemistry/elem/elem-1.0.3-r2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit toolchain-funcs
+
+DESCRIPTION="periodic table of the elements"
+HOMEPAGE="http://elem.sourceforge.net/"
+SRC_URI="mirror://sourceforge/elem/${PN}-src-${PV}-Linux.tgz"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~sparc ~x86"
+SLOT="0"
+IUSE=""
+
+DEPEND="x11-libs/xforms"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -e 's:\(^LIBS = .*\):\1 -lXpm:' \
+ -e "s:\${FLAGS} -o elem:\$(LDFLAGS) &:" \
+ -i Makefile || die #336190
+ sed -e "/string.h/ i #include <stdlib.h>" \
+ -i elem_cb.c || die #implicit exit()
+}
+
+src_compile () {
+ emake COMPILER="$(tc-getCC)" FLAGS="${CFLAGS}" all || die "Build failed."
+}
+
+src_install () {
+ dobin elem elem-de elem-en || die
+ dohtml -r doc/* || die
+}
diff --git a/sci-chemistry/elem/metadata.xml b/sci-chemistry/elem/metadata.xml
new file mode 100644
index 000000000000..841c9b22af92
--- /dev/null
+++ b/sci-chemistry/elem/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-chemistry</herd>
+ <upstream>
+ <remote-id type="sourceforge">elem</remote-id>
+ </upstream>
+</pkgmetadata>