summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-electronics/drawtiming/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-electronics/drawtiming/files')
-rw-r--r--sci-electronics/drawtiming/files/drawtiming-0.7.1-gcc43.patch10
-rw-r--r--sci-electronics/drawtiming/files/drawtiming-0.7.1-ldflags.patch36
2 files changed, 46 insertions, 0 deletions
diff --git a/sci-electronics/drawtiming/files/drawtiming-0.7.1-gcc43.patch b/sci-electronics/drawtiming/files/drawtiming-0.7.1-gcc43.patch
new file mode 100644
index 000000000000..4249c79aa6e1
--- /dev/null
+++ b/sci-electronics/drawtiming/files/drawtiming-0.7.1-gcc43.patch
@@ -0,0 +1,10 @@
+--- src/timing.cc.old 2011-06-01 18:27:42.000000000 +0000
++++ src/timing.cc 2011-06-01 18:28:09.000000000 +0000
+@@ -23,6 +23,7 @@
+ #include "timing.h"
+ #include <map>
+ #include <fstream>
++#include <cstring>
+ using namespace std;
+ using namespace timing;
+ using namespace Magick;
diff --git a/sci-electronics/drawtiming/files/drawtiming-0.7.1-ldflags.patch b/sci-electronics/drawtiming/files/drawtiming-0.7.1-ldflags.patch
new file mode 100644
index 000000000000..d50621f76796
--- /dev/null
+++ b/sci-electronics/drawtiming/files/drawtiming-0.7.1-ldflags.patch
@@ -0,0 +1,36 @@
+Description: Switch LDADD with LDFLAGS
+ This change is to move the objects before the libs. to fix an FTBFS when
+ --as-needed is passed to gcc.
+Author: …حمودي (Ahmed El-Mahmoudy) <aelmahmoudy@sabily.org>
+Forwarded: yes
+--- drawtiming-0.7.1.orig/src/Makefile.am
++++ drawtiming-0.7.1/src/Makefile.am
+@@ -3,7 +3,7 @@
+
+ bin_PROGRAMS = drawtiming
+ drawtiming_SOURCES = main.cc globals.h parser.yy scanner.ll timing.cc timing.h
+-drawtiming_LDFLAGS = @MAGICK_LIBS@
++drawtiming_LDADD = @MAGICK_LIBS@
+
+ EXTRA_DIST = parser.h
+ BUILT_SOURCES = parser.h
+--- drawtiming-0.7.1.orig/src/Makefile.in
++++ drawtiming-0.7.1/src/Makefile.in
+@@ -51,7 +51,7 @@
+ am_drawtiming_OBJECTS = main.$(OBJEXT) parser.$(OBJEXT) \
+ scanner.$(OBJEXT) timing.$(OBJEXT)
+ drawtiming_OBJECTS = $(am_drawtiming_OBJECTS)
+-drawtiming_LDADD = $(LDADD)
++drawtiming_LDADD = @MAGICK_LIBS@ $(LDADD)
+ DEFAULT_INCLUDES = -I. -I$(srcdir) -I$(top_builddir)
+ depcomp = $(SHELL) $(top_srcdir)/depcomp
+ am__depfiles_maybe = depfiles
+@@ -159,7 +159,7 @@
+ AM_CXXFLAGS = @MAGICK_CFLAGS@ -DYYDEBUG=1
+ AM_YFLAGS = -d
+ drawtiming_SOURCES = main.cc globals.h parser.yy scanner.ll timing.cc timing.h
+-drawtiming_LDFLAGS = @MAGICK_LIBS@
++drawtiming_LDFLAGS = @LDFLAGS@
+ EXTRA_DIST = parser.h
+ BUILT_SOURCES = parser.h
+ all: $(BUILT_SOURCES)