summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-electronics/gnucap/gnucap-0.35.20091207.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-electronics/gnucap/gnucap-0.35.20091207.ebuild')
-rw-r--r--sci-electronics/gnucap/gnucap-0.35.20091207.ebuild81
1 files changed, 81 insertions, 0 deletions
diff --git a/sci-electronics/gnucap/gnucap-0.35.20091207.ebuild b/sci-electronics/gnucap/gnucap-0.35.20091207.ebuild
new file mode 100644
index 000000000000..19ab60a2a823
--- /dev/null
+++ b/sci-electronics/gnucap/gnucap-0.35.20091207.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+inherit multilib toolchain-funcs
+
+SNAPSHOTDATE="${P##*.}"
+MY_PV="${PN}-${SNAPSHOTDATE:0:4}-${SNAPSHOTDATE:4:2}-${SNAPSHOTDATE:6:2}"
+
+DESCRIPTION="GNUCap is the GNU Circuit Analysis Package"
+SRC_URI="http://www.gnucap.org/devel/${MY_PV}.tar.gz
+ http://www.gnucap.org/devel/${MY_PV}-models-bsim.tar.gz
+ http://www.gnucap.org/devel/${MY_PV}-models-jspice3-2.5.tar.gz
+ http://www.gnucap.org/devel/${MY_PV}-models-ngspice17.tar.gz
+ http://www.gnucap.org/devel/${MY_PV}-models-spice3f5.tar.gz"
+HOMEPAGE="http://www.gnucap.org/"
+
+IUSE="examples"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="amd64 ppc x86"
+
+DEPEND=""
+RDEPEND=""
+
+S="${WORKDIR}/${MY_PV}"
+
+src_prepare() {
+ # No need to install COPYING and INSTALL
+ sed -i \
+ -e 's: COPYING INSTALL::' \
+ -e 's:COPYING history INSTALL:history:' \
+ doc/Makefile.in || die "sed failed"
+
+ if ! use examples ; then
+ sed -i \
+ -e 's:examples modelgen:modelgen:' \
+ Makefile.in || die "sed failed"
+ fi
+
+ sed -i -e 's:CFLAGS = -O2 -g:CPPFLAGS +=:' \
+ -e '/CCFLAGS =/i\CFLAGS += $(CPPFLAGS)' \
+ -e 's:CCFLAGS = $(CFLAGS):CXXFLAGS += $(CPPFLAGS):' \
+ -e 's:LDFLAGS = :LDFLAGS += :' \
+ -e 's:CCFLAGS:CXXFLAGS:' \
+ -e "s:../Gnucap:${S}/src:" \
+ models-*/Make2 || die "sed failed"
+
+ sed -i -e "s:strchr(str2, '|'):const_cast<char*>(strchr(str2, '|')):" \
+ {src,modelgen}/ap_match.cc || die "sed failed"
+
+ tc-export CC CXX
+}
+
+src_compile () {
+ emake || die "Compilation failed"
+ for PLUGIN_DIR in models-* ; do
+ cd "${S}/${PLUGIN_DIR}"
+ emake CC=$(tc-getCC) CCC=$(tc-getCXX) || die "Compilation failed in ${PLUGIN_DIR}"
+ done
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die "Installation failed"
+ insopts -m0755
+ for PLUGIN_DIR in models-* ; do
+ insinto /usr/$(get_libdir)/gnucap/${PLUGIN_DIR}
+ cd "${S}/${PLUGIN_DIR}"
+ for PLUGIN in */*.so ; do
+ newins ${PLUGIN} ${PLUGIN##*/} \
+ || die "Installation of ${PLUGIN_DIR}/${PLUGIN} failed"
+ done
+ done
+}
+
+pkg_postinst() {
+ elog "Documentation for development releases is now available at :"
+ elog " http://wiki.gnucap.org/dokuwiki/doku.php?id=gnucap:manual"
+}