summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMario Haustein <mario.haustein@hrz.tu-chemnitz.de>2023-02-07 18:04:11 +0100
committerSam James <sam@gentoo.org>2023-02-08 04:11:06 +0000
commit91e79c4852d808c79d435ef0afadd4386a1dfb02 (patch)
tree4ae1e4a1872a8701d70fa6a81229300f4ad63748 /sci-geosciences
parentsci-geosciences/grass: add 8.2.1 (diff)
downloadgentoo-91e79c4852d808c79d435ef0afadd4386a1dfb02.tar.gz
gentoo-91e79c4852d808c79d435ef0afadd4386a1dfb02.tar.bz2
gentoo-91e79c4852d808c79d435ef0afadd4386a1dfb02.zip
sci-geosciences/grass: add bzip2 use flag
Bug: https://bugs.gentoo.org/893134 Signed-off-by: Mario Haustein <mario.haustein@hrz.tu-chemnitz.de> Closes: https://github.com/gentoo/gentoo/pull/29333 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-geosciences')
-rw-r--r--sci-geosciences/grass/grass-8.2.1.ebuild4
-rw-r--r--sci-geosciences/grass/grass-9999.ebuild4
2 files changed, 6 insertions, 2 deletions
diff --git a/sci-geosciences/grass/grass-8.2.1.ebuild b/sci-geosciences/grass/grass-8.2.1.ebuild
index 70d3a66f7e30..0b77a9524bf5 100644
--- a/sci-geosciences/grass/grass-8.2.1.ebuild
+++ b/sci-geosciences/grass/grass-8.2.1.ebuild
@@ -36,7 +36,7 @@ else
S="${WORKDIR}/${MY_P}"
fi
-IUSE="blas cxx fftw geos lapack las mysql netcdf nls odbc opencl opengl openmp pdal png postgres readline sqlite threads tiff truetype X zstd"
+IUSE="blas bzip2 cxx fftw geos lapack las mysql netcdf nls odbc opencl opengl openmp pdal png postgres readline sqlite threads tiff truetype X zstd"
REQUIRED_USE="
${PYTHON_REQUIRED_USE}
opengl? ( X )"
@@ -60,6 +60,7 @@ RDEPEND="
virtual/cblas[eselect-ldso(+)]
virtual/blas[eselect-ldso(+)]
)
+ bzip2? ( app-arch/bzip2:= )
fftw? ( sci-libs/fftw:3.0= )
geos? ( sci-libs/geos:= )
lapack? ( virtual/lapack[eselect-ldso(+)] )
@@ -188,6 +189,7 @@ src_configure() {
$(use_with threads pthread)
$(use_with openmp)
$(use_with opencl)
+ $(use_with bzip2 bzlib)
$(use_with pdal pdal "${EPREFIX}"/usr/bin/pdal-config)
$(use_with las liblas "${EPREFIX}"/usr/bin/liblas-config)
$(use_with netcdf netcdf "${EPREFIX}"/usr/bin/nc-config)
diff --git a/sci-geosciences/grass/grass-9999.ebuild b/sci-geosciences/grass/grass-9999.ebuild
index 4c29251814aa..80491b81b91a 100644
--- a/sci-geosciences/grass/grass-9999.ebuild
+++ b/sci-geosciences/grass/grass-9999.ebuild
@@ -36,7 +36,7 @@ else
S="${WORKDIR}/${MY_P}"
fi
-IUSE="blas cxx fftw geos lapack las mysql netcdf nls odbc opencl opengl openmp pdal png postgres readline sqlite threads tiff truetype X zstd"
+IUSE="blas bzip2 cxx fftw geos lapack las mysql netcdf nls odbc opencl opengl openmp pdal png postgres readline sqlite threads tiff truetype X zstd"
REQUIRED_USE="
${PYTHON_REQUIRED_USE}
opengl? ( X )"
@@ -60,6 +60,7 @@ RDEPEND="
virtual/cblas[eselect-ldso(+)]
virtual/blas[eselect-ldso(+)]
)
+ bzip2? ( app-arch/bzip2:= )
fftw? ( sci-libs/fftw:3.0= )
geos? ( sci-libs/geos:= )
lapack? ( virtual/lapack[eselect-ldso(+)] )
@@ -183,6 +184,7 @@ src_configure() {
$(use_with threads pthread)
$(use_with openmp)
$(use_with opencl)
+ $(use_with bzip2 bzlib)
$(use_with pdal pdal "${EPREFIX}"/usr/bin/pdal-config)
$(use_with las liblas "${EPREFIX}"/usr/bin/liblas-config)
$(use_with netcdf netcdf "${EPREFIX}"/usr/bin/nc-config)