summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-libs/libpdb
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-libs/libpdb')
-rw-r--r--sci-libs/libpdb/Manifest1
-rw-r--r--sci-libs/libpdb/files/991112-dynlib.patch12
-rw-r--r--sci-libs/libpdb/files/libpdb-991112-dynlib+flags.patch46
-rw-r--r--sci-libs/libpdb/libpdb-991112-r1.ebuild44
-rw-r--r--sci-libs/libpdb/libpdb-991112.ebuild46
-rw-r--r--sci-libs/libpdb/metadata.xml8
6 files changed, 157 insertions, 0 deletions
diff --git a/sci-libs/libpdb/Manifest b/sci-libs/libpdb/Manifest
new file mode 100644
index 000000000000..be3a7ecfca38
--- /dev/null
+++ b/sci-libs/libpdb/Manifest
@@ -0,0 +1 @@
+DIST libpdb-991112.shar 123895 SHA256 31101a9e6a98a4359241978cb389acc3d0845171209c87e127a7264b21cedcee SHA512 ae356997d11068736bbbd1a57e4e3a28fa54fd396326bc8fea41485186a1c69ce39c7f81195ae65ddc59c017d85dd123614f56f910c8faffd4791fcfd1b064f4 WHIRLPOOL 8017376c127032727b0e115ea240ef084c8a054c4c5be1545152926cb710243e5210a15e191a635df8f7bc6f1fea8422735888b5881efc199176acab85ef2153
diff --git a/sci-libs/libpdb/files/991112-dynlib.patch b/sci-libs/libpdb/files/991112-dynlib.patch
new file mode 100644
index 000000000000..d3e25ce5281c
--- /dev/null
+++ b/sci-libs/libpdb/files/991112-dynlib.patch
@@ -0,0 +1,12 @@
+diff --git a/Makefile b/Makefile
+index 760a427..da2f62d 100644
+--- a/Makefile
++++ b/Makefile
+@@ -29,6 +29,7 @@ install: $(LIBARCH)
+
+ $(LIBARCH): $(OBJS)
+ @echo "Loading $(LIBARCH) ... "
++ $(CC) $(LDFLAGS) -shared -Wl,--soname,libpdb.so.0 -o libpdb.so.0.1 $(OBJS)
+ @ar cru $(LIBARCH) $(OBJS)
+ @$(RANLIB) $(LIBARCH)
+ @echo "done"
diff --git a/sci-libs/libpdb/files/libpdb-991112-dynlib+flags.patch b/sci-libs/libpdb/files/libpdb-991112-dynlib+flags.patch
new file mode 100644
index 000000000000..72048b684a93
--- /dev/null
+++ b/sci-libs/libpdb/files/libpdb-991112-dynlib+flags.patch
@@ -0,0 +1,46 @@
+ Makefile | 17 +++++++++++------
+ 1 file changed, 11 insertions(+), 6 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index 760a427..de7e724 100644
+--- a/Makefile
++++ b/Makefile
+@@ -8,16 +8,16 @@
+ # RANLIB should be ':'
+ #
+ SHELL = /bin/sh
+-RANLIB = :
++#RANLIB = :
+ NOTHING =
+ LINTOPT = -o $(NOTHING)
+
+ OPT = -O -g
+ DEBUG =
+-CFLAGS = $(OPT) $(DEBUG)
++CFLAGS += -fPIC
+ LIBRARY = pdb
+
+-LIBARCH = lib$(LIBRARY).a
++LIBARCH = lib$(LIBRARY)
+ LINTLIB = llib-l$(LIBRARY).ln
+ OBJS = pdb_read.o pdb_sprntf.o pdb_sscanf.o pdb_write.o pdbrun.o ms.o
+ SRCS = pdb_read.c pdb_sprntf.c pdb_sscanf.c pdb_write.c pdbrun.c ms.c
+@@ -27,10 +27,15 @@ all: $(LIBARCH) $(LINTLIB)
+ install: $(LIBARCH)
+ install -F /usr/local/lib $(LIBARCH)
+
+-$(LIBARCH): $(OBJS)
++$(LIBARCH).so: $(OBJS)
++ $(CC) $(LDFLAGS) -shared -Wl,--soname,libpdb.so.0 -o libpdb.so.0.1 $(OBJS)
++ ln -sf libpdb.so.0.1 libpdb.so.0
++ ln -sf libpdb.so.0.1 libpdb.so
++
++$(LIBARCH).a: $(OBJS)
+ @echo "Loading $(LIBARCH) ... "
+- @ar cru $(LIBARCH) $(OBJS)
+- @$(RANLIB) $(LIBARCH)
++ $(AR) cru $@ $(OBJS)
++ $(RANLIB) $@
+ @echo "done"
+
+ $(LINTLIB): $(SRCS) $(HDRS)
diff --git a/sci-libs/libpdb/libpdb-991112-r1.ebuild b/sci-libs/libpdb/libpdb-991112-r1.ebuild
new file mode 100644
index 000000000000..0981f38c68bc
--- /dev/null
+++ b/sci-libs/libpdb/libpdb-991112-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="PDB Record I/O Libraries -- c version"
+HOMEPAGE="http://www.cgl.ucsf.edu/Overview/software.html"
+SRC_URI="mirror://gentoo/${P}.shar"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="static-libs"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ app-arch/sharutils"
+
+S="${WORKDIR}"
+
+src_unpack() {
+ "${EPREFIX}/usr/bin/unshar" "${DISTDIR}"/${A} || die
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-dynlib+flags.patch
+ tc-export CC RANLIB AR
+}
+
+src_compile() {
+ emake ${PN}.so
+ use static-libs && emake ${PN}.a
+}
+
+src_install() {
+ dolib.so ${PN}.so*
+ use static-libs && dolib.a ${PN}.a
+
+ insinto /usr/include/${PN}
+ doins *.h
+}
diff --git a/sci-libs/libpdb/libpdb-991112.ebuild b/sci-libs/libpdb/libpdb-991112.ebuild
new file mode 100644
index 000000000000..9b1ce441b74b
--- /dev/null
+++ b/sci-libs/libpdb/libpdb-991112.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+
+inherit eutils multilib toolchain-funcs
+
+DESCRIPTION="PDB Record I/O Libraries -- c version"
+HOMEPAGE="http://www.cgl.ucsf.edu/Overview/software.html"
+SRC_URI="mirror://gentoo/${P}.shar"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+LICENSE="BSD"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ app-arch/sharutils"
+
+S="${WORKDIR}"/${PN}
+
+src_unpack() {
+ "${EPREFIX}"/usr/bin/unshar "${DISTDIR}"/${A} || die
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PV}-dynlib.patch
+}
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS} -fPIC" \
+ ${PN}.a || die
+}
+
+src_install() {
+ dolib.a ${PN}.a || die
+ dolib.so ${PN}.so.0.1 || die
+ dosym ${PN}.so.0.1 /usr/$(get_libdir)/${PN}.so.0
+ dosym ${PN}.so.0.1 /usr/$(get_libdir)/${PN}.so
+ insinto /usr/include/${PN}
+ doins *.h || die
+}
diff --git a/sci-libs/libpdb/metadata.xml b/sci-libs/libpdb/metadata.xml
new file mode 100644
index 000000000000..210ad0db014c
--- /dev/null
+++ b/sci-libs/libpdb/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci</herd>
+ <maintainer>
+ <email>jlec@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>