summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2020-03-01 08:28:15 -0500
committerMichael Orlitzky <mjo@gentoo.org>2020-03-01 08:58:34 -0500
commit01fa816214124421eb411b4fe0136af92cdc314a (patch)
treef82dbc99bfd324699ded736c69a41cb7b52f1b8a /sci-mathematics
parentapp-eselect/eselect-php: new version 0.9.6. (diff)
downloadgentoo-01fa816214124421eb411b4fe0136af92cdc314a.tar.gz
gentoo-01fa816214124421eb411b4fe0136af92cdc314a.tar.bz2
gentoo-01fa816214124421eb411b4fe0136af92cdc314a.zip
sci-mathematics/gmp-ecm: fix USE=custom-tune.
I overzealously removed the series of steps needed to build gmp-ecm with custom parameters in the -r2. We need to build, find the custom parameters, and then build again to reap the benefits. I left a comment in the ebuild to explain that to other, future mes. Bug: https://bugs.gentoo.org/711078 Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/gmp-ecm/gmp-ecm-7.0.4-r2.ebuild10
1 files changed, 10 insertions, 0 deletions
diff --git a/sci-mathematics/gmp-ecm/gmp-ecm-7.0.4-r2.ebuild b/sci-mathematics/gmp-ecm/gmp-ecm-7.0.4-r2.ebuild
index 62d2aabe95ee..fa9bae778568 100644
--- a/sci-mathematics/gmp-ecm/gmp-ecm-7.0.4-r2.ebuild
+++ b/sci-mathematics/gmp-ecm/gmp-ecm-7.0.4-r2.ebuild
@@ -26,6 +26,16 @@ pkg_pretend() {
use openmp && tc-check-openmp
}
+src_compile() {
+ default
+ if use custom-tune; then
+ # One "emake" was needed to build the library. Now we can find
+ # the best set of parameters, and then run "emake" one more time
+ # to rebuild the library with the custom parameters. See the
+ # project's README or INSTALL-ecm
+ emake ecm-params && emake
+ fi
+}
src_configure() {
econf \
--enable-shared \