summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFrançois Bissey <frp.bissey@gmail.com>2020-06-17 11:25:48 +1200
committerMichael Orlitzky <mjo@gentoo.org>2020-06-16 21:40:14 -0400
commit538c2b0961838fb7ad41b342083e52d61998d33f (patch)
treeb07e410b3fa41fe9f0842b3dd757d30a938ddadc /sci-mathematics
parentsci-mathematics/flint: upstream bump to 2.6.0 (diff)
downloadgentoo-538c2b0961838fb7ad41b342083e52d61998d33f.tar.gz
gentoo-538c2b0961838fb7ad41b342083e52d61998d33f.tar.bz2
gentoo-538c2b0961838fb7ad41b342083e52d61998d33f.zip
sci-mathematics/arb: bump to 2.18.0. Use cmake.
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Closes: https://github.com/gentoo/gentoo/pull/16281 Signed-off-by: François René Pierre Bissey <frp.bissey@gmail.com> Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/arb/Manifest1
-rw-r--r--sci-mathematics/arb/arb-2.18.0.ebuild37
-rw-r--r--sci-mathematics/arb/files/arb-2.18.0-build_type.patch21
-rw-r--r--sci-mathematics/arb/files/arb-2.18.0-multilib-strict.patch20
4 files changed, 79 insertions, 0 deletions
diff --git a/sci-mathematics/arb/Manifest b/sci-mathematics/arb/Manifest
index bb3a8b16eb94..48e0e7b556b8 100644
--- a/sci-mathematics/arb/Manifest
+++ b/sci-mathematics/arb/Manifest
@@ -1 +1,2 @@
DIST arb-2.17.0.tar.gz 1589083 BLAKE2B 68d5b04dca24129ceaec4e05124e35b474157cf1efbb6505121a03058e014cd4eb67b99497dbbafcf62e9e31f9d11c92f749f6e047e6b1513b6c0cc5ef8f22da SHA512 201e0cebbd1c4857d194e5531c76c6e45a478cf6965b836818919adf0fc04f0fe25e16ecd49c62a438876b67f009b872c4f3c774fe35620be0b22c5e08bdb824
+DIST arb-2.18.0.tar.gz 1595610 BLAKE2B be6a7e1a306f91b70383110e1ef6ead1ebd39f7d408c7a2e3031ca4b6fd788133607779d8f8edb3de1f00abe8ac5f21e07f951caecb4d56ada0517af71265d05 SHA512 3db0b2af4fe63fbc505d9b0e1940165f8bb62eec99d83569a1d959144f33b99141afd6c402d10b24407f9fce1853017a4802850f57fca181cf2f58605395fc31
diff --git a/sci-mathematics/arb/arb-2.18.0.ebuild b/sci-mathematics/arb/arb-2.18.0.ebuild
new file mode 100644
index 000000000000..691185c1d346
--- /dev/null
+++ b/sci-mathematics/arb/arb-2.18.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils
+
+DESCRIPTION="C library for arbitrary-precision interval arithmetic"
+HOMEPAGE="https://fredrikj.net/arb/"
+SRC_URI="https://github.com/fredrik-johansson/arb/archive/${PV}.tar.gz -> ${P}.tar.gz"
+IUSE="test"
+
+RESTRICT="!test? ( test )"
+
+LICENSE="GPL-2+"
+SLOT="0/2"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+
+RDEPEND="
+ dev-libs/gmp:0=
+ dev-libs/mpfr:0=
+ >=sci-mathematics/flint-2.5.0:="
+
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.18.0-multilib-strict.patch
+ "${FILESDIR}"/${PN}-2.18.0-build_type.patch
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TESTING="$(usex test)"
+ )
+
+ cmake-utils_src_configure
+}
diff --git a/sci-mathematics/arb/files/arb-2.18.0-build_type.patch b/sci-mathematics/arb/files/arb-2.18.0-build_type.patch
new file mode 100644
index 000000000000..1db7d5f2df42
--- /dev/null
+++ b/sci-mathematics/arb/files/arb-2.18.0-build_type.patch
@@ -0,0 +1,21 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index ec806fe..4101c09 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -19,11 +19,11 @@ endif ()
+ set (BUILD_SHARED_LIBS yes CACHE BOOL "Build shared library or not")
+ set (BUILD_TESTING no CACHE BOOL "Build tests or not")
+
+-if (NOT (CMAKE_BUILD_TYPE STREQUAL "Debug" OR
+- CMAKE_BUILD_TYPE STREQUAL "Release"))
+- message("${CMAKE_BUILD_TYPE}")
+- message(FATAL_ERROR "CMAKE_BUILD_TYPE must be one of: Debug, Release (current value: '${CMAKE_BUILD_TYPE}')")
+-endif ()
++# if (NOT (CMAKE_BUILD_TYPE STREQUAL "Debug" OR
++# CMAKE_BUILD_TYPE STREQUAL "Release"))
++# message("${CMAKE_BUILD_TYPE}")
++# message(FATAL_ERROR "CMAKE_BUILD_TYPE must be one of: Debug, Release (current value: '${CMAKE_BUILD_TYPE}')")
++# endif ()
+
+ if ("${CMAKE_SIZEOF_VOID_P}" STREQUAL "8")
+ set (PLATFORM "x64")
diff --git a/sci-mathematics/arb/files/arb-2.18.0-multilib-strict.patch b/sci-mathematics/arb/files/arb-2.18.0-multilib-strict.patch
new file mode 100644
index 000000000000..e45dec9f3742
--- /dev/null
+++ b/sci-mathematics/arb/files/arb-2.18.0-multilib-strict.patch
@@ -0,0 +1,20 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index ec806fe..d6136a8 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -136,10 +136,12 @@ if(NOT MSVC)
+ target_link_libraries(arb m)
+ endif()
+
++include(GNUInstallDirs)
++
+ install(TARGETS arb
+- RUNTIME DESTINATION bin
+- ARCHIVE DESTINATION lib
+- LIBRARY DESTINATION lib
++ RUNTIME DESTINATION "${CMAKE_INSTALL_FULL_BINDIR}"
++ ARCHIVE DESTINATION "${CMAKE_INSTALL_FULL_LIBDIR}"
++ LIBRARY DESTINATION "${CMAKE_INSTALL_FULL_LIBDIR}"
+ )
+
+ foreach (FOLDER ${FOLDERS})