summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2016-08-09 09:06:37 +0200
committerDavid Seifert <soap@gentoo.org>2016-08-09 09:08:05 +0200
commit8020ccb2e7e25d0ae3fbd2f3ab039538b055e31c (patch)
treed26f3b37ebc38267e4beb505b159b7cefc8149bb /sci-mathematics
parentkde-apps/kgamma -> kde-plasma/kgamma (diff)
downloadgentoo-8020ccb2e7e25d0ae3fbd2f3ab039538b055e31c.tar.gz
gentoo-8020ccb2e7e25d0ae3fbd2f3ab039538b055e31c.tar.bz2
gentoo-8020ccb2e7e25d0ae3fbd2f3ab039538b055e31c.zip
sci-mathematics/octave: Remove automagic dep on media-gfx/graphicsmagick
Gentoo-Bug: 590280 * Explicitly select dependency on the basis of USE="graphicsmagick" vs USE="imagemagick" only. Package-Manager: portage-2.3.0
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/octave/octave-3.6.4-r1.ebuild17
-rw-r--r--sci-mathematics/octave/octave-3.6.4.ebuild17
-rw-r--r--sci-mathematics/octave/octave-3.8.2-r1.ebuild (renamed from sci-mathematics/octave/octave-3.8.2.ebuild)17
-rw-r--r--sci-mathematics/octave/octave-4.0.0-r1.ebuild17
-rw-r--r--sci-mathematics/octave/octave-4.0.0.ebuild17
-rw-r--r--sci-mathematics/octave/octave-4.0.1-r1.ebuild17
-rw-r--r--sci-mathematics/octave/octave-4.0.1.ebuild17
-rw-r--r--sci-mathematics/octave/octave-4.0.2-r2.ebuild (renamed from sci-mathematics/octave/octave-4.0.2-r1.ebuild)17
8 files changed, 56 insertions, 80 deletions
diff --git a/sci-mathematics/octave/octave-3.6.4-r1.ebuild b/sci-mathematics/octave/octave-3.6.4-r1.ebuild
index e698a8ca08ad..3aeefddb4a7c 100644
--- a/sci-mathematics/octave/octave-3.6.4-r1.ebuild
+++ b/sci-mathematics/octave/octave-3.6.4-r1.ebuild
@@ -17,6 +17,7 @@ SRC_URI="mirror://gnu/${PN}/${P}.tar.bz2"
SLOT="0/${PV}"
IUSE="curl doc fftw +glpk gnuplot graphicsmagick hdf5 +imagemagick opengl postscript
+qhull +qrupdate readline +sparse static-libs X zlib"
+REQUIRED_USE="?? ( graphicsmagick imagemagick )"
KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
RDEPEND="
@@ -29,10 +30,8 @@ RDEPEND="
glpk? ( sci-mathematics/glpk )
gnuplot? ( sci-visualization/gnuplot )
hdf5? ( sci-libs/hdf5 )
- imagemagick? (
- graphicsmagick? ( media-gfx/graphicsmagick:=[cxx] )
- !graphicsmagick? ( media-gfx/imagemagick:=[cxx] )
- )
+ graphicsmagick? ( media-gfx/graphicsmagick:=[cxx] )
+ imagemagick? ( media-gfx/imagemagick:=[cxx] )
opengl? (
media-libs/freetype:2
media-libs/fontconfig
@@ -114,12 +113,10 @@ src_configure() {
$(use_with X x)
$(use_with zlib z)
)
- if use imagemagick; then
- if has_version media-gfx/graphicsmagick[cxx]; then
- myeconfargs+=( "--with-magick=GraphicsMagick" )
- else
- myeconfargs+=( "--with-magick=ImageMagick" )
- fi
+ if use graphicsmagick; then
+ myeconfargs+=( "--with-magick=GraphicsMagick" )
+ elif use imagemagick; then
+ myeconfargs+=( "--with-magick=ImageMagick" )
else
myeconfargs+=( "--without-magick" )
fi
diff --git a/sci-mathematics/octave/octave-3.6.4.ebuild b/sci-mathematics/octave/octave-3.6.4.ebuild
index db636ad50e32..f25a0fdee2c2 100644
--- a/sci-mathematics/octave/octave-3.6.4.ebuild
+++ b/sci-mathematics/octave/octave-3.6.4.ebuild
@@ -17,6 +17,7 @@ SRC_URI="mirror://gnu/${PN}/${P}.tar.bz2"
SLOT="0/${PV}"
IUSE="curl doc fftw +glpk gnuplot graphicsmagick hdf5 +imagemagick opengl postscript
+qhull +qrupdate readline +sparse static-libs X zlib"
+REQUIRED_USE="?? ( graphicsmagick imagemagick )"
KEYWORDS="amd64 ~arm hppa ppc ppc64 x86 ~x86-fbsd ~amd64-linux ~x86-linux"
RDEPEND="
@@ -29,10 +30,8 @@ RDEPEND="
glpk? ( sci-mathematics/glpk )
gnuplot? ( sci-visualization/gnuplot )
hdf5? ( sci-libs/hdf5 )
- imagemagick? (
- graphicsmagick? ( media-gfx/graphicsmagick:=[cxx] )
- !graphicsmagick? ( media-gfx/imagemagick:=[cxx] )
- )
+ graphicsmagick? ( media-gfx/graphicsmagick:=[cxx] )
+ imagemagick? ( media-gfx/imagemagick:=[cxx] )
opengl? (
media-libs/freetype:2
media-libs/fontconfig
@@ -112,12 +111,10 @@ src_configure() {
$(use_with X x)
$(use_with zlib z)
)
- if use imagemagick; then
- if has_version media-gfx/graphicsmagick[cxx]; then
- myeconfargs+=( "--with-magick=GraphicsMagick" )
- else
- myeconfargs+=( "--with-magick=ImageMagick" )
- fi
+ if use graphicsmagick; then
+ myeconfargs+=( "--with-magick=GraphicsMagick" )
+ elif use imagemagick; then
+ myeconfargs+=( "--with-magick=ImageMagick" )
else
myeconfargs+=( "--without-magick" )
fi
diff --git a/sci-mathematics/octave/octave-3.8.2.ebuild b/sci-mathematics/octave/octave-3.8.2-r1.ebuild
index 35bfd1114b45..186c802c54f3 100644
--- a/sci-mathematics/octave/octave-3.8.2.ebuild
+++ b/sci-mathematics/octave/octave-3.8.2-r1.ebuild
@@ -17,6 +17,7 @@ SRC_URI="mirror://gnu/${PN}/${P}.tar.bz2"
SLOT="0/${PV}"
IUSE="curl doc fftw +glpk gnuplot graphicsmagick gui hdf5 +imagemagick java opengl
postscript +qhull +qrupdate readline +sparse static-libs X zlib"
+REQUIRED_USE="?? ( graphicsmagick imagemagick )"
KEYWORDS="amd64 ~arm hppa ppc ppc64 x86 ~x86-fbsd ~amd64-linux ~x86-linux"
RDEPEND="
@@ -30,10 +31,8 @@ RDEPEND="
gnuplot? ( sci-visualization/gnuplot )
gui? ( x11-libs/qscintilla:0= )
hdf5? ( sci-libs/hdf5:0= )
- imagemagick? (
- graphicsmagick? ( media-gfx/graphicsmagick:=[cxx] )
- !graphicsmagick? ( media-gfx/imagemagick:=[cxx] )
- )
+ graphicsmagick? ( media-gfx/graphicsmagick:=[cxx] )
+ imagemagick? ( media-gfx/imagemagick:=[cxx] )
java? ( >=virtual/jre-1.6.0:* )
opengl? (
media-libs/freetype:2=
@@ -130,12 +129,10 @@ src_configure() {
$(use_with X x)
$(use_with zlib z)
)
- if use imagemagick; then
- if has_version media-gfx/graphicsmagick[cxx]; then
- myeconfargs+=( "--with-magick=GraphicsMagick" )
- else
- myeconfargs+=( "--with-magick=ImageMagick" )
- fi
+ if use graphicsmagick; then
+ myeconfargs+=( "--with-magick=GraphicsMagick" )
+ elif use imagemagick; then
+ myeconfargs+=( "--with-magick=ImageMagick" )
else
myeconfargs+=( "--without-magick" )
fi
diff --git a/sci-mathematics/octave/octave-4.0.0-r1.ebuild b/sci-mathematics/octave/octave-4.0.0-r1.ebuild
index 2a99d8be9dfe..4aa4db278af2 100644
--- a/sci-mathematics/octave/octave-4.0.0-r1.ebuild
+++ b/sci-mathematics/octave/octave-4.0.0-r1.ebuild
@@ -17,6 +17,7 @@ SRC_URI="mirror://gnu/${PN}/${P}.tar.xz"
SLOT="0/${PV}"
IUSE="curl doc fftw +glpk gnuplot graphicsmagick gui hdf5 +imagemagick java jit opengl
postscript +qhull +qrupdate readline +sparse static-libs X zlib"
+REQUIRED_USE="?? ( graphicsmagick imagemagick )"
KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
RDEPEND="
@@ -31,10 +32,8 @@ RDEPEND="
gnuplot? ( sci-visualization/gnuplot )
gui? ( x11-libs/qscintilla:0= )
hdf5? ( sci-libs/hdf5:0= )
- imagemagick? (
- graphicsmagick? ( media-gfx/graphicsmagick:=[cxx] )
- !graphicsmagick? ( media-gfx/imagemagick:=[cxx] )
- )
+ graphicsmagick? ( media-gfx/graphicsmagick:=[cxx] )
+ imagemagick? ( media-gfx/imagemagick:=[cxx] )
java? ( >=virtual/jre-1.6.0:* )
jit? (
>=sys-devel/autoconf-archive-2015.02.04
@@ -145,12 +144,10 @@ src_configure() {
$(use_with X x)
$(use_with zlib z)
)
- if use imagemagick; then
- if has_version media-gfx/graphicsmagick[cxx]; then
- myeconfargs+=( "--with-magick=GraphicsMagick" )
- else
- myeconfargs+=( "--with-magick=ImageMagick" )
- fi
+ if use graphicsmagick; then
+ myeconfargs+=( "--with-magick=GraphicsMagick" )
+ elif use imagemagick; then
+ myeconfargs+=( "--with-magick=ImageMagick" )
else
myeconfargs+=( "--without-magick" )
fi
diff --git a/sci-mathematics/octave/octave-4.0.0.ebuild b/sci-mathematics/octave/octave-4.0.0.ebuild
index 459bec9efa3f..a90d8000ce2a 100644
--- a/sci-mathematics/octave/octave-4.0.0.ebuild
+++ b/sci-mathematics/octave/octave-4.0.0.ebuild
@@ -17,6 +17,7 @@ SRC_URI="mirror://gnu/${PN}/${P}.tar.xz"
SLOT="0/${PV}"
IUSE="curl doc fftw +glpk gnuplot graphicsmagick gui hdf5 +imagemagick java jit opengl
postscript +qhull +qrupdate readline +sparse static-libs X zlib"
+REQUIRED_USE="?? ( graphicsmagick imagemagick )"
KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
RDEPEND="
@@ -31,10 +32,8 @@ RDEPEND="
gnuplot? ( sci-visualization/gnuplot )
gui? ( x11-libs/qscintilla:0= )
hdf5? ( sci-libs/hdf5:0= )
- imagemagick? (
- graphicsmagick? ( media-gfx/graphicsmagick:=[cxx] )
- !graphicsmagick? ( media-gfx/imagemagick:=[cxx] )
- )
+ graphicsmagick? ( media-gfx/graphicsmagick:=[cxx] )
+ imagemagick? ( media-gfx/imagemagick:=[cxx] )
java? ( >=virtual/jre-1.6.0:* )
jit? (
>=sys-devel/autoconf-archive-2015.02.04
@@ -140,12 +139,10 @@ src_configure() {
$(use_with X x)
$(use_with zlib z)
)
- if use imagemagick; then
- if has_version media-gfx/graphicsmagick[cxx]; then
- myeconfargs+=( "--with-magick=GraphicsMagick" )
- else
- myeconfargs+=( "--with-magick=ImageMagick" )
- fi
+ if use graphicsmagick; then
+ myeconfargs+=( "--with-magick=GraphicsMagick" )
+ elif use imagemagick; then
+ myeconfargs+=( "--with-magick=ImageMagick" )
else
myeconfargs+=( "--without-magick" )
fi
diff --git a/sci-mathematics/octave/octave-4.0.1-r1.ebuild b/sci-mathematics/octave/octave-4.0.1-r1.ebuild
index 17c05636c2d8..279abf2fb37d 100644
--- a/sci-mathematics/octave/octave-4.0.1-r1.ebuild
+++ b/sci-mathematics/octave/octave-4.0.1-r1.ebuild
@@ -17,6 +17,7 @@ SRC_URI="mirror://gnu/${PN}/${P}.tar.xz"
SLOT="0/${PV}"
IUSE="curl doc fftw +glpk gnuplot graphicsmagick gui hdf5 +imagemagick java jit opengl
postscript +qhull +qrupdate readline +sparse static-libs X zlib"
+REQUIRED_USE="?? ( graphicsmagick imagemagick )"
KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
RDEPEND="
@@ -31,10 +32,8 @@ RDEPEND="
gnuplot? ( sci-visualization/gnuplot )
gui? ( x11-libs/qscintilla:0= )
hdf5? ( sci-libs/hdf5:0= )
- imagemagick? (
- graphicsmagick? ( media-gfx/graphicsmagick:=[cxx] )
- !graphicsmagick? ( media-gfx/imagemagick:=[cxx] )
- )
+ graphicsmagick? ( media-gfx/graphicsmagick:=[cxx] )
+ imagemagick? ( media-gfx/imagemagick:=[cxx] )
java? ( >=virtual/jre-1.6.0:* )
jit? (
>=sys-devel/autoconf-archive-2015.02.04
@@ -140,12 +139,10 @@ src_configure() {
$(use_with X x)
$(use_with zlib z)
)
- if use imagemagick; then
- if has_version media-gfx/graphicsmagick[cxx]; then
- myeconfargs+=( "--with-magick=GraphicsMagick" )
- else
- myeconfargs+=( "--with-magick=ImageMagick" )
- fi
+ if use graphicsmagick; then
+ myeconfargs+=( "--with-magick=GraphicsMagick" )
+ elif use imagemagick; then
+ myeconfargs+=( "--with-magick=ImageMagick" )
else
myeconfargs+=( "--without-magick" )
fi
diff --git a/sci-mathematics/octave/octave-4.0.1.ebuild b/sci-mathematics/octave/octave-4.0.1.ebuild
index 459bec9efa3f..a90d8000ce2a 100644
--- a/sci-mathematics/octave/octave-4.0.1.ebuild
+++ b/sci-mathematics/octave/octave-4.0.1.ebuild
@@ -17,6 +17,7 @@ SRC_URI="mirror://gnu/${PN}/${P}.tar.xz"
SLOT="0/${PV}"
IUSE="curl doc fftw +glpk gnuplot graphicsmagick gui hdf5 +imagemagick java jit opengl
postscript +qhull +qrupdate readline +sparse static-libs X zlib"
+REQUIRED_USE="?? ( graphicsmagick imagemagick )"
KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
RDEPEND="
@@ -31,10 +32,8 @@ RDEPEND="
gnuplot? ( sci-visualization/gnuplot )
gui? ( x11-libs/qscintilla:0= )
hdf5? ( sci-libs/hdf5:0= )
- imagemagick? (
- graphicsmagick? ( media-gfx/graphicsmagick:=[cxx] )
- !graphicsmagick? ( media-gfx/imagemagick:=[cxx] )
- )
+ graphicsmagick? ( media-gfx/graphicsmagick:=[cxx] )
+ imagemagick? ( media-gfx/imagemagick:=[cxx] )
java? ( >=virtual/jre-1.6.0:* )
jit? (
>=sys-devel/autoconf-archive-2015.02.04
@@ -140,12 +139,10 @@ src_configure() {
$(use_with X x)
$(use_with zlib z)
)
- if use imagemagick; then
- if has_version media-gfx/graphicsmagick[cxx]; then
- myeconfargs+=( "--with-magick=GraphicsMagick" )
- else
- myeconfargs+=( "--with-magick=ImageMagick" )
- fi
+ if use graphicsmagick; then
+ myeconfargs+=( "--with-magick=GraphicsMagick" )
+ elif use imagemagick; then
+ myeconfargs+=( "--with-magick=ImageMagick" )
else
myeconfargs+=( "--without-magick" )
fi
diff --git a/sci-mathematics/octave/octave-4.0.2-r1.ebuild b/sci-mathematics/octave/octave-4.0.2-r2.ebuild
index 17c05636c2d8..279abf2fb37d 100644
--- a/sci-mathematics/octave/octave-4.0.2-r1.ebuild
+++ b/sci-mathematics/octave/octave-4.0.2-r2.ebuild
@@ -17,6 +17,7 @@ SRC_URI="mirror://gnu/${PN}/${P}.tar.xz"
SLOT="0/${PV}"
IUSE="curl doc fftw +glpk gnuplot graphicsmagick gui hdf5 +imagemagick java jit opengl
postscript +qhull +qrupdate readline +sparse static-libs X zlib"
+REQUIRED_USE="?? ( graphicsmagick imagemagick )"
KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
RDEPEND="
@@ -31,10 +32,8 @@ RDEPEND="
gnuplot? ( sci-visualization/gnuplot )
gui? ( x11-libs/qscintilla:0= )
hdf5? ( sci-libs/hdf5:0= )
- imagemagick? (
- graphicsmagick? ( media-gfx/graphicsmagick:=[cxx] )
- !graphicsmagick? ( media-gfx/imagemagick:=[cxx] )
- )
+ graphicsmagick? ( media-gfx/graphicsmagick:=[cxx] )
+ imagemagick? ( media-gfx/imagemagick:=[cxx] )
java? ( >=virtual/jre-1.6.0:* )
jit? (
>=sys-devel/autoconf-archive-2015.02.04
@@ -140,12 +139,10 @@ src_configure() {
$(use_with X x)
$(use_with zlib z)
)
- if use imagemagick; then
- if has_version media-gfx/graphicsmagick[cxx]; then
- myeconfargs+=( "--with-magick=GraphicsMagick" )
- else
- myeconfargs+=( "--with-magick=ImageMagick" )
- fi
+ if use graphicsmagick; then
+ myeconfargs+=( "--with-magick=GraphicsMagick" )
+ elif use imagemagick; then
+ myeconfargs+=( "--with-magick=ImageMagick" )
else
myeconfargs+=( "--without-magick" )
fi