summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2018-05-16 11:36:25 +0200
committerLars Wendler <polynomial-c@gentoo.org>2018-05-16 11:38:32 +0200
commitcf063984cc7b2efb34e61c56a15b53362e7e277d (patch)
tree721feefa9906f4a0c679075e2d05e2d7f620117c /sys-apps/less/less-531.ebuild
parentpackage.mask: Update dev-util/scons-3.0.1-r2 mask (diff)
downloadgentoo-cf063984cc7b2efb34e61c56a15b53362e7e277d.tar.gz
gentoo-cf063984cc7b2efb34e61c56a15b53362e7e277d.tar.bz2
gentoo-cf063984cc7b2efb34e61c56a15b53362e7e277d.zip
sys-apps/less: Bump to version 531
Bug: https://bugs.gentoo.org/646884 Package-Manager: Portage-2.3.36, Repoman-2.3.9
Diffstat (limited to 'sys-apps/less/less-531.ebuild')
-rw-r--r--sys-apps/less/less-531.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/sys-apps/less/less-531.ebuild b/sys-apps/less/less-531.ebuild
new file mode 100644
index 000000000000..6509cbbb85e3
--- /dev/null
+++ b/sys-apps/less/less-531.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Excellent text file viewer"
+HOMEPAGE="http://www.greenwoodsoftware.com/less/"
+SRC_URI="http://www.greenwoodsoftware.com/less/${P}.tar.gz"
+
+LICENSE="|| ( GPL-3 BSD-2 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="pcre unicode"
+
+DEPEND=">=app-misc/editor-wrapper-3
+ >=sys-libs/ncurses-5.2:0=
+ pcre? ( dev-libs/libpcre )"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ export ac_cv_lib_ncursesw_initscr=$(usex unicode)
+ export ac_cv_lib_ncurses_initscr=$(usex !unicode)
+ local myeconfargs=(
+ --with-regex=$(usex pcre pcre posix)
+ --with-editor="${EPREFIX}"/usr/libexec/editor
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ newbin "${FILESDIR}"/lesspipe.sh lesspipe
+ newenvd "${FILESDIR}"/less.envd 70less
+}
+
+pkg_preinst() {
+ if has_version "<${CATEGORY}/${PN}-483-r1" ; then
+ elog "The lesspipe.sh symlink has been dropped. If you are still setting"
+ elog "LESSOPEN to that, you will need to update it to '|lesspipe %s'."
+ elog "Colorization support has been dropped. If you want that, check out"
+ elog "the new app-text/lesspipe package."
+ fi
+}