summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-apps/vbetool
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-apps/vbetool')
-rw-r--r--sys-apps/vbetool/Manifest1
-rw-r--r--sys-apps/vbetool/files/vbetool-1.0-build.patch18
-rw-r--r--sys-apps/vbetool/metadata.xml8
-rw-r--r--sys-apps/vbetool/vbetool-1.1.ebuild31
4 files changed, 58 insertions, 0 deletions
diff --git a/sys-apps/vbetool/Manifest b/sys-apps/vbetool/Manifest
new file mode 100644
index 000000000000..a2f0cdf04bae
--- /dev/null
+++ b/sys-apps/vbetool/Manifest
@@ -0,0 +1 @@
+DIST vbetool-1.1.tar.gz 182826 SHA256 4d26ddc43144593742349e69481e3536ce3482faaa9ad4494fdc7c8b7662f954 SHA512 09d8713516f074fe8e901ab3e24aba7e8b9ddf459b3ee3394b7604e4489a70a27c6dc3604cf1284c49233dba908f00da746c583562af2bc93b6df8ff413efd96 WHIRLPOOL 9b6d6b616c0b074e49c80291e48e2c951e83a2981780cf942ca535f2909e7e83a0d7cf1f9efdc6cea779a5db688635bb7a3740c3bd77a80a268776dea9b1d147
diff --git a/sys-apps/vbetool/files/vbetool-1.0-build.patch b/sys-apps/vbetool/files/vbetool-1.0-build.patch
new file mode 100644
index 000000000000..69d2f7b341ba
--- /dev/null
+++ b/sys-apps/vbetool/files/vbetool-1.0-build.patch
@@ -0,0 +1,18 @@
+Index: vbetool-1.0/Makefile.am
+===================================================================
+--- vbetool-1.0.orig/Makefile.am
++++ vbetool-1.0/Makefile.am
+@@ -2,7 +2,7 @@ AUTOMAKE_OPTIONS = foreign
+
+ sbin_PROGRAMS = vbetool
+
+-vbetool_LDADD = $(libdir)/libpci.a
++vbetool_LDADD = -lpci -lz -lx86
+
+ man_MANS = vbetool.1
+ vbetool_SOURCES = vbetool.c $(x86)
+@@ -14,4 +14,3 @@ maintainer-clean-local:
+ $(RM) Makefile.in aclocal.m4 config.h.in stamp-h.in configure
+
+ AM_CFLAGS = -g -Wall -pedantic -std=gnu99
+-AM_LDFLAGS = -lz -lx86
diff --git a/sys-apps/vbetool/metadata.xml b/sys-apps/vbetool/metadata.xml
new file mode 100644
index 000000000000..ad3f22a0b39f
--- /dev/null
+++ b/sys-apps/vbetool/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>x11</herd>
+<maintainer>
+ <email>robbat2@gentoo.org</email>
+</maintainer>
+</pkgmetadata>
diff --git a/sys-apps/vbetool/vbetool-1.1.ebuild b/sys-apps/vbetool/vbetool-1.1.ebuild
new file mode 100644
index 000000000000..b201b640ff97
--- /dev/null
+++ b/sys-apps/vbetool/vbetool-1.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit eutils autotools
+
+DESCRIPTION="Run real-mode video BIOS code to alter hardware state (i.e. reinitialize video card)"
+HOMEPAGE="http://www.codon.org.uk/~mjg59/vbetool/"
+SRC_URI="http://www.codon.org.uk/~mjg59/vbetool/download/vbetool-1.1.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="sys-libs/zlib
+ sys-apps/pciutils
+ >=dev-libs/libx86-1.1-r1"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.0-build.patch
+ eaclocal # temp fix for #439614
+ eautoreconf
+}
+
+src_configure() {
+ econf --with-x86emu
+}