summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetr Vaněk <arkamar@atlas.cz>2022-03-08 15:52:12 +0100
committerJoonas Niilola <juippis@gentoo.org>2022-03-11 10:31:02 +0200
commit502228a9e053ae6cc554ff676abd278e2c18f53d (patch)
tree4cbc22d76c54f4ffc6f91783a72dc29061751ac8 /sys-apps
parentsys-apps/s6: add 2.11.1.0 (diff)
downloadgentoo-502228a9e053ae6cc554ff676abd278e2c18f53d.tar.gz
gentoo-502228a9e053ae6cc554ff676abd278e2c18f53d.tar.bz2
gentoo-502228a9e053ae6cc554ff676abd278e2c18f53d.zip
sys-apps/s6-portable-utils: add 2.2.4.0
Signed-off-by: Petr Vaněk <arkamar@atlas.cz> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/s6-portable-utils/Manifest1
-rw-r--r--sys-apps/s6-portable-utils/s6-portable-utils-2.2.4.0.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/sys-apps/s6-portable-utils/Manifest b/sys-apps/s6-portable-utils/Manifest
index 151ad8fc7367..91b1bd4d0ead 100644
--- a/sys-apps/s6-portable-utils/Manifest
+++ b/sys-apps/s6-portable-utils/Manifest
@@ -1,2 +1,3 @@
DIST s6-portable-utils-2.2.3.0.tar.gz 49239 BLAKE2B 3be6d6f7b92eea4fb67e3e52ced4409d2bc04c7bb23fea146d778b3739b4682f10dcd2f58cc37a7760368a645d0fa50c887445e6006a563d290c739e72634e9f SHA512 17cb58a49494bba323f031aa07db134505a0884827745ea48e4e93d1ea70b9d4dd141d065b126abb40d5c7625cbb03ba71090e66fd0adb0c54ab49478e929837
DIST s6-portable-utils-2.2.3.4.tar.gz 50120 BLAKE2B 17eecbf432b91720ed672e0388665e3dd7302fa2638225d0cdb9ad3c580fa29734ebf5f6e838e1bc4fdcec841ac4414d5b13d78ccb9167f5fad18dc763d8f611 SHA512 1bb9f7bd1c00d12d8434dbabb7061fe589ee9de9f0745399aacf560712bb0c9b4df2dbc221b0c8144c351e9976982c7a7e69dd127517281799d810596d8db5a2
+DIST s6-portable-utils-2.2.4.0.tar.gz 50343 BLAKE2B edfbe4ab48914ae485072f220931e6af4d53fc8d1c1dc5e1186bc1688a429e6d14a370b02dbe0a9b641a8204f65e6f6bfb6cb0c0c9318acf89d9f6ad7f7f914f SHA512 35b62aff76b9fbf978e81dad2f343a2542cb4a853530948cc3b446b20e8d5f976d1624194c2aad6e0277b73d23d5cecf2142e3f2916bd152ad62342fc30fe07a
diff --git a/sys-apps/s6-portable-utils/s6-portable-utils-2.2.4.0.ebuild b/sys-apps/s6-portable-utils/s6-portable-utils-2.2.4.0.ebuild
new file mode 100644
index 000000000000..5defe8187bb3
--- /dev/null
+++ b/sys-apps/s6-portable-utils/s6-portable-utils-2.2.4.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Set of tiny portable unix utilities"
+HOMEPAGE="https://www.skarnet.org/software/s6-portable-utils/"
+SRC_URI="https://www.skarnet.org/software/${PN}/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="static"
+
+RDEPEND="!static? ( >=dev-libs/skalibs-2.11.2.0:= )"
+DEPEND="${RDEPEND}
+ static? ( >=dev-libs/skalibs-2.11.2.0[static-libs] )
+"
+
+HTML_DOCS=( doc/. )
+
+src_prepare() {
+ default
+
+ # Avoid QA warning for LDFLAGS addition
+ sed -i -e 's/.*-Wl,--hash-style=both$/:/' configure || die
+
+ sed -i -e '/AR := /d' -e '/RANLIB := /d' Makefile || die
+}
+
+src_configure() {
+ tc-export AR CC RANLIB
+
+ local myconf=(
+ --bindir=/bin
+ --dynlibdir=/usr/$(get_libdir)
+ --libdir=/usr/$(get_libdir)/${PN}
+ --with-dynlib=/usr/$(get_libdir)
+ --with-lib=/usr/$(get_libdir)/skalibs
+ --with-sysdeps=/usr/$(get_libdir)/skalibs
+ $(use_enable static allstatic)
+ $(use_enable static static-libc)
+ )
+
+ econf "${myconf[@]}"
+}