summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2020-02-07 11:54:31 -0500
committerMike Gilbert <floppym@gentoo.org>2020-02-07 11:54:31 -0500
commit7b8bdcde438406d25255b1565b035a51f27aea00 (patch)
treee02374c2c3bbb72a0e85df1d917cc407350db204 /sys-apps
parentsys-apps/systemd: define python_check_deps (diff)
downloadgentoo-7b8bdcde438406d25255b1565b035a51f27aea00.tar.gz
gentoo-7b8bdcde438406d25255b1565b035a51f27aea00.tar.bz2
gentoo-7b8bdcde438406d25255b1565b035a51f27aea00.zip
sys-apps/coreutils: define python_check_deps
Closes: https://bugs.gentoo.org/708588 Package-Manager: Portage-2.3.86_p1, Repoman-2.3.20_p43 Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/coreutils/coreutils-8.30.ebuild6
-rw-r--r--sys-apps/coreutils/coreutils-8.31-r1.ebuild6
-rw-r--r--sys-apps/coreutils/coreutils-8.31.ebuild6
3 files changed, 18 insertions, 0 deletions
diff --git a/sys-apps/coreutils/coreutils-8.30.ebuild b/sys-apps/coreutils/coreutils-8.30.ebuild
index 91ea2d3a06db..6c40cc430002 100644
--- a/sys-apps/coreutils/coreutils-8.30.ebuild
+++ b/sys-apps/coreutils/coreutils-8.30.ebuild
@@ -54,6 +54,12 @@ RDEPEND+="
!<app-forensics/tct-1.18-r1
!<net-fs/netatalk-2.0.3-r4"
+python_check_deps() {
+ if use test; then
+ has_version --host-root "dev-python/pyinotify[${PYTHON_USEDEP}]"
+ fi
+}
+
pkg_setup() {
if use test ; then
python-any-r1_pkg_setup
diff --git a/sys-apps/coreutils/coreutils-8.31-r1.ebuild b/sys-apps/coreutils/coreutils-8.31-r1.ebuild
index 643aa3aeeca6..5860f7daa1b5 100644
--- a/sys-apps/coreutils/coreutils-8.31-r1.ebuild
+++ b/sys-apps/coreutils/coreutils-8.31-r1.ebuild
@@ -52,6 +52,12 @@ RDEPEND+="
!<app-forensics/tct-1.18-r1
!<net-fs/netatalk-2.0.3-r4"
+python_check_deps() {
+ if use test; then
+ has_version --host-root "dev-python/pyinotify[${PYTHON_USEDEP}]"
+ fi
+}
+
pkg_setup() {
if use test ; then
python-any-r1_pkg_setup
diff --git a/sys-apps/coreutils/coreutils-8.31.ebuild b/sys-apps/coreutils/coreutils-8.31.ebuild
index 565e641c8b48..eb8a90e46999 100644
--- a/sys-apps/coreutils/coreutils-8.31.ebuild
+++ b/sys-apps/coreutils/coreutils-8.31.ebuild
@@ -54,6 +54,12 @@ RDEPEND+="
!<app-forensics/tct-1.18-r1
!<net-fs/netatalk-2.0.3-r4"
+python_check_deps() {
+ if use test; then
+ has_version --host-root "dev-python/pyinotify[${PYTHON_USEDEP}]"
+ fi
+}
+
pkg_setup() {
if use test ; then
python-any-r1_pkg_setup