summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonas Stein <jstein@gentoo.org>2017-05-30 18:30:35 +0200
committerPatrice Clement <monsieurp@gentoo.org>2017-06-30 15:17:49 +0200
commitce09039315a772516a19c3b24c7e974460b6d4ef (patch)
tree71e0d6cd0cc1365ff61de93188d00d3d5a059b3c /sys-apps
parentapp-misc/geoclue: EAPI 6 bump and version bump to 2.4.7. (diff)
downloadgentoo-ce09039315a772516a19c3b24c7e974460b6d4ef.tar.gz
gentoo-ce09039315a772516a19c3b24c7e974460b6d4ef.tar.bz2
gentoo-ce09039315a772516a19c3b24c7e974460b6d4ef.zip
sys-apps/inxi: unpack before doman.
Gentoo-Bug: https://bugs.gentoo.org/619970 * unpack manpage before doman * general ebuild upkeep Closes: https://github.com/gentoo/gentoo/pull/4811
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/inxi/inxi-2.3.0_p20160807-r1.ebuild28
-rw-r--r--sys-apps/inxi/inxi-2.3.0_p20160807.ebuild36
-rw-r--r--sys-apps/inxi/inxi-2.3.4_p20161104-r1.ebuild28
-rw-r--r--sys-apps/inxi/inxi-2.3.4_p20161104.ebuild36
4 files changed, 56 insertions, 72 deletions
diff --git a/sys-apps/inxi/inxi-2.3.0_p20160807-r1.ebuild b/sys-apps/inxi/inxi-2.3.0_p20160807-r1.ebuild
new file mode 100644
index 000000000000..09afef734064
--- /dev/null
+++ b/sys-apps/inxi/inxi-2.3.0_p20160807-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_COMMIT=c2a22b3e2590d896d4b0a8fd298f505cc1d787f5 #because upstream refuses to tag commits with version numbers
+
+DESCRIPTION="The CLI inxi collects and prints hardware and system information"
+HOMEPAGE="https://github.com/smxi/inxi"
+SRC_URI="https://github.com/smxi/${PN}/tarball/${MY_COMMIT} -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=">=app-shells/bash-3.0
+ sys-apps/pciutils
+ sys-apps/usbutils
+ "
+S="${WORKDIR}/smxi-${PN}-${MY_COMMIT:0:7}"
+
+src_install() {
+ dobin "${PN}"
+ unpack "./${PN}.1.gz"
+ doman "${PN}.1"
+}
diff --git a/sys-apps/inxi/inxi-2.3.0_p20160807.ebuild b/sys-apps/inxi/inxi-2.3.0_p20160807.ebuild
deleted file mode 100644
index 6a87c6104e2a..000000000000
--- a/sys-apps/inxi/inxi-2.3.0_p20160807.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-MY_COMMIT=c2a22b3e2590d896d4b0a8fd298f505cc1d787f5 #because upstream refuses to tag commits with version numbers
-MY_SHORTCOMMIT=${MY_COMMIT:0:7}
-
-DESCRIPTION="Commandline script to print hardware information for irc and administration."
-
-HOMEPAGE="https://github.com/smxi/inxi"
-SRC_URI="https://github.com/smxi/${PN}/tarball/${MY_COMMIT} -> ${P}.tar.gz"
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~x86"
-IUSE=""
-
-DEPEND=""
-RDEPEND=">=app-shells/bash-3.0
- sys-apps/pciutils
- "
-
-S="${WORKDIR}/smxi-${PN}-${MY_SHORTCOMMIT}"
-
-src_install() {
- dobin ${PN}
- doman ${PN}.1.gz
-}
-
-pkg_postinst() {
- einfo "To view a short or full system information."
- einfo "inxi -b for short information."
- einfo "inxi -F for full information."
- einfo "inxi provides seven verbose levels -v1 to -v7."
- einfo "inxi -h for help."
-}
diff --git a/sys-apps/inxi/inxi-2.3.4_p20161104-r1.ebuild b/sys-apps/inxi/inxi-2.3.4_p20161104-r1.ebuild
new file mode 100644
index 000000000000..619a8b5cb19b
--- /dev/null
+++ b/sys-apps/inxi/inxi-2.3.4_p20161104-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_COMMIT=89e18d245bc34fc5be5f5baddac2ccd8106be050 #because upstream refuses to tag commits with version numbers
+
+DESCRIPTION="The CLI inxi collects and prints hardware and system information"
+HOMEPAGE="https://github.com/smxi/inxi"
+SRC_URI="https://github.com/smxi/${PN}/tarball/${MY_COMMIT} -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=">=app-shells/bash-3.0
+ sys-apps/pciutils
+ sys-apps/usbutils
+ "
+S="${WORKDIR}/smxi-${PN}-${MY_COMMIT:0:7}"
+
+src_install() {
+ dobin "${PN}"
+ unpack "./${PN}.1.gz"
+ doman "${PN}.1"
+}
diff --git a/sys-apps/inxi/inxi-2.3.4_p20161104.ebuild b/sys-apps/inxi/inxi-2.3.4_p20161104.ebuild
deleted file mode 100644
index ed3ef560c079..000000000000
--- a/sys-apps/inxi/inxi-2.3.4_p20161104.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-MY_COMMIT=89e18d245bc34fc5be5f5baddac2ccd8106be050 #because upstream refuses to tag commits with version numbers
-MY_SHORTCOMMIT=${MY_COMMIT:0:7}
-
-DESCRIPTION="Commandline script to print hardware information for irc and administration"
-
-HOMEPAGE="https://github.com/smxi/inxi"
-SRC_URI="https://github.com/smxi/${PN}/tarball/${MY_COMMIT} -> ${P}.tar.gz"
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~x86"
-IUSE=""
-
-DEPEND=""
-RDEPEND=">=app-shells/bash-3.0
- sys-apps/pciutils
- "
-
-S="${WORKDIR}/smxi-${PN}-${MY_SHORTCOMMIT}"
-
-src_install() {
- dobin "${PN}"
- doman "${PN}.1.gz"
-}
-
-pkg_postinst() {
- einfo "To view a short or full system information:"
- einfo " inxi -b for short information."
- einfo " inxi -F for full information."
- einfo "inxi provides seven verbose levels -v1 to -v7."
- einfo "Type inxi -h for help."
-}