summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2018-05-16 21:15:49 +0300
committerAlon Bar-Lev <alonbl@gentoo.org>2018-05-16 21:15:49 +0300
commit8c524aadb2c964ca60743e93bcd098d09dcfbf65 (patch)
treef00e1455d09f2f10478fcfc0f0a3aaa899b5d93f /sys-auth/pam_p11/pam_p11-0.2.0.ebuild
parentsys-fs/e2fsprogs: amd64 stable wrt bug #655850 (diff)
downloadgentoo-8c524aadb2c964ca60743e93bcd098d09dcfbf65.tar.gz
gentoo-8c524aadb2c964ca60743e93bcd098d09dcfbf65.tar.bz2
gentoo-8c524aadb2c964ca60743e93bcd098d09dcfbf65.zip
sys-auth/pam_p11: version bump
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'sys-auth/pam_p11/pam_p11-0.2.0.ebuild')
-rw-r--r--sys-auth/pam_p11/pam_p11-0.2.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/sys-auth/pam_p11/pam_p11-0.2.0.ebuild b/sys-auth/pam_p11/pam_p11-0.2.0.ebuild
new file mode 100644
index 000000000000..5719fc04d4c4
--- /dev/null
+++ b/sys-auth/pam_p11/pam_p11-0.2.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit ltprune pam
+
+DESCRIPTION="PAM module for authenticating against PKCS#11 tokens"
+HOMEPAGE="https://github.com/opensc/pam_p11/wiki"
+SRC_URI="https://github.com/OpenSC/${PN}/releases/download/${P}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND="virtual/pam
+ dev-libs/libp11
+ dev-libs/openssl:0="
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_configure() {
+ econf --with-pamdir="$(getpam_mod_dir)"
+}
+
+src_install() {
+ default
+ prune_libtool_files --all
+}