summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGöktürk Yüksek <gokturk@gentoo.org>2016-06-23 20:50:56 -0400
committerGöktürk Yüksek <gokturk@gentoo.org>2016-06-28 17:38:44 -0400
commitd629f9fe9e99dc983188295b2d4be2ed7eeff494 (patch)
treefaa21f6b88ebfd5a7d4a2b6b9024a0d595b31b6b /sys-auth/pam_u2f/pam_u2f-1.0.4.ebuild
parentapp-crypt/libu2f-server: initial commit of U2F server library in C (diff)
downloadgentoo-d629f9fe9e99dc983188295b2d4be2ed7eeff494.tar.gz
gentoo-d629f9fe9e99dc983188295b2d4be2ed7eeff494.tar.bz2
gentoo-d629f9fe9e99dc983188295b2d4be2ed7eeff494.zip
sys-auth/pam_u2f: initial commit of U2F PAM module
Package-Manager: portage-2.2.28
Diffstat (limited to 'sys-auth/pam_u2f/pam_u2f-1.0.4.ebuild')
-rw-r--r--sys-auth/pam_u2f/pam_u2f-1.0.4.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/sys-auth/pam_u2f/pam_u2f-1.0.4.ebuild b/sys-auth/pam_u2f/pam_u2f-1.0.4.ebuild
new file mode 100644
index 000000000000..16a5741b650c
--- /dev/null
+++ b/sys-auth/pam_u2f/pam_u2f-1.0.4.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit autotools flag-o-matic pam
+
+DESCRIPTION="Library for authenticating against PAM with a Yubikey"
+HOMEPAGE="https://github.com/Yubico/pam-u2f"
+SRC_URI="https://developers.yubico.com/${PN/_/-}/Releases/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+RDEPEND="
+ app-crypt/libu2f-host
+ app-crypt/libu2f-server
+ virtual/pam"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+PATCHES=( "${FILESDIR}/${PN}-1.0.2-fix-Makefile.patch" )
+
+src_prepare() {
+ default
+ use debug || append-cppflags -UDEBUG_PAM -UPAM_DEBUG
+ eautoreconf
+}
+
+src_configure() {
+ econf --with-pam-dir=$(getpam_mod_dir)
+}