summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2015-09-28 12:14:13 -0400
committerMike Frysinger <vapier@gentoo.org>2015-09-28 12:18:22 -0400
commit18b9751839db4a5bebd79d9e3dac6d19cc0d3ef0 (patch)
tree26e0d28709ec1446810e92504c50119dd52cabf9 /sys-block/fio
parentdev-java/istack-commons-runtime: Clean up old. (diff)
downloadgentoo-18b9751839db4a5bebd79d9e3dac6d19cc0d3ef0.tar.gz
gentoo-18b9751839db4a5bebd79d9e3dac6d19cc0d3ef0.tar.bz2
gentoo-18b9751839db4a5bebd79d9e3dac6d19cc0d3ef0.zip
sys-block/fio: echo configure step for debugging
Diffstat (limited to 'sys-block/fio')
-rw-r--r--sys-block/fio/fio-2.2.9.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/sys-block/fio/fio-2.2.9.ebuild b/sys-block/fio/fio-2.2.9.ebuild
index 32929cb63bfc..6af0f05c48d8 100644
--- a/sys-block/fio/fio-2.2.9.ebuild
+++ b/sys-block/fio/fio-2.2.9.ebuild
@@ -51,6 +51,7 @@ src_prepare() {
src_configure() {
chmod g-w "${T}"
# not a real configure script
+ set -- \
./configure \
--extra-cflags="${CFLAGS} ${CPPFLAGS}" \
--cc="$(tc-getCC)" \
@@ -58,8 +59,9 @@ src_configure() {
$(usex gtk '--enable-gfio' '') \
$(usex numa '' '--disable-numa') \
$(usex rbd '' '--disable-rbd') \
- $(usex static '--build-static' '') \
- || die 'configure failed'
+ $(usex static '--build-static' '')
+ echo "$@"
+ "$@" || die 'configure failed'
}
src_compile() {