summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2015-12-18 11:54:42 -0500
committerMike Gilbert <floppym@gentoo.org>2015-12-18 11:54:59 -0500
commit293b4ac4d038f4c00cc19a92af728a0fa06edfa2 (patch)
treebe25aa42ef35c23f23cb5b0bb6426e3ee2a6651a /sys-boot
parentnet-wireless/blueman: Security fix bump to 2.0.3, #568644 (diff)
downloadgentoo-293b4ac4d038f4c00cc19a92af728a0fa06edfa2.tar.gz
gentoo-293b4ac4d038f4c00cc19a92af728a0fa06edfa2.tar.bz2
gentoo-293b4ac4d038f4c00cc19a92af728a0fa06edfa2.zip
sys-boot/grub: Add postinst warning about security bug
Package-Manager: portage-2.2.26_p32
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/grub/grub-2.02_beta2-r8.ebuild9
1 files changed, 9 insertions, 0 deletions
diff --git a/sys-boot/grub/grub-2.02_beta2-r8.ebuild b/sys-boot/grub/grub-2.02_beta2-r8.ebuild
index abfeffba89f8..90e03995228d 100644
--- a/sys-boot/grub/grub-2.02_beta2-r8.ebuild
+++ b/sys-boot/grub/grub-2.02_beta2-r8.ebuild
@@ -309,5 +309,14 @@ pkg_postinst() {
optfeature "Detect other operating systems (grub-mkconfig)" sys-boot/os-prober
optfeature "Create rescue media (grub-mkrescue)" dev-libs/libisoburn
optfeature "Enable RAID device detection" sys-fs/mdadm
+ else
+ local v
+ for v in ${REPLACING_VERSIONS}; do
+ if ! version_is_at_least 2.02_beta2-r8 ${v}; then
+ ewarn "Please re-run grub2-install to address a security flaw when using"
+ ewarn "username/password authentication in grub."
+ ewarn "See bug 568326 for more information."
+ fi
+ done
fi
}