summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFelix Janda <felix.janda@posteo.de>2020-08-02 17:27:57 -0400
committerSam James <sam@gentoo.org>2020-08-07 17:57:49 +0000
commit977cfe6dac1a14198581c281213d8cff4be1e9b5 (patch)
tree8585632cb180aef40fedccc271abdc40843f54db /www-client/elinks
parentwww-client/elinks: bump to 0.13.4 (diff)
downloadgentoo-977cfe6dac1a14198581c281213d8cff4be1e9b5.tar.gz
gentoo-977cfe6dac1a14198581c281213d8cff4be1e9b5.tar.bz2
gentoo-977cfe6dac1a14198581c281213d8cff4be1e9b5.zip
www-client/elinks: fix compilation with -fno-common/gcc10
Bug: https://bugs.gentoo.org/730658 Signed-off-by: Felix Janda <felix.janda@posteo.de> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'www-client/elinks')
-rw-r--r--www-client/elinks/elinks-0.13.4.ebuild1
-rw-r--r--www-client/elinks/elinks-9999.ebuild1
-rw-r--r--www-client/elinks/files/elinks-0.13.4-ruby-gcc10.patch13
3 files changed, 15 insertions, 0 deletions
diff --git a/www-client/elinks/elinks-0.13.4.ebuild b/www-client/elinks/elinks-0.13.4.ebuild
index 82731e98cabf..c4b601e544b9 100644
--- a/www-client/elinks/elinks-0.13.4.ebuild
+++ b/www-client/elinks/elinks-0.13.4.ebuild
@@ -46,6 +46,7 @@ DEPEND="${RDEPEND}
PATCHES=(
"${FILESDIR}"/${PN}-9999-parallel-make.patch
+ "${FILESDIR}"/${P}-ruby-gcc10.patch
)
src_prepare() {
diff --git a/www-client/elinks/elinks-9999.ebuild b/www-client/elinks/elinks-9999.ebuild
index 16eb304d3e7a..ce228d3832a8 100644
--- a/www-client/elinks/elinks-9999.ebuild
+++ b/www-client/elinks/elinks-9999.ebuild
@@ -46,6 +46,7 @@ DEPEND="${RDEPEND}
PATCHES=(
"${FILESDIR}"/${P}-parallel-make.patch
+ "${FILESDIR}"/${PN}-0.13.4-ruby-gcc10.patch
)
src_unpack() {
diff --git a/www-client/elinks/files/elinks-0.13.4-ruby-gcc10.patch b/www-client/elinks/files/elinks-0.13.4-ruby-gcc10.patch
new file mode 100644
index 000000000000..380dce51f0dc
--- /dev/null
+++ b/www-client/elinks/files/elinks-0.13.4-ruby-gcc10.patch
@@ -0,0 +1,13 @@
+https://github.com/rkd77/felinks/pull/61
+
+--- a/src/scripting/ruby/core.h
++++ b/src/scripting/ruby/core.h
+@@ -21,7 +21,7 @@
+ #define RB_ERRINFO (ruby_errinfo)
+ #endif
+
+-VALUE erb_module;
++extern VALUE erb_module;
+
+ void alert_ruby_error(struct session *ses, unsigned char *msg);
+ void erb_report_error(struct session *ses, int state);