summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2018-07-11 22:03:36 +0900
committerAkinori Hattori <hattya@gentoo.org>2018-07-11 22:03:36 +0900
commit734eddfb4ed754c87338062b0bf0a29a3811678b (patch)
treedad6912a0a2fb05c14b88aea1c4ea8b9df51f9d8 /www-servers/h2o/h2o-9999.ebuild
parentnet-mail/mailutils: remove unused patches (diff)
downloadgentoo-734eddfb4ed754c87338062b0bf0a29a3811678b.tar.gz
gentoo-734eddfb4ed754c87338062b0bf0a29a3811678b.tar.bz2
gentoo-734eddfb4ed754c87338062b0bf0a29a3811678b.zip
www-servers/h2o: inherit ssl-cert
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'www-servers/h2o/h2o-9999.ebuild')
-rw-r--r--www-servers/h2o/h2o-9999.ebuild10
1 files changed, 9 insertions, 1 deletions
diff --git a/www-servers/h2o/h2o-9999.ebuild b/www-servers/h2o/h2o-9999.ebuild
index 89f63062ca99..56f77212526f 100644
--- a/www-servers/h2o/h2o-9999.ebuild
+++ b/www-servers/h2o/h2o-9999.ebuild
@@ -3,9 +3,10 @@
EAPI="6"
CMAKE_MAKEFILE_GENERATOR="emake"
+SSL_DEPS_SKIP=1
USE_RUBY="ruby23 ruby24"
-inherit cmake-utils git-r3 ruby-single systemd toolchain-funcs user
+inherit cmake-utils git-r3 ruby-single ssl-cert systemd toolchain-funcs user
DESCRIPTION="H2O - the optimized HTTP/1, HTTP/2 server"
HOMEPAGE="https://h2o.examp1e.net/"
@@ -85,3 +86,10 @@ src_install() {
fowners ${PN}:${PN} /var/log/${PN}
fperms 0750 /var/log/${PN}
}
+
+pkg_postinst() {
+ if [[ ! -f "${EROOT}"etc/ssl/${PN}/server.key ]]; then
+ install_cert /etc/ssl/${PN}/server
+ chown ${PN}:${PN} "${EROOT}"etc/ssl/${PN}/server.*
+ fi
+}