summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2018-07-11 22:03:36 +0900
committerAkinori Hattori <hattya@gentoo.org>2018-07-11 22:03:36 +0900
commit734eddfb4ed754c87338062b0bf0a29a3811678b (patch)
treedad6912a0a2fb05c14b88aea1c4ea8b9df51f9d8 /www-servers/h2o
parentnet-mail/mailutils: remove unused patches (diff)
downloadgentoo-734eddfb4ed754c87338062b0bf0a29a3811678b.tar.gz
gentoo-734eddfb4ed754c87338062b0bf0a29a3811678b.tar.bz2
gentoo-734eddfb4ed754c87338062b0bf0a29a3811678b.zip
www-servers/h2o: inherit ssl-cert
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'www-servers/h2o')
-rw-r--r--www-servers/h2o/files/h2o.conf26
-rw-r--r--www-servers/h2o/h2o-2.2.4.ebuild10
-rw-r--r--www-servers/h2o/h2o-9999.ebuild10
3 files changed, 26 insertions, 20 deletions
diff --git a/www-servers/h2o/files/h2o.conf b/www-servers/h2o/files/h2o.conf
index ccca5dd2de51..a135cc357351 100644
--- a/www-servers/h2o/files/h2o.conf
+++ b/www-servers/h2o/files/h2o.conf
@@ -1,27 +1,17 @@
-# see /usr/share/doc/h2o/index.html for detailed documentation
-# see h2o --help for command-line options and settings
-
user: h2o
pid-file: /run/h2o.pid
access-log: /var/log/h2o/access.log
error-log: /var/log/h2o/error.log
-# httpoxy mitigation (https://httpoxy.org)
-# see https://github.com/h2o/h2o/pull/996
-setenv:
- HTTP_PROXY: ""
-
-listen: 80
-
-#listen:
-# port: 443
-# ssl:
-# minimum-version: TLSv1.2
-# certificate-file: /etc/h2o/server.crt
-# key-file: /etc/h2o/server.key
-
hosts:
- "localhost:80":
+ "localhost":
+ listen:
+ port: 80
+ listen:
+ port: 443
+ ssl:
+ certificate-file: /etc/ssl/h2o/server.crt
+ key-file: /etc/ssl/h2o/server.key
paths:
"/":
file.dir: /var/www/localhost/htdocs
diff --git a/www-servers/h2o/h2o-2.2.4.ebuild b/www-servers/h2o/h2o-2.2.4.ebuild
index 25c1690eeeb3..47d1794fa4aa 100644
--- a/www-servers/h2o/h2o-2.2.4.ebuild
+++ b/www-servers/h2o/h2o-2.2.4.ebuild
@@ -3,9 +3,10 @@
EAPI="6"
CMAKE_MAKEFILE_GENERATOR="emake"
+SSL_DEPS_SKIP=1
USE_RUBY="ruby23 ruby24"
-inherit cmake-utils ruby-single systemd toolchain-funcs user
+inherit cmake-utils ruby-single ssl-cert systemd toolchain-funcs user
DESCRIPTION="H2O - the optimized HTTP/1, HTTP/2 server"
HOMEPAGE="https://h2o.examp1e.net/"
@@ -88,3 +89,10 @@ src_install() {
fowners ${PN}:${PN} /var/log/${PN}
fperms 0750 /var/log/${PN}
}
+
+pkg_postinst() {
+ if [[ ! -f "${EROOT}"etc/ssl/${PN}/server.key ]]; then
+ install_cert /etc/ssl/${PN}/server
+ chown ${PN}:${PN} "${EROOT}"etc/ssl/${PN}/server.*
+ fi
+}
diff --git a/www-servers/h2o/h2o-9999.ebuild b/www-servers/h2o/h2o-9999.ebuild
index 89f63062ca99..56f77212526f 100644
--- a/www-servers/h2o/h2o-9999.ebuild
+++ b/www-servers/h2o/h2o-9999.ebuild
@@ -3,9 +3,10 @@
EAPI="6"
CMAKE_MAKEFILE_GENERATOR="emake"
+SSL_DEPS_SKIP=1
USE_RUBY="ruby23 ruby24"
-inherit cmake-utils git-r3 ruby-single systemd toolchain-funcs user
+inherit cmake-utils git-r3 ruby-single ssl-cert systemd toolchain-funcs user
DESCRIPTION="H2O - the optimized HTTP/1, HTTP/2 server"
HOMEPAGE="https://h2o.examp1e.net/"
@@ -85,3 +86,10 @@ src_install() {
fowners ${PN}:${PN} /var/log/${PN}
fperms 0750 /var/log/${PN}
}
+
+pkg_postinst() {
+ if [[ ! -f "${EROOT}"etc/ssl/${PN}/server.key ]]; then
+ install_cert /etc/ssl/${PN}/server
+ chown ${PN}:${PN} "${EROOT}"etc/ssl/${PN}/server.*
+ fi
+}