summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-misc/trayer-srg
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-misc/trayer-srg')
-rw-r--r--x11-misc/trayer-srg/Manifest2
-rw-r--r--x11-misc/trayer-srg/metadata.xml11
-rw-r--r--x11-misc/trayer-srg/trayer-srg-1.1.5.ebuild32
-rw-r--r--x11-misc/trayer-srg/trayer-srg-1.1.6.ebuild32
4 files changed, 77 insertions, 0 deletions
diff --git a/x11-misc/trayer-srg/Manifest b/x11-misc/trayer-srg/Manifest
new file mode 100644
index 000000000000..898c501b26d0
--- /dev/null
+++ b/x11-misc/trayer-srg/Manifest
@@ -0,0 +1,2 @@
+DIST trayer-srg-1.1.5.tar.gz 27322 SHA256 98804500188c0bb99c7389ebea4b2e4dfffa2f3d06dc97e633b4934cf7c29757 SHA512 143277849c19f0caf8fcfb7c0e49f6caa1aec35e12a52cc9a92bdab0f64a9112334d998eb107e587755212d4421ff303582052206ac916b35f1e06e3e1d23277 WHIRLPOOL 37be63aa199a3c9271a7dbcc18c7b6639e81c746e9ba8cd772eb3f229723fad254c2d457ff6120278401124d98f0934857c2fb46fff5872518edc20d8af5fe19
+DIST trayer-srg-1.1.6.tar.gz 27576 SHA256 70acdf466e03a69715f8b90296ecbb14c5e8594f64a94d4b1ad1f5ba6b146a2e SHA512 456af94277dc237c516fff1589060b0b656040811ae48bba3c021be6310d104881c0eee7391d228d197db78e9bfb04773d4282ab2fe31717a4779b38bdb6739d WHIRLPOOL 6dc5394db31d73e6f8e28b4a86f0262108f946e2f0b111af3bd7c774cc84ea0b90e0eb0ba869c24b1dcdf477280dfaed10cf2c598ba5d075c372a28736434574
diff --git a/x11-misc/trayer-srg/metadata.xml b/x11-misc/trayer-srg/metadata.xml
new file mode 100644
index 000000000000..6616aa14aecc
--- /dev/null
+++ b/x11-misc/trayer-srg/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>xmw@gentoo.org</email>
+ <name>Michael Weber</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">sargon/trayer-srg</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/x11-misc/trayer-srg/trayer-srg-1.1.5.ebuild b/x11-misc/trayer-srg/trayer-srg-1.1.5.ebuild
new file mode 100644
index 000000000000..95765bb1f103
--- /dev/null
+++ b/x11-misc/trayer-srg/trayer-srg-1.1.5.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit toolchain-funcs vcs-snapshot
+
+DESCRIPTION="trayer fork with multi monitor support, cleaned up codebase and other fancy stuff"
+HOMEPAGE="https://github.com/sargon/trayer-srg"
+SRC_URI="https://github.com/sargon/${PN}/tarball/${P/-srg/} -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:2
+ x11-libs/libX11
+ x11-libs/libXmu"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_compile() {
+ emake DEVEL=1 TARGET=${PN} CC="$(tc-getCC)"
+}
+
+src_install() {
+ dobin ${PN}
+ dodoc CHANGELOG CREDITS README TODO
+}
diff --git a/x11-misc/trayer-srg/trayer-srg-1.1.6.ebuild b/x11-misc/trayer-srg/trayer-srg-1.1.6.ebuild
new file mode 100644
index 000000000000..7269d23666c5
--- /dev/null
+++ b/x11-misc/trayer-srg/trayer-srg-1.1.6.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit toolchain-funcs vcs-snapshot
+
+DESCRIPTION="trayer fork with multi monitor support, cleaned up codebase and other fancy stuff"
+HOMEPAGE="https://github.com/sargon/trayer-srg"
+SRC_URI="https://github.com/sargon/${PN}/tarball/${P/-srg/} -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:2
+ x11-libs/libX11
+ x11-libs/libXmu"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_compile() {
+ emake DEVEL=1 TARGET=${PN} CC="$(tc-getCC)"
+}
+
+src_install() {
+ dobin ${PN}
+ dodoc CHANGELOG CREDITS README TODO
+}