summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-misc/viewglob
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-misc/viewglob')
-rw-r--r--x11-misc/viewglob/Manifest1
-rw-r--r--x11-misc/viewglob/files/README.gentoo17
-rw-r--r--x11-misc/viewglob/files/viewglob-2.0.4-format-security.patch36
-rw-r--r--x11-misc/viewglob/files/viewglob-2.0.4-underlinking.patch163
-rw-r--r--x11-misc/viewglob/metadata.xml15
-rw-r--r--x11-misc/viewglob/viewglob-2.0.4-r1.ebuild35
6 files changed, 267 insertions, 0 deletions
diff --git a/x11-misc/viewglob/Manifest b/x11-misc/viewglob/Manifest
new file mode 100644
index 000000000000..668812bef61e
--- /dev/null
+++ b/x11-misc/viewglob/Manifest
@@ -0,0 +1 @@
+DIST viewglob-2.0.4.tar.gz 324752 SHA256 69ef6c62de26b2fad82ddff3fcc72e15ddf7eed7047492218f7c6387c0e7c6f4 SHA512 95fb5ef6dc412804cbff6a961ec08bf8e114eefb9ea5430aa1be2f8b2bcbb7e76ab8392e31148d4275debd6f4cada81d1ebfb08a741b8a579f749efdb8f7adb4 WHIRLPOOL e22d237e736283027991a9e2c5bf61bf275b61a34ff3f6b645d46bb69fe2c524f14b07820e03cec526b2268e0ad88c81f9b82b299df253b79d64f1e0ffcb8979
diff --git a/x11-misc/viewglob/files/README.gentoo b/x11-misc/viewglob/files/README.gentoo
new file mode 100644
index 000000000000..be03a013571b
--- /dev/null
+++ b/x11-misc/viewglob/files/README.gentoo
@@ -0,0 +1,17 @@
+/usr/bin/viewglob is a wrapper for vgd and vgseer (client and
+daemon, respectively). Generally speaking, this is what you want to
+execute from your shell.
+
+Should you prefer to start viewglob with each shell session, try
+something like this:
+
+ if [[ ! $VG_VIEWGLOB_ACTIVE && $DISPLAY ]] ; then
+ exec viewglob
+ fi
+
+Have a look at http://viewglob.sourceforge.net/faq.html for a
+few more viewglob tricks.
+
+There are some known bugs in viewglob with screen. Exercise some
+caution and take results with a pinch of salt if you try the two
+together.
diff --git a/x11-misc/viewglob/files/viewglob-2.0.4-format-security.patch b/x11-misc/viewglob/files/viewglob-2.0.4-format-security.patch
new file mode 100644
index 000000000000..98490e3836c9
--- /dev/null
+++ b/x11-misc/viewglob/files/viewglob-2.0.4-format-security.patch
@@ -0,0 +1,36 @@
+ common/syslogging.c | 2 +-
+ vgseer/vgseer.c | 4 ++--
+ 2 files changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/common/syslogging.c b/common/syslogging.c
+index dcb7106..df0b537 100644
+--- a/common/syslogging.c
++++ b/common/syslogging.c
+@@ -40,6 +40,6 @@ void syslogging(const gchar* log_domain, GLogLevelFlags log_level,
+ else
+ priority = LOG_NOTICE;
+
+- syslog(priority, message);
++ syslog(priority, "%s", message);
+ }
+
+diff --git a/vgseer/vgseer.c b/vgseer/vgseer.c
+index e045835..18b0024 100644
+--- a/vgseer/vgseer.c
++++ b/vgseer/vgseer.c
+@@ -276,13 +276,13 @@ static gint connect_to_vgd(gchar* server, gchar* port,
+ if (STREQ(value, "ERROR")) {
+ /* Print reason for error and exit. */
+ get_param_verify(fd, &param, &value, P_REASON, NULL);
+- g_critical(value);
++ g_critical("%s", value);
+ clean_fail(NULL);
+ }
+ else if (STREQ(value, "WARNING")) {
+ /* Print warning but continue. */
+ get_param_verify(fd, &param, &value, P_REASON, NULL);
+- g_warning(value);
++ g_warning("%s", value);
+ }
+ else if (!STREQ(value, "OK")) {
+ g_critical("Unknown value for P_STATUS: %s", value);
diff --git a/x11-misc/viewglob/files/viewglob-2.0.4-underlinking.patch b/x11-misc/viewglob/files/viewglob-2.0.4-underlinking.patch
new file mode 100644
index 000000000000..acea0bd6c359
--- /dev/null
+++ b/x11-misc/viewglob/files/viewglob-2.0.4-underlinking.patch
@@ -0,0 +1,163 @@
+ Makefile.am | 6 +++---
+ shell/Makefile.am | 12 ++++++------
+ vgd/Makefile.am | 2 +-
+ vgdisplay/Makefile.am | 4 ++--
+ vgdisplay/Makefile.in | 2 +-
+ vgexpand/Makefile.am | 2 +-
+ vgping/Makefile.am | 2 +-
+ vgseer/Makefile.am | 2 +-
+ 8 files changed, 16 insertions(+), 16 deletions(-)
+
+diff --git a/Makefile.am b/Makefile.am
+index 5378bad..4b0d394 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -11,19 +11,19 @@ man_MANS = vgseer.1 viewglob.1 $(MANS_FULL)
+ viewglob.1:
+ rm -f viewglob.1.tmp
+ sed -e 's/@RELEASE_DATE\@/$(RELEASE_DATE)/g' \
+- viewglob.1.in > viewglob.1.tmp
++ $(srcdir)/viewglob.1.in > viewglob.1.tmp
+ mv viewglob.1.tmp viewglob.1
+
+ vgseer.1:
+ rm -f vgseer.1.tmp
+ sed -e 's/@RELEASE_DATE\@/$(RELEASE_DATE)/g' \
+- vgseer.1.in > vgseer.1.tmp
++ $(srcdir)/vgseer.1.in > vgseer.1.tmp
+ mv vgseer.1.tmp vgseer.1
+
+ vgd.1:
+ rm -f vgd.1.tmp
+ sed -e 's/@RELEASE_DATE\@/$(RELEASE_DATE)/g' \
+- vgd.1.in > vgd.1.tmp
++ $(srcdir)/vgd.1.in > vgd.1.tmp
+ mv vgd.1.tmp vgd.1
+
+ EXTRA_DIST = COPYING2 HACKING viewglob.1.in vgseer.1.in vgd.1.in
+diff --git a/shell/Makefile.am b/shell/Makefile.am
+index 1d4239a..0a62bc7 100644
+--- a/shell/Makefile.am
++++ b/shell/Makefile.am
+@@ -1,7 +1,7 @@
+
+ bin_SCRIPTS = viewglob
+-pkglib_SCRIPTS = getopt.sh conf-to-args.sh
+-pkglib_DATA = init-viewglob.bashrc .zshrc
++libexec_SCRIPTS = getopt.sh conf-to-args.sh
++pkgdata_DATA = init-viewglob.bashrc .zshrc
+
+ viewglob:
+ rm -f viewglob.tmp
+@@ -10,27 +10,27 @@ viewglob:
+ -e 's,@PACKAGE_NAME\@,$(PACKAGE_NAME),g' \
+ -e 's,@PACKAGE_VERSION\@,$(PACKAGE_VERSION),g' \
+ -e 's/@RELEASE_DATE\@/$(RELEASE_DATE)/g' \
+- viewglob.in > viewglob.tmp
++ $(srcdir)/viewglob.in > viewglob.tmp
+ chmod a+x viewglob.tmp
+ mv viewglob.tmp viewglob
+
+ getopt.sh:
+ rm -f getopt.sh.tmp
+ sed -e 's,@BASH_FULL_PATH\@,$(BASH_FULL_PATH),g' \
+- getopt.sh.in > getopt.sh.tmp
++ $(srcdir)/getopt.sh.in > getopt.sh.tmp
+ chmod a+x getopt.sh.tmp
+ mv getopt.sh.tmp getopt.sh
+
+ .zshrc:
+ rm -f init-viewglob.zshrc.tmp
+ sed -e 's,@pkglibdir\@,$(pkglibdir),g' \
+- init-viewglob.zshrc.in > init-viewglob.zshrc.tmp
++ $(srcdir)/init-viewglob.zshrc.in > init-viewglob.zshrc.tmp
+ mv init-viewglob.zshrc.tmp .zshrc
+
+ init-viewglob.bashrc:
+ rm -f init-viewglob.bashrc.tmp
+ sed -e 's,@pkglibdir\@,$(pkglibdir),g' \
+- init-viewglob.bashrc.in > init-viewglob.bashrc.tmp
++ $(srcdir)/init-viewglob.bashrc.in > init-viewglob.bashrc.tmp
+ mv init-viewglob.bashrc.tmp init-viewglob.bashrc
+
+
+diff --git a/vgd/Makefile.am b/vgd/Makefile.am
+index 634b7de..1982981 100644
+--- a/vgd/Makefile.am
++++ b/vgd/Makefile.am
+@@ -25,7 +25,7 @@ BUILT_SOURCES = vgd-usage.h
+
+ vgd-usage.h: vgd-usage.txt
+ rm -f vgd-usage.tmp
+- sed <vgd-usage.txt >vgd-usage.tmp \
++ sed < $(srcdir)/vgd-usage.txt >vgd-usage.tmp \
+ -e 's/\\/\\\\/g' \
+ -e 's/"/\\"/g' \
+ -e 's/.*/\"&\\n\"/'
+diff --git a/vgdisplay/Makefile.am b/vgdisplay/Makefile.am
+index 4aa941b..5d2e1df 100644
+--- a/vgdisplay/Makefile.am
++++ b/vgdisplay/Makefile.am
+@@ -4,9 +4,9 @@ AM_CPPFLAGS = -DVG_LIB_DIR="\"$(pkglibdir)\"" -I$(COMMON_DIR) \
+ LDADD = \
+ @GLIB_LIBS@ \
+ @X_PRE_LIBS@ @X_LIBS@ -lX11 @X_EXTRA_LIBS@ \
+- @GTK_LIBS@
++ @GTK_LIBS@ -lm
+
+-pkglib_PROGRAMS = vgclassic vgmini
++libexec_PROGRAMS = vgclassic vgmini
+
+ vgclassic_SOURCES = \
+ vgclassic.c \
+diff --git a/vgdisplay/Makefile.in b/vgdisplay/Makefile.in
+index 218587b..cd7d86d 100644
+--- a/vgdisplay/Makefile.in
++++ b/vgdisplay/Makefile.in
+@@ -55,7 +55,7 @@ am_vgclassic_OBJECTS = vgclassic.$(OBJEXT) exhibit.$(OBJEXT) \
+ hardened-io.$(OBJEXT) x11-stuff.$(OBJEXT) syslogging.$(OBJEXT) \
+ fgetopt.$(OBJEXT)
+ vgclassic_OBJECTS = $(am_vgclassic_OBJECTS)
+-vgclassic_LDADD = $(LDADD)
++vgclassic_LDADD = $(LDADD) -lm
+ vgclassic_DEPENDENCIES =
+ am_vgmini_OBJECTS = vgmini.$(OBJEXT) wrap_box.$(OBJEXT) \
+ file_box.$(OBJEXT) lscolors.$(OBJEXT) dircont.$(OBJEXT) \
+diff --git a/vgexpand/Makefile.am b/vgexpand/Makefile.am
+index e6817cc..6357fc8 100644
+--- a/vgexpand/Makefile.am
++++ b/vgexpand/Makefile.am
+@@ -2,7 +2,7 @@ COMMON_DIR = $(top_srcdir)/common
+ AM_CPPFLAGS = @GLIB_CFLAGS@ -DVG_LIB_DIR="\"$(pkglibdir)\"" -I$(COMMON_DIR)
+ LDADD = @GLIB_LIBS@
+
+-pkglib_PROGRAMS = vgexpand
++libexec_PROGRAMS = vgexpand
+
+ vgexpand_SOURCES = vgexpand.c
+
+diff --git a/vgping/Makefile.am b/vgping/Makefile.am
+index 02a1db3..7b09845 100644
+--- a/vgping/Makefile.am
++++ b/vgping/Makefile.am
+@@ -1,6 +1,6 @@
+ COMMON_DIR = $(top_srcdir)/common
+
+-pkglib_PROGRAMS = vgping
++libexec_PROGRAMS = vgping
+
+ vgping_CPPFLAGS = @GLIB_CFLAGS@ -DVG_LIB_DIR="\"$(pkglibdir)\"" -I$(COMMON_DIR)
+ vgping_LDADD = @GLIB_LIBS@ @LIBS@
+diff --git a/vgseer/Makefile.am b/vgseer/Makefile.am
+index ff0431e..05480b8 100644
+--- a/vgseer/Makefile.am
++++ b/vgseer/Makefile.am
+@@ -29,7 +29,7 @@ BUILT_SOURCES = vgseer-usage.h
+
+ vgseer-usage.h: vgseer-usage.txt
+ rm -f vgseer-usage.tmp
+- sed <vgseer-usage.txt >vgseer-usage.tmp \
++ sed < $(srcdir)/vgseer-usage.txt >vgseer-usage.tmp \
+ -e 's/\\/\\\\/g' \
+ -e 's/"/\\"/g' \
+ -e 's/.*/\"&\\n\"/'
diff --git a/x11-misc/viewglob/metadata.xml b/x11-misc/viewglob/metadata.xml
new file mode 100644
index 000000000000..665f68caaade
--- /dev/null
+++ b/x11-misc/viewglob/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>shell-tools</herd>
+ <longdescription lang="en">
+ Viewglob is a package that graphically displays the results of a shell
+ glob, helping beginners of shell usage become acclimitised to filename
+ generation. In addition, it acts as a basic replacement for ls, by
+ tracking shell directory changes. It is compatible with zsh and bash,
+ and helper files and documentation are provided.
+ </longdescription>
+ <upstream>
+ <remote-id type="sourceforge">viewglob</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/x11-misc/viewglob/viewglob-2.0.4-r1.ebuild b/x11-misc/viewglob/viewglob-2.0.4-r1.ebuild
new file mode 100644
index 000000000000..20cdb09ecaaf
--- /dev/null
+++ b/x11-misc/viewglob/viewglob-2.0.4-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=yes
+
+inherit autotools-utils readme.gentoo
+
+DESCRIPTION="Graphical display of directories and globs referenced at the shell prompt"
+HOMEPAGE="http://viewglob.sourceforge.net/"
+SRC_URI="mirror://sourceforge/viewglob/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc ~sparc x86"
+IUSE=""
+
+RDEPEND="
+ dev-libs/glib:2
+ x11-libs/gtk+:2
+ || ( app-shells/bash:* app-shells/zsh )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-underlinking.patch
+ "${FILESDIR}"/${P}-format-security.patch
+)
+
+src_install() {
+ autotools-utils_src_install
+ readme.gentoo_src_install
+}