summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2016-08-22 21:00:43 +0200
committerJeroen Roovers <jer@gentoo.org>2016-08-22 21:01:03 +0200
commit25c7fd05b4e8078439390b36cda83bab69041852 (patch)
tree2b783dd62cc6ff6293733e81d880a20fd4debb03 /x11-misc/xnots
parentapp-office/scribus: Version bump (bug 590386). (diff)
downloadgentoo-25c7fd05b4e8078439390b36cda83bab69041852.tar.gz
gentoo-25c7fd05b4e8078439390b36cda83bab69041852.tar.bz2
gentoo-25c7fd05b4e8078439390b36cda83bab69041852.zip
x11-misc/xnots: Fix building with sys-devel/gcc-5* (bug #575376).
Package-Manager: portage-2.3.0
Diffstat (limited to 'x11-misc/xnots')
-rw-r--r--x11-misc/xnots/xnots-0.2.1-r1.ebuild22
-rw-r--r--x11-misc/xnots/xnots-9999.ebuild22
2 files changed, 28 insertions, 16 deletions
diff --git a/x11-misc/xnots/xnots-0.2.1-r1.ebuild b/x11-misc/xnots/xnots-0.2.1-r1.ebuild
index ee11e5f09c33..92153b83810a 100644
--- a/x11-misc/xnots/xnots-0.2.1-r1.ebuild
+++ b/x11-misc/xnots/xnots-0.2.1-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
-inherit toolchain-funcs
+inherit flag-o-matic toolchain-funcs
DESCRIPTION="A desktop sticky note program for the unix geek"
HOMEPAGE="http://xnots.sourceforge.net https://github.com/thePalindrome/xnots"
@@ -14,20 +14,26 @@ SLOT="0"
KEYWORDS="amd64 x86"
IUSE="vim-syntax"
-RDEPEND="x11-libs/libX11
+RDEPEND="
+ x11-libs/libX11
x11-libs/libXext
- x11-libs/libXrender
x11-libs/libXrandr
- x11-libs/pango[X]"
+ x11-libs/libXrender
+ x11-libs/pango[X]
+"
-DEPEND="${RDEPEND}
+DEPEND="
+ ${RDEPEND}
virtual/pkgconfig
- x11-proto/xextproto
+ x11-proto/randrproto
x11-proto/renderproto
- x11-proto/randrproto"
+ x11-proto/xextproto
+"
src_prepare() {
sed -i -e 's|LICENCE||g' Makefile || die
+
+ append-cflags -std=gnu89
}
src_compile() {
diff --git a/x11-misc/xnots/xnots-9999.ebuild b/x11-misc/xnots/xnots-9999.ebuild
index d30b43eb9dc2..4615827f4fb6 100644
--- a/x11-misc/xnots/xnots-9999.ebuild
+++ b/x11-misc/xnots/xnots-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
-inherit git-r3 toolchain-funcs
+inherit flag-o-matic git-r3 toolchain-funcs
DESCRIPTION="A desktop sticky note program for the unix geek"
HOMEPAGE="http://xnots.sourceforge.net https://github.com/thePalindrome/xnots"
@@ -13,20 +13,26 @@ LICENSE="GPL-2"
SLOT="0"
IUSE="vim-syntax"
-RDEPEND="x11-libs/libX11
+RDEPEND="
+ x11-libs/libX11
x11-libs/libXext
- x11-libs/libXrender
x11-libs/libXrandr
- x11-libs/pango[X]"
+ x11-libs/libXrender
+ x11-libs/pango[X]
+"
-DEPEND="${RDEPEND}
+DEPEND="
+ ${RDEPEND}
virtual/pkgconfig
- x11-proto/xextproto
+ x11-proto/randrproto
x11-proto/renderproto
- x11-proto/randrproto"
+ x11-proto/xextproto
+"
src_prepare() {
sed -i -e 's|LICENCE||g' Makefile || die
+
+ append-cflags -std=gnu89
}
src_compile() {