summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <Marek.Szuba@cern.ch>2016-04-28 10:06:38 +0200
committerSam Jorna <wraeth@gentoo.org>2016-04-29 01:14:52 +1000
commit5f5f50e4655d7da1cedc0f9c49a8d20010f9a6f1 (patch)
treef73f46a775bef7f12c6703e084eedef73dd71db8 /x11-plugins/pidgin-gnome-keyring/files
parentkde-frameworks/baloo: Virtual X is required for tests (diff)
downloadgentoo-5f5f50e4655d7da1cedc0f9c49a8d20010f9a6f1.tar.gz
gentoo-5f5f50e4655d7da1cedc0f9c49a8d20010f9a6f1.tar.bz2
gentoo-5f5f50e4655d7da1cedc0f9c49a8d20010f9a6f1.zip
x11-plugins/pidgin-gnome-keyring: new ebuild, initial version 2.0
By default Pidgin/Purple store saved passwords in plain text in their configuration files. This plug-in makes it possible to store passwords in a keyring instead. Gentoo-Bug: 581422 Package-Manager: portage-2.2.28 Closes: https://github.com/gentoo/gentoo/pull/1368
Diffstat (limited to 'x11-plugins/pidgin-gnome-keyring/files')
-rw-r--r--x11-plugins/pidgin-gnome-keyring/files/pidgin-gnome-keyring-2.0-plugindir.patch21
1 files changed, 21 insertions, 0 deletions
diff --git a/x11-plugins/pidgin-gnome-keyring/files/pidgin-gnome-keyring-2.0-plugindir.patch b/x11-plugins/pidgin-gnome-keyring/files/pidgin-gnome-keyring-2.0-plugindir.patch
new file mode 100644
index 000000000000..6aa6ffca3c52
--- /dev/null
+++ b/x11-plugins/pidgin-gnome-keyring/files/pidgin-gnome-keyring-2.0-plugindir.patch
@@ -0,0 +1,21 @@
+--- a/Makefile 2015-02-07 03:23:05.000000000 +0000
++++ b/Makefile 2016-04-28 09:53:59.915565380 +0000
+@@ -2,6 +2,7 @@
+
+ SECRETFLAGS = `pkg-config --libs --cflags libsecret-1`
+ PURPLEFLAGS = `pkg-config --cflags purple`
++PLUGINDIR = `pkg-config --variable=plugindir purple`
+ VERSION = $(shell cat VERSION)
+ ifeq ($(strip $(VERSION)),)
+ VERSION = `git describe --tags`
+@@ -18,8 +19,8 @@
+ ${CC} ${CFLAGS} ${LDFLAGS} -Wall -I. -g -O2 ${TARGET}.c -o ${TARGET}.so -shared -fPIC -DPIC -ggdb ${PURPLEFLAGS} ${SECRETFLAGS} -DVERSION=\"${VERSION}\"
+
+ install: ${TARGET}.so
+- mkdir -p ${DESTDIR}/usr/lib/purple-2/
+- cp ${TARGET}.so ${DESTDIR}/usr/lib/purple-2/
++ mkdir -p ${DESTDIR}/$(PLUGINDIR)/
++ cp ${TARGET}.so ${DESTDIR}/$(PLUGINDIR)/
+
+ install_local: ${TARGET}.so
+ mkdir -p ~/.purple/plugins