summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-plugins/wmdate
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-plugins/wmdate')
-rw-r--r--x11-plugins/wmdate/Manifest1
-rw-r--r--x11-plugins/wmdate/files/wmdate-ComplexProgramTargetNoMan.patch11
-rw-r--r--x11-plugins/wmdate/metadata.xml5
-rw-r--r--x11-plugins/wmdate/wmdate-0.7.ebuild39
4 files changed, 56 insertions, 0 deletions
diff --git a/x11-plugins/wmdate/Manifest b/x11-plugins/wmdate/Manifest
new file mode 100644
index 000000000000..22bb856c9c11
--- /dev/null
+++ b/x11-plugins/wmdate/Manifest
@@ -0,0 +1 @@
+DIST wmdate-0.7.tar.gz 10645 SHA256 e246e38a7488470d271dc5262f526462821fa4337c3e07bda8b9b3f9e7b8d975
diff --git a/x11-plugins/wmdate/files/wmdate-ComplexProgramTargetNoMan.patch b/x11-plugins/wmdate/files/wmdate-ComplexProgramTargetNoMan.patch
new file mode 100644
index 000000000000..3f24316f7d19
--- /dev/null
+++ b/x11-plugins/wmdate/files/wmdate-ComplexProgramTargetNoMan.patch
@@ -0,0 +1,11 @@
+--- wmdate-0.7./Imakefile~ Mon Nov 26 06:13:46 2001
++++ wmdate-0.7/Imakefile Mon Nov 26 06:13:46 2001
+@@ -132,7 +132,7 @@
+ XCOMM Create Makefile
+ XCOMM ---------------------------------------
+
+-ComplexProgramTarget(wmdate)
++ComplexProgramTargetNoMan(wmdate)
+
+ XCOMM - - - - - - - - - - - - - - - - - - - -
+ XCOMM e n d
diff --git a/x11-plugins/wmdate/metadata.xml b/x11-plugins/wmdate/metadata.xml
new file mode 100644
index 000000000000..b1a9efc4f2f0
--- /dev/null
+++ b/x11-plugins/wmdate/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>desktop-dock</herd>
+</pkgmetadata>
diff --git a/x11-plugins/wmdate/wmdate-0.7.ebuild b/x11-plugins/wmdate/wmdate-0.7.ebuild
new file mode 100644
index 000000000000..06a3285036f5
--- /dev/null
+++ b/x11-plugins/wmdate/wmdate-0.7.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="yet another date-display dock application"
+HOMEPAGE="http://solfertje.student.utwente.nl/~dalroi/applications.php"
+SRC_URI="http://solfertje.student.utwente.nl/~dalroi/${PN}/files/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 sparc x86"
+IUSE=""
+
+RDEPEND="x11-libs/libdockapp
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXpm"
+DEPEND="${RDEPEND}
+ x11-misc/gccmakedep
+ x11-misc/imake"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-ComplexProgramTargetNoMan.patch
+}
+
+src_compile() {
+ xmkmf || die "xmkmf failed."
+ emake CC="$(tc-getCC)" CDEBUGFLAGS="${CFLAGS}" \
+ LDOPTIONS="${LDFLAGS}" || die "emake failed."
+}
+
+src_install() {
+ dobin ${PN}
+ dodoc Changelog README
+}