summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-plugins/wmdate')
-rw-r--r--x11-plugins/wmdate/Manifest1
-rw-r--r--x11-plugins/wmdate/files/wmdate-ComplexProgramTargetNoMan.patch11
-rw-r--r--x11-plugins/wmdate/metadata.xml5
-rw-r--r--x11-plugins/wmdate/wmdate-0.7.ebuild39
4 files changed, 56 insertions, 0 deletions
diff --git a/x11-plugins/wmdate/Manifest b/x11-plugins/wmdate/Manifest
new file mode 100644
index 000000000000..22bb856c9c11
--- /dev/null
+++ b/x11-plugins/wmdate/Manifest
@@ -0,0 +1 @@
+DIST wmdate-0.7.tar.gz 10645 SHA256 e246e38a7488470d271dc5262f526462821fa4337c3e07bda8b9b3f9e7b8d975
diff --git a/x11-plugins/wmdate/files/wmdate-ComplexProgramTargetNoMan.patch b/x11-plugins/wmdate/files/wmdate-ComplexProgramTargetNoMan.patch
new file mode 100644
index 000000000000..3f24316f7d19
--- /dev/null
+++ b/x11-plugins/wmdate/files/wmdate-ComplexProgramTargetNoMan.patch
@@ -0,0 +1,11 @@
+--- wmdate-0.7./Imakefile~ Mon Nov 26 06:13:46 2001
++++ wmdate-0.7/Imakefile Mon Nov 26 06:13:46 2001
+@@ -132,7 +132,7 @@
+ XCOMM Create Makefile
+ XCOMM ---------------------------------------
+
+-ComplexProgramTarget(wmdate)
++ComplexProgramTargetNoMan(wmdate)
+
+ XCOMM - - - - - - - - - - - - - - - - - - - -
+ XCOMM e n d
diff --git a/x11-plugins/wmdate/metadata.xml b/x11-plugins/wmdate/metadata.xml
new file mode 100644
index 000000000000..b1a9efc4f2f0
--- /dev/null
+++ b/x11-plugins/wmdate/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>desktop-dock</herd>
+</pkgmetadata>
diff --git a/x11-plugins/wmdate/wmdate-0.7.ebuild b/x11-plugins/wmdate/wmdate-0.7.ebuild
new file mode 100644
index 000000000000..06a3285036f5
--- /dev/null
+++ b/x11-plugins/wmdate/wmdate-0.7.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="yet another date-display dock application"
+HOMEPAGE="http://solfertje.student.utwente.nl/~dalroi/applications.php"
+SRC_URI="http://solfertje.student.utwente.nl/~dalroi/${PN}/files/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 sparc x86"
+IUSE=""
+
+RDEPEND="x11-libs/libdockapp
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXpm"
+DEPEND="${RDEPEND}
+ x11-misc/gccmakedep
+ x11-misc/imake"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-ComplexProgramTargetNoMan.patch
+}
+
+src_compile() {
+ xmkmf || die "xmkmf failed."
+ emake CC="$(tc-getCC)" CDEBUGFLAGS="${CFLAGS}" \
+ LDOPTIONS="${LDFLAGS}" || die "emake failed."
+}
+
+src_install() {
+ dobin ${PN}
+ dodoc Changelog README
+}