summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPablo <pord@tuta.io>2021-01-10 22:31:56 +0100
committerSam James <sam@gentoo.org>2021-01-24 01:48:04 +0000
commit680b479e28806bfff528a9201041c3e48c713693 (patch)
treef1b3c7a0f7b371c90edd78f4e52b4a71b72baf30 /x11-terms
parentx11-terms/kitty: bump to 0.19.3 (diff)
downloadgentoo-680b479e28806bfff528a9201041c3e48c713693.tar.gz
gentoo-680b479e28806bfff528a9201041c3e48c713693.tar.bz2
gentoo-680b479e28806bfff528a9201041c3e48c713693.zip
x11-terms/kitty-terminfo: bump to 0.19.3
Signed-off-by: Pablo Orduna <pabloorduna98@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/19021 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'x11-terms')
-rw-r--r--x11-terms/kitty-terminfo/Manifest1
-rw-r--r--x11-terms/kitty-terminfo/kitty-terminfo-0.19.3.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/x11-terms/kitty-terminfo/Manifest b/x11-terms/kitty-terminfo/Manifest
index b600f93893c6..03046d626343 100644
--- a/x11-terms/kitty-terminfo/Manifest
+++ b/x11-terms/kitty-terminfo/Manifest
@@ -1,2 +1,3 @@
DIST kitty-0.19.1.tar.xz 3262516 BLAKE2B 82520e79125483a9e3b6592bdf38e782231934214a989fe44ad6c587a025338a98f1d09219a315dfbffc8264be5f5b2352db457b5e11edc2d08af594989a8092 SHA512 3a61d15598f32634646cbf0be596e9023420452130be1b9a718d2ce7daf3edeee6d2ba3abfe91c768758b043ed46423a2382680f9dd65fd6a6c57dbcd0fc1fd3
DIST kitty-0.19.2.tar.xz 3259928 BLAKE2B c6060a098df53e53cfd56f680f0972ee2a116c0d9ae8eabd2f087540f5f181a5980e2d963d27f24df5c57f6e81327591531397341e33b3d9bb4a2420138aa473 SHA512 86b6a08c7f5282587967ff7e3509d6ac4ef556b3bbeae1a9529a584f804f204d54f5031a90dcd08af735eb16a283938fa9e49c8d767dca12e945b7493f0e76da
+DIST kitty-0.19.3.tar.xz 3269628 BLAKE2B b3b673f8ad06baf770b03bcee87b2f405e1ff09d0fa5c6a232fd8df651351a428c8fbd9e2d0dc90ed44a0d6632192bea83650388ee73ebc3b523f51e51168006 SHA512 d1eea7f909c9492542650a83a149fd279c44380cf10387759f10caad57cd4dbabeac1ce84e8142bfa47266ec2562dfa3766ce08e2aee4d8e0ebacea165f101e4
diff --git a/x11-terms/kitty-terminfo/kitty-terminfo-0.19.3.ebuild b/x11-terms/kitty-terminfo/kitty-terminfo-0.19.3.ebuild
new file mode 100644
index 000000000000..cc2defc98684
--- /dev/null
+++ b/x11-terms/kitty-terminfo/kitty-terminfo-0.19.3.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit python-any-r1 toolchain-funcs xdg
+
+DESCRIPTION="Terminfo for kitty, an OpenGL-based terminal emulator"
+HOMEPAGE="https://github.com/kovidgoyal/kitty"
+SRC_URI="https://github.com/kovidgoyal/kitty/releases/download/v${PV}/kitty-${PV}.tar.xz"
+S="${WORKDIR}/kitty-${PV}"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+DEPEND="${PYTHON_DEPS}"
+
+PATCHES=(
+ "${FILESDIR}"/kitty-terminfo-setup-0.19.1.patch
+)
+
+# kitty-terminfo is a split package from kitty that only installs the terminfo
+# file. As tests are designed to be run with the whole package compiled they
+# would fail in this case.
+RESTRICT="test"
+
+src_compile() {
+ "${EPYTHON}" setup.py \
+ --verbose $(usex debug --debug "") \
+ --libdir-name $(get_libdir) \
+ linux-terminfo || die "Failed to compile kitty."
+}
+
+src_install() {
+ insinto /usr
+ doins -r linux-package/*
+}