summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2017-01-16 20:28:31 +0200
committerMart Raudsepp <leio@gentoo.org>2017-01-16 20:45:30 +0200
commitc9bff85f6f63656956401eb6b906b0ec7bfa6a83 (patch)
treedb2d62bea75857bdcf719ae6b185546604d4e918 /x11-themes/gtk-engines-adwaita/gtk-engines-adwaita-3.22.2.ebuild
parentx11-libs/gdk-pixbuf: Clarify what USE=X does in local description (diff)
downloadgentoo-c9bff85f6f63656956401eb6b906b0ec7bfa6a83.tar.gz
gentoo-c9bff85f6f63656956401eb6b906b0ec7bfa6a83.tar.bz2
gentoo-c9bff85f6f63656956401eb6b906b0ec7bfa6a83.zip
x11-themes/gtk-engines-adwaita: Bump to 3.22.2 to keep in sync with gnome-themes-standard
No changes to the compiled code that this split uses, but it's a fast compile and better to keep in sync with gnome-themes-standard to use the same tarball at the same visibility level. Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'x11-themes/gtk-engines-adwaita/gtk-engines-adwaita-3.22.2.ebuild')
-rw-r--r--x11-themes/gtk-engines-adwaita/gtk-engines-adwaita-3.22.2.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/x11-themes/gtk-engines-adwaita/gtk-engines-adwaita-3.22.2.ebuild b/x11-themes/gtk-engines-adwaita/gtk-engines-adwaita-3.22.2.ebuild
new file mode 100644
index 000000000000..f765a8bb1be5
--- /dev/null
+++ b/x11-themes/gtk-engines-adwaita/gtk-engines-adwaita-3.22.2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="6"
+GNOME_ORG_MODULE="gnome-themes-standard"
+
+inherit gnome.org multilib-minimal
+
+DESCRIPTION="Adwaita GTK+2 theme engine"
+HOMEPAGE="https://git.gnome.org/browse/gnome-themes-standard/"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+IUSE=""
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~arm-linux ~x86-linux ~x64-solaris ~x86-solaris"
+
+COMMON_DEPEND="
+ >=x11-libs/gtk+-2.24.15:2[${MULTILIB_USEDEP}]
+"
+RDEPEND="${COMMON_DEPEND}
+ !<x11-themes/gnome-themes-standard-3.20.2-r1
+"
+DEPEND="${COMMON_DEPEND}
+ >=dev-util/intltool-0.40
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf \
+ --disable-static \
+ --enable-gtk2-engine \
+ --disable-gtk3-engine \
+ GTK_UPDATE_ICON_CACHE=$(type -P true)
+}
+
+multilib_src_compile() {
+ emake -C themes/Adwaita/gtk-2.0 libadwaita.la
+}
+
+multilib_src_install() {
+ emake -C themes/Adwaita/gtk-2.0 DESTDIR="${D}" install-engineLTLIBRARIES
+ prune_libtool_files --modules
+}