summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-08-15 11:14:35 +0200
committerMichał Górny <mgorny@gentoo.org>2017-08-15 11:15:54 +0200
commitc0c7320c64220f984d8692e84d2b3ab717123341 (patch)
treeff740cbdeae01efa03d5f9f33c402d59d5302ea3 /xfce-base
parentkde-frameworks/extra-cmake-modules: Drop old (diff)
downloadgentoo-c0c7320c64220f984d8692e84d2b3ab717123341.tar.gz
gentoo-c0c7320c64220f984d8692e84d2b3ab717123341.tar.bz2
gentoo-c0c7320c64220f984d8692e84d2b3ab717123341.zip
xfce-base/thunar: Fix missed desktop db update
Diffstat (limited to 'xfce-base')
-rw-r--r--xfce-base/thunar/thunar-1.6.12.ebuild10
1 files changed, 9 insertions, 1 deletions
diff --git a/xfce-base/thunar/thunar-1.6.12.ebuild b/xfce-base/thunar/thunar-1.6.12.ebuild
index 1081996ccfd5..7f0e7ed3946e 100644
--- a/xfce-base/thunar/thunar-1.6.12.ebuild
+++ b/xfce-base/thunar/thunar-1.6.12.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit virtualx
+inherit virtualx xdg-utils
MY_P=${P^}
@@ -65,3 +65,11 @@ src_configure() {
src_test() {
virtx emake check
}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+}