summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-text/bact/bact-0.13-r1.ebuild (renamed from app-text/bact/bact-0.13.ebuild)19
1 files changed, 8 insertions, 11 deletions
diff --git a/app-text/bact/bact-0.13.ebuild b/app-text/bact/bact-0.13-r1.ebuild
index 00cd99778b7c..a5b5f5b4bd76 100644
--- a/app-text/bact/bact-0.13.ebuild
+++ b/app-text/bact/bact-0.13-r1.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=4
+EAPI=6
-inherit eutils toolchain-funcs
+inherit toolchain-funcs
DESCRIPTION="Boosting Algorithm for Classification of Trees"
HOMEPAGE="http://chasen.org/~taku/software/bact/"
@@ -15,12 +15,11 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
-DEPEND=""
-RDEPEND="${DEPEND}"
+RDEPEND=""
+DEPEND="${RDEPEND}"
-src_prepare() {
- epatch "${FILESDIR}/${P}-cpp14.patch" # bug #594312
-}
+HTML_DOCS=( index.html bact.css )
+PATCHES=( "${FILESDIR}/${P}-cpp14.patch" )
src_compile() {
emake CXX="$(tc-getCXX)" CXXFLAGS="${CXXFLAGS}" LDFLAGS="${LDFLAGS}"
@@ -32,7 +31,5 @@ src_test() {
src_install() {
dobin bact_learn bact_mkmodel bact_classify
-
- dohtml index.html bact.css
- dodoc README AUTHORS
+ einstalldocs
}