summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/bact/bact-0.13-r1.ebuild')
-rw-r--r--app-text/bact/bact-0.13-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/app-text/bact/bact-0.13-r1.ebuild b/app-text/bact/bact-0.13-r1.ebuild
new file mode 100644
index 000000000000..a5b5f5b4bd76
--- /dev/null
+++ b/app-text/bact/bact-0.13-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="Boosting Algorithm for Classification of Trees"
+HOMEPAGE="http://chasen.org/~taku/software/bact/"
+SRC_URI="http://chasen.org/~taku/software/bact/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}"
+
+HTML_DOCS=( index.html bact.css )
+PATCHES=( "${FILESDIR}/${P}-cpp14.patch" )
+
+src_compile() {
+ emake CXX="$(tc-getCXX)" CXXFLAGS="${CXXFLAGS}" LDFLAGS="${LDFLAGS}"
+}
+
+src_test() {
+ emake test
+}
+
+src_install() {
+ dobin bact_learn bact_mkmodel bact_classify
+ einstalldocs
+}