summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-editors/emacs/emacs-18.59-r11.ebuild5
-rw-r--r--app-editors/emacs/emacs-23.4-r16.ebuild5
-rw-r--r--app-editors/emacs/emacs-24.5-r4.ebuild4
-rw-r--r--app-editors/emacs/emacs-25.3.ebuild4
4 files changed, 9 insertions, 9 deletions
diff --git a/app-editors/emacs/emacs-18.59-r11.ebuild b/app-editors/emacs/emacs-18.59-r11.ebuild
index 8b9d3d2c04e9..19abd28b5a20 100644
--- a/app-editors/emacs/emacs-18.59-r11.ebuild
+++ b/app-editors/emacs/emacs-18.59-r11.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -71,8 +71,7 @@ src_configure() {
src_compile() {
# Do not use the sandbox, or the dumped Emacs will be twice as large
- export SANDBOX_ON=0
- emake --jobs=1 \
+ SANDBOX_ON=0 LD_PRELOAD="" emake --jobs=1 \
CC="$(tc-getCC)" CFLAGS="${CFLAGS} -Demacs" \
LD="$(tc-getCC) -nostdlib" LDFLAGS="${LDFLAGS}"
}
diff --git a/app-editors/emacs/emacs-23.4-r16.ebuild b/app-editors/emacs/emacs-23.4-r16.ebuild
index eb7cceabd897..00d4f14a53a5 100644
--- a/app-editors/emacs/emacs-23.4-r16.ebuild
+++ b/app-editors/emacs/emacs-23.4-r16.ebuild
@@ -209,8 +209,9 @@ src_configure() {
}
src_compile() {
- export SANDBOX_ON=0 # for the unbelievers, see Bug #131505
- emake CC="$(tc-getCC)" \
+ # Disable the sandbox. For the unbelievers, see bug #131505
+ SANDBOX_ON=0 LD_PRELOAD="" emake \
+ CC="$(tc-getCC)" \
AR="$(tc-getAR) cq" \
RANLIB="$(tc-getRANLIB)"
}
diff --git a/app-editors/emacs/emacs-24.5-r4.ebuild b/app-editors/emacs/emacs-24.5-r4.ebuild
index c86549765c99..8360af8c48d8 100644
--- a/app-editors/emacs/emacs-24.5-r4.ebuild
+++ b/app-editors/emacs/emacs-24.5-r4.ebuild
@@ -210,8 +210,8 @@ src_configure() {
}
src_compile() {
- export SANDBOX_ON=0 # for the unbelievers, see Bug #131505
- emake
+ # Disable the sandbox. For the unbelievers, see bug #131505
+ SANDBOX_ON=0 LD_PRELOAD="" emake
}
src_install () {
diff --git a/app-editors/emacs/emacs-25.3.ebuild b/app-editors/emacs/emacs-25.3.ebuild
index 35c1cc20476f..286763c2e236 100644
--- a/app-editors/emacs/emacs-25.3.ebuild
+++ b/app-editors/emacs/emacs-25.3.ebuild
@@ -220,8 +220,8 @@ src_configure() {
}
src_compile() {
- export SANDBOX_ON=0 # for the unbelievers, see Bug #131505
- emake
+ # Disable the sandbox. For the unbelievers, see bug #131505
+ SANDBOX_ON=0 LD_PRELOAD="" emake
}
src_install () {