summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-ml/type-conv/Manifest1
-rw-r--r--dev-ml/type-conv/type-conv-113.00.02.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-ml/type-conv/Manifest b/dev-ml/type-conv/Manifest
index 68e5b46fb234..22ad5947cccd 100644
--- a/dev-ml/type-conv/Manifest
+++ b/dev-ml/type-conv/Manifest
@@ -1,2 +1,3 @@
DIST type_conv-112.01.02.tar.gz 64095 SHA256 342a241a43a2d494739244c8e41624bef25dfae809ebf15577d817ebb67f3890 SHA512 68acc043dc33db3928c6078c8bd5eac2f3346c39af2e7ff4605a397b3322032da5ae8be4ef8a1eba440b57c048f55b74ba47de4fc08cefe934eba34f35e235a4 WHIRLPOOL a53009600678d75405d6648030efe84896cf9cdbcde261265608691b9f6a8d28340acaf414e7de48b52c27b0b030a294612b80e1573759f0e4fdd70bd3142dcb
DIST type_conv-113.00.00.tar.gz 64297 SHA256 52bf5bc316f24411ad8f334b07b98a852071c92d0f95914c5d933ae7c65feb43 SHA512 bd9a455b4c30b5ba95a6cd4032bac61f69f9657a8e583c72b74e2a1974b0ad5b7488c5ba173ab880937ff0b8fa79712f761436fe1ffe7a45f8301f37cfb5a825 WHIRLPOOL 1dff5fe344c747a2525615a4c9379fb9b392fec01702f50ae80c614d1d0445ebb04558b2ca1c605a0396bbecc66e97e4d61f6a4259d304b556e566929a733fcd
+DIST type_conv-113.00.02.tar.gz 64174 SHA256 d305d0032be314916ac3ec37617e0c8d3aadab9bcee14e746e567d8405f5289c SHA512 6bc6db0e5a36fa4150941155290d137552d9e19aac7cf3aff107f0a7eaa47749c7044c4a4e475827d739784b99ef2103e9c9c03191c6aaa55c51585e71553559 WHIRLPOOL c973ae79adc01dbf6150b9427e878cc7aea754cc1fab8ae2cf2ddcb2fb2fbba6cef3ff2e4095993fd72bbe3e6d646099db46ec153e0542b6180c6c8230875deb
diff --git a/dev-ml/type-conv/type-conv-113.00.02.ebuild b/dev-ml/type-conv/type-conv-113.00.02.ebuild
new file mode 100644
index 000000000000..8acec6e53dec
--- /dev/null
+++ b/dev-ml/type-conv/type-conv-113.00.02.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+OASIS_BUILD_DOCS=1
+
+inherit oasis
+
+MY_P=${PN/-/_}-${PV}
+DESCRIPTION="Mini library required for some other preprocessing libraries"
+HOMEPAGE="http://janestreet.github.io/"
+SRC_URI="http://ocaml.janestreet.com/ocaml-core/${PV%.*}/files/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/ocaml-4.02[ocamlopt?]
+ dev-ml/camlp4:="
+DEPEND="${RDEPEND}
+ >=dev-ml/findlib-1.3.2"
+
+DOCS=( "README.md" "CHANGES.md" )
+
+S="${WORKDIR}/${MY_P}"