summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/type-conv/type-conv-113.00.02.ebuild')
-rw-r--r--dev-ml/type-conv/type-conv-113.00.02.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ml/type-conv/type-conv-113.00.02.ebuild b/dev-ml/type-conv/type-conv-113.00.02.ebuild
new file mode 100644
index 000000000000..8acec6e53dec
--- /dev/null
+++ b/dev-ml/type-conv/type-conv-113.00.02.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+OASIS_BUILD_DOCS=1
+
+inherit oasis
+
+MY_P=${PN/-/_}-${PV}
+DESCRIPTION="Mini library required for some other preprocessing libraries"
+HOMEPAGE="http://janestreet.github.io/"
+SRC_URI="http://ocaml.janestreet.com/ocaml-core/${PV%.*}/files/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/ocaml-4.02[ocamlopt?]
+ dev-ml/camlp4:="
+DEPEND="${RDEPEND}
+ >=dev-ml/findlib-1.3.2"
+
+DOCS=( "README.md" "CHANGES.md" )
+
+S="${WORKDIR}/${MY_P}"