summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/consul-template/consul-template-9999.ebuild')
-rw-r--r--app-admin/consul-template/consul-template-9999.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/app-admin/consul-template/consul-template-9999.ebuild b/app-admin/consul-template/consul-template-9999.ebuild
index 40307ab73520..0dcf7f1b9541 100644
--- a/app-admin/consul-template/consul-template-9999.ebuild
+++ b/app-admin/consul-template/consul-template-9999.ebuild
@@ -4,7 +4,7 @@
EAPI=5
-inherit git-r3 systemd user
+inherit git-r3 golang-base systemd user
KEYWORDS=""
DESCRIPTION="Generic template rendering and notifications with Consul"
@@ -32,7 +32,7 @@ pkg_setup() {
}
src_unpack() {
- export GOPATH=${WORKDIR}
+ export GOPATH=${WORKDIR}:$(get_golibdir_gopath)
git-r3_src_unpack
go get -d -v ./... $(go list -f '{{range .TestImports}}{{.}} {{end}}' ./...) || die
}