summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-db/opendbx/opendbx-1.4.5-r1.ebuild')
-rw-r--r--dev-db/opendbx/opendbx-1.4.5-r1.ebuild28
1 files changed, 13 insertions, 15 deletions
diff --git a/dev-db/opendbx/opendbx-1.4.5-r1.ebuild b/dev-db/opendbx/opendbx-1.4.5-r1.ebuild
index c069c4e62341..6def19a1ee09 100644
--- a/dev-db/opendbx/opendbx-1.4.5-r1.ebuild
+++ b/dev-db/opendbx/opendbx-1.4.5-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="5"
+EAPI="6"
-inherit flag-o-matic multilib
+inherit flag-o-matic
DESCRIPTION="OpenDBX - A database abstraction layer"
HOMEPAGE="https://www.linuxnetworks.de/doc/index.php/OpenDBX"
@@ -15,28 +15,22 @@ KEYWORDS="amd64 x86"
IUSE="firebird +mysql oracle postgres sqlite"
RESTRICT="firebird? ( bindist )"
-DEPEND="mysql? ( virtual/mysql )
+RDEPEND="mysql? ( dev-db/mysql-connector-c:0= )
postgres? ( dev-db/postgresql:* )
sqlite? ( dev-db/sqlite:3 )
oracle? ( dev-db/oracle-instantclient-basic )
firebird? ( dev-db/firebird )"
-RDEPEND="${DEPEND}"
+DEPEND="${RDEPEND} app-doc/doxygen app-text/docbook2X"
-pkg_setup() {
- if ! ( use firebird || use mysql || use oracle || use postgres || use sqlite )
- then
- ewarn "You should enable at least one of the following USE flags:"
- ewarn "firebird, mysql, oracle, postgres or sqlite"
- fi
+REQUIRED_USE="|| ( firebird mysql oracle postgres sqlite )"
+
+PATCHES=( "${FILESDIR}/${PN}-doxy.patch" )
+pkg_setup() {
if use oracle && [[ ! -d ${ORACLE_HOME} ]]
then
die "Oracle support requested, but ORACLE_HOME not set to a valid directory!"
fi
-
- use mysql && append-cppflags -I/usr/include/mysql
- use firebird && append-cppflags -I/opt/firebird/include
- use oracle && append-ldflags -L"${ORACLE_HOME}"/lib
}
src_configure() {
@@ -48,6 +42,10 @@ src_configure() {
use postgres && backends="${backends} pgsql"
use sqlite && backends="${backends} sqlite3"
+ use mysql && append-cppflags -I/usr/include/mysql
+ use firebird && append-cppflags -I/opt/firebird/include
+ use oracle && append-ldflags -L"${ORACLE_HOME}"/lib
+
econf --with-backends="${backends}"
}