summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/opendbx/files/opendbx-doxy.patch45
-rw-r--r--dev-db/opendbx/opendbx-1.4.5-r1.ebuild28
-rw-r--r--dev-db/opendbx/opendbx-1.4.6-r2.ebuild (renamed from dev-db/opendbx/opendbx-1.4.6-r1.ebuild)34
-rw-r--r--dev-db/opendbx/opendbx-1.5.0-r2.ebuild (renamed from dev-db/opendbx/opendbx-1.5.0-r1.ebuild)34
4 files changed, 90 insertions, 51 deletions
diff --git a/dev-db/opendbx/files/opendbx-doxy.patch b/dev-db/opendbx/files/opendbx-doxy.patch
new file mode 100644
index 000000000000..d95712bcf704
--- /dev/null
+++ b/dev-db/opendbx/files/opendbx-doxy.patch
@@ -0,0 +1,45 @@
+--- a/doc/Doxyfile.in 2009-07-13 16:30:48.000000000 -0400
++++ b/doc/Doxyfile.in 2019-02-08 13:22:51.088064431 -0500
+@@ -46,6 +46,8 @@
+ DISTRIBUTE_GROUP_DOC = NO
+ SUBGROUPING = YES
+ TYPEDEF_HIDES_STRUCT = NO
++EXTENSION_MAPPING = no_extension=C++
++
+ #---------------------------------------------------------------------------
+ # Build related configuration options
+ #---------------------------------------------------------------------------
+@@ -75,7 +77,6 @@
+ ENABLED_SECTIONS =
+ MAX_INITIALIZER_LINES = 30
+ SHOW_USED_FILES = YES
+-SHOW_DIRECTORIES = NO
+ SHOW_FILES = YES
+ SHOW_NAMESPACES = YES
+ FILE_VERSION_FILTER =
+@@ -182,7 +183,6 @@
+ HTML_HEADER =
+ HTML_FOOTER =
+ HTML_STYLESHEET =
+-HTML_ALIGN_MEMBERS = YES
+ GENERATE_HTMLHELP = NO
+ GENERATE_DOCSET = NO
+ DOCSET_FEEDNAME = "Doxygen generated docs"
+@@ -235,8 +235,6 @@
+ #---------------------------------------------------------------------------
+ GENERATE_XML = YES
+ XML_OUTPUT = xml
+-XML_SCHEMA =
+-XML_DTD =
+ XML_PROGRAMLISTING = YES
+ #---------------------------------------------------------------------------
+ # configuration options for the AutoGen Definitions output
+@@ -276,7 +274,7 @@
+ MSCGEN_PATH =
+ HIDE_UNDOC_RELATIONS = YES
+ HAVE_DOT = NO
+-DOT_FONTNAME = FreeSans
++DOT_FONTNAME = Helvetica
+ DOT_FONTPATH =
+ CLASS_GRAPH = YES
+ COLLABORATION_GRAPH = YES
diff --git a/dev-db/opendbx/opendbx-1.4.5-r1.ebuild b/dev-db/opendbx/opendbx-1.4.5-r1.ebuild
index c069c4e62341..6def19a1ee09 100644
--- a/dev-db/opendbx/opendbx-1.4.5-r1.ebuild
+++ b/dev-db/opendbx/opendbx-1.4.5-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="5"
+EAPI="6"
-inherit flag-o-matic multilib
+inherit flag-o-matic
DESCRIPTION="OpenDBX - A database abstraction layer"
HOMEPAGE="https://www.linuxnetworks.de/doc/index.php/OpenDBX"
@@ -15,28 +15,22 @@ KEYWORDS="amd64 x86"
IUSE="firebird +mysql oracle postgres sqlite"
RESTRICT="firebird? ( bindist )"
-DEPEND="mysql? ( virtual/mysql )
+RDEPEND="mysql? ( dev-db/mysql-connector-c:0= )
postgres? ( dev-db/postgresql:* )
sqlite? ( dev-db/sqlite:3 )
oracle? ( dev-db/oracle-instantclient-basic )
firebird? ( dev-db/firebird )"
-RDEPEND="${DEPEND}"
+DEPEND="${RDEPEND} app-doc/doxygen app-text/docbook2X"
-pkg_setup() {
- if ! ( use firebird || use mysql || use oracle || use postgres || use sqlite )
- then
- ewarn "You should enable at least one of the following USE flags:"
- ewarn "firebird, mysql, oracle, postgres or sqlite"
- fi
+REQUIRED_USE="|| ( firebird mysql oracle postgres sqlite )"
+
+PATCHES=( "${FILESDIR}/${PN}-doxy.patch" )
+pkg_setup() {
if use oracle && [[ ! -d ${ORACLE_HOME} ]]
then
die "Oracle support requested, but ORACLE_HOME not set to a valid directory!"
fi
-
- use mysql && append-cppflags -I/usr/include/mysql
- use firebird && append-cppflags -I/opt/firebird/include
- use oracle && append-ldflags -L"${ORACLE_HOME}"/lib
}
src_configure() {
@@ -48,6 +42,10 @@ src_configure() {
use postgres && backends="${backends} pgsql"
use sqlite && backends="${backends} sqlite3"
+ use mysql && append-cppflags -I/usr/include/mysql
+ use firebird && append-cppflags -I/opt/firebird/include
+ use oracle && append-ldflags -L"${ORACLE_HOME}"/lib
+
econf --with-backends="${backends}"
}
diff --git a/dev-db/opendbx/opendbx-1.4.6-r1.ebuild b/dev-db/opendbx/opendbx-1.4.6-r2.ebuild
index b438b36edf6d..f3c0607e740f 100644
--- a/dev-db/opendbx/opendbx-1.4.6-r1.ebuild
+++ b/dev-db/opendbx/opendbx-1.4.6-r2.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="5"
+EAPI="6"
-inherit flag-o-matic multilib
+inherit flag-o-matic
DESCRIPTION="OpenDBX - A database abstraction layer"
HOMEPAGE="https://www.linuxnetworks.de/doc/index.php/OpenDBX"
@@ -15,28 +15,22 @@ KEYWORDS="~amd64 ~x86"
IUSE="firebird +mysql oracle postgres sqlite"
RESTRICT="firebird? ( bindist )"
-DEPEND="mysql? ( virtual/mysql )
+RDEPEND="mysql? ( dev-db/mysql-connector-c:0= )
postgres? ( dev-db/postgresql:* )
sqlite? ( dev-db/sqlite:3 )
oracle? ( dev-db/oracle-instantclient-basic )
firebird? ( dev-db/firebird )"
-RDEPEND="${DEPEND}"
+DEPEND="${RDEPEND} app-doc/doxygen app-text/docbook2X"
-pkg_setup() {
- if ! ( use firebird || use mysql || use oracle || use postgres || use sqlite )
- then
- ewarn "You should enable at least one of the following USE flags:"
- ewarn "firebird, mysql, oracle, postgres or sqlite"
- fi
+REQUIRED_USE="|| ( firebird mysql oracle postgres sqlite )"
+
+PATCHES=( "${FILESDIR}/${PN}-doxy.patch" )
+pkg_setup() {
if use oracle && [[ ! -d ${ORACLE_HOME} ]]
then
die "Oracle support requested, but ORACLE_HOME not set to a valid directory!"
fi
-
- use mysql && append-cppflags -I/usr/include/mysql
- use firebird && append-cppflags -I/opt/firebird/include
- use oracle && append-ldflags -L"${ORACLE_HOME}"/lib
}
src_configure() {
@@ -48,16 +42,20 @@ src_configure() {
use postgres && backends="${backends} pgsql"
use sqlite && backends="${backends} sqlite3"
- econf --with-backends="${backends}" || die "econf failed"
+ use mysql && append-cppflags -I/usr/include/mysql
+ use firebird && append-cppflags -I/opt/firebird/include
+ use oracle && append-ldflags -L"${ORACLE_HOME}"/lib
+
+ econf --with-backends="${backends}"
}
src_compile() {
# bug #322221
- emake -j1 || die "emake failed"
+ emake -j1
}
src_install() {
- emake -j1 install DESTDIR="${D}" || die "make install failed"
+ emake -j1 install DESTDIR="${D}"
dodoc AUTHORS ChangeLog README
rm -f "${D}"/usr/$(get_libdir)/opendbx/*.{a,la}
diff --git a/dev-db/opendbx/opendbx-1.5.0-r1.ebuild b/dev-db/opendbx/opendbx-1.5.0-r2.ebuild
index e377a26c8c0a..9f23d103a95d 100644
--- a/dev-db/opendbx/opendbx-1.5.0-r1.ebuild
+++ b/dev-db/opendbx/opendbx-1.5.0-r2.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="5"
+EAPI="6"
-inherit flag-o-matic multilib
+inherit flag-o-matic
MY_PN="lib${PN}"
MY_P="${MY_PN}-${PV}"
@@ -18,30 +18,24 @@ KEYWORDS="~x64-solaris"
IUSE="firebird +mysql oracle postgres sqlite"
RESTRICT="firebird? ( bindist )"
-DEPEND="mysql? ( virtual/mysql )
+RDEPEND="mysql? ( dev-db/mysql-connector-c:0= )
postgres? ( dev-db/postgresql:* )
sqlite? ( dev-db/sqlite:3 )
oracle? ( dev-db/oracle-instantclient-basic )
firebird? ( dev-db/firebird )"
-RDEPEND="${DEPEND}"
+DEPEND="${RDEPEND} app-doc/doxygen app-text/docbook2X"
S="${WORKDIR}"/${MY_P}
-pkg_setup() {
- if ! ( use firebird || use mysql || use oracle || use postgres || use sqlite )
- then
- ewarn "You should enable at least one of the following USE flags:"
- ewarn "firebird, mysql, oracle, postgres or sqlite"
- fi
+REQUIRED_USE="|| ( firebird mysql oracle postgres sqlite )"
+
+PATCHES=( "${FILESDIR}/${PN}-doxy.patch" )
+pkg_setup() {
if use oracle && [[ ! -d ${ORACLE_HOME} ]]
then
die "Oracle support requested, but ORACLE_HOME not set to a valid directory!"
fi
-
- use mysql && append-cppflags -I/usr/include/mysql
- use firebird && append-cppflags -I/opt/firebird/include
- use oracle && append-ldflags -L"${ORACLE_HOME}"/lib
}
src_configure() {
@@ -53,16 +47,20 @@ src_configure() {
use postgres && backends="${backends} pgsql"
use sqlite && backends="${backends} sqlite3"
- econf --with-backends="${backends}" || die "econf failed"
+ use mysql && append-cppflags -I/usr/include/mysql
+ use firebird && append-cppflags -I/opt/firebird/include
+ use oracle && append-ldflags -L"${ORACLE_HOME}"/lib
+
+ econf --with-backends="${backends}"
}
src_compile() {
# bug #322221
- emake -j1 || die "emake failed"
+ emake -j1
}
src_install() {
- emake -j1 install DESTDIR="${D}" || die "make install failed"
+ emake -j1 install DESTDIR="${D}"
dodoc AUTHORS ChangeLog README
rm -f "${D}"/usr/$(get_libdir)/opendbx/*.{a,la}