summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/attoparsec/attoparsec-0.11.2.1.ebuild')
-rw-r--r--dev-haskell/attoparsec/attoparsec-0.11.2.1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-haskell/attoparsec/attoparsec-0.11.2.1.ebuild b/dev-haskell/attoparsec/attoparsec-0.11.2.1.ebuild
new file mode 100644
index 000000000000..4fbdb1e23252
--- /dev/null
+++ b/dev-haskell/attoparsec/attoparsec-0.11.2.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.6.9999
+#hackport: flags: -developer
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Fast combinator parsing for bytestrings and text"
+HOMEPAGE="https://github.com/bos/attoparsec"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/scientific-0.2:=[profile?]
+ >=dev-haskell/text-0.11.3.1:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( >=dev-haskell/quickcheck-2.4
+ >=dev-haskell/test-framework-0.4
+ >=dev-haskell/test-framework-quickcheck2-0.2 )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-developer
+}