summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/attoparsec')
-rw-r--r--dev-haskell/attoparsec/Manifest4
-rw-r--r--dev-haskell/attoparsec/attoparsec-0.10.4.0.ebuild33
-rw-r--r--dev-haskell/attoparsec/attoparsec-0.11.2.1.ebuild36
-rw-r--r--dev-haskell/attoparsec/attoparsec-0.12.1.5.ebuild38
-rw-r--r--dev-haskell/attoparsec/attoparsec-0.13.0.1.ebuild39
-rw-r--r--dev-haskell/attoparsec/metadata.xml13
6 files changed, 163 insertions, 0 deletions
diff --git a/dev-haskell/attoparsec/Manifest b/dev-haskell/attoparsec/Manifest
new file mode 100644
index 000000000000..9aa45fadeadf
--- /dev/null
+++ b/dev-haskell/attoparsec/Manifest
@@ -0,0 +1,4 @@
+DIST attoparsec-0.10.4.0.tar.gz 36268 SHA256 b6b84e0dbd1c3beec1dedea578ac2f4d62afbe66b383582b7b3349406866d346 SHA512 f32db51d6c4e8119fb28a8d51f6d7452f8870765b652992f577602aba0ecb9e81522fd4919a907f1b7b8ff06d21d4bd64c05b86f808b098f93fbb22daaaa7e8f WHIRLPOOL f15e0a5f2f27132eeb645ea36384b7cff93585af1729f10915aa54405653707baf082fb17b59aeea434d6522ba809ea90b0d8964e56f03e1afe42a30460224cd
+DIST attoparsec-0.11.2.1.tar.gz 36439 SHA256 3ce8f56c0231ddc19e326285acfaca3c144618fea971f0ece202581c3bac3bbf SHA512 33f27bad5e13e515a07a77247a31822e136531da8d9aa7c15ad9cf1205d681c53b68d09c2e09d3b6c2fba9ec7bfae640f6ac0a9ed45cd421b11cabb1f5cd4282 WHIRLPOOL 47997d77639453271baeb6f259ad5655c4b8dd2118e1c8f4f805a81daf6d2a526e5782f49b55401043b9ccbf82dd547a43a489c72a2eda7a790207c65f39d6b6
+DIST attoparsec-0.12.1.5.tar.gz 64844 SHA256 388bf78177d4b8b870db7fb291d103691ccf171d97d2944f09cc62d01516348c SHA512 e861b93bfcdeb284c95e7c96d2a41754e2ad061f169842523bd8680b60743f0d6d300e13237d17b776f60b338152b4fa10679aeb95d1cf0c9d073e093952e9e4 WHIRLPOOL ea6488c08134eebcc3ab86433047a0920bd8fb31e189f864526cd7828265d3edbb682e75ff4235efd6ff9d54c0e4386dda9cca600898a0018648ebfcd17cf45f
+DIST attoparsec-0.13.0.1.tar.gz 66039 SHA256 ce880acb45142eafd872e01d9af57d8dbb95c9f2b9a27f01ca9912ba4e9ef932 SHA512 596a1bda128c116b9e56decf0f5850b01f58c4b0bb81454155a1ee7b4c6b7143476cb9d66f02fba10e6fa5d5fb7a47dead6265dd3d98baeea4d8fa4a9958289c WHIRLPOOL 7b54f3015be2d77b1dcfcb2dd7053de3a2b2a5e13b18c5b61d0a17c6e5dd74261dd1aa3fcf0fdf17df6bcbf92c6c66bc0c1c3b7b04843bda3ae0371ba00dbff1
diff --git a/dev-haskell/attoparsec/attoparsec-0.10.4.0.ebuild b/dev-haskell/attoparsec/attoparsec-0.10.4.0.ebuild
new file mode 100644
index 000000000000..4fb42a5cbeab
--- /dev/null
+++ b/dev-haskell/attoparsec/attoparsec-0.10.4.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.2.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Fast combinator parsing for bytestrings and text"
+HOMEPAGE="https://github.com/bos/attoparsec"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/text-0.11.1.5:=[profile?]
+ >=dev-lang/ghc-6.10.4:="
+DEPEND="${RDEPEND}
+ test? ( >=dev-haskell/quickcheck-2.4
+ >=dev-haskell/test-framework-0.4
+ >=dev-haskell/test-framework-quickcheck2-0.2
+ )
+ >=dev-haskell/cabal-1.8"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-developer
+}
diff --git a/dev-haskell/attoparsec/attoparsec-0.11.2.1.ebuild b/dev-haskell/attoparsec/attoparsec-0.11.2.1.ebuild
new file mode 100644
index 000000000000..4fbdb1e23252
--- /dev/null
+++ b/dev-haskell/attoparsec/attoparsec-0.11.2.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.6.9999
+#hackport: flags: -developer
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Fast combinator parsing for bytestrings and text"
+HOMEPAGE="https://github.com/bos/attoparsec"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/scientific-0.2:=[profile?]
+ >=dev-haskell/text-0.11.3.1:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( >=dev-haskell/quickcheck-2.4
+ >=dev-haskell/test-framework-0.4
+ >=dev-haskell/test-framework-quickcheck2-0.2 )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-developer
+}
diff --git a/dev-haskell/attoparsec/attoparsec-0.12.1.5.ebuild b/dev-haskell/attoparsec/attoparsec-0.12.1.5.ebuild
new file mode 100644
index 000000000000..d5c5b398132b
--- /dev/null
+++ b/dev-haskell/attoparsec/attoparsec-0.12.1.5.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.3
+#hackport: flags: -developer
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Fast combinator parsing for bytestrings and text"
+HOMEPAGE="https://github.com/bos/attoparsec"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/scientific-0.3.1:=[profile?] <dev-haskell/scientific-0.4:=[profile?]
+ >=dev-haskell/text-1.1.1.3:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( >=dev-haskell/quickcheck-2.7
+ dev-haskell/quickcheck-unicode
+ >=dev-haskell/test-framework-0.8.0.2
+ >=dev-haskell/test-framework-quickcheck2-0.3.0.3
+ dev-haskell/vector )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-developer
+}
diff --git a/dev-haskell/attoparsec/attoparsec-0.13.0.1.ebuild b/dev-haskell/attoparsec/attoparsec-0.13.0.1.ebuild
new file mode 100644
index 000000000000..34b4be2394b7
--- /dev/null
+++ b/dev-haskell/attoparsec/attoparsec-0.13.0.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.5.9999
+#hackport: flags: -developer
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Fast combinator parsing for bytestrings and text"
+HOMEPAGE="https://github.com/bos/attoparsec"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/scientific-0.3.1:=[profile?] <dev-haskell/scientific-0.4:=[profile?]
+ >=dev-haskell/text-1.1.1.3:=[profile?]
+ dev-haskell/transformers:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( >=dev-haskell/quickcheck-2.7
+ dev-haskell/quickcheck-unicode
+ >=dev-haskell/test-framework-0.8.0.2
+ >=dev-haskell/test-framework-quickcheck2-0.3.0.3
+ dev-haskell/vector )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-developer
+}
diff --git a/dev-haskell/attoparsec/metadata.xml b/dev-haskell/attoparsec/metadata.xml
new file mode 100644
index 000000000000..c3972bf907b7
--- /dev/null
+++ b/dev-haskell/attoparsec/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <longdescription>
+ A fast parser combinator library, aimed particularly at dealing
+ efficiently with network protocols and complicated text/binary
+ file formats.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">bos/attoparsec</remote-id>
+ </upstream>
+</pkgmetadata>