summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/shellish/files/shellish-0.1.4-ghc-7.10.patch9
-rw-r--r--dev-haskell/shellish/shellish-0.1.4.ebuild6
2 files changed, 14 insertions, 1 deletions
diff --git a/dev-haskell/shellish/files/shellish-0.1.4-ghc-7.10.patch b/dev-haskell/shellish/files/shellish-0.1.4-ghc-7.10.patch
new file mode 100644
index 000000000000..c756635f6000
--- /dev/null
+++ b/dev-haskell/shellish/files/shellish-0.1.4-ghc-7.10.patch
@@ -0,0 +1,9 @@
+diff --git a/Shellish.hs b/Shellish.hs
+index 1e3c192..0ac20c2 100644
+--- a/Shellish.hs
++++ b/Shellish.hs
+@@ -1,3 +1,3 @@
+ {-# LANGUAGE ScopedTypeVariables, DeriveDataTypeable, OverloadedStrings,
+- MultiParamTypeClasses, FlexibleInstances #-}
++ MultiParamTypeClasses, FlexibleInstances, FlexibleContexts #-}
+
diff --git a/dev-haskell/shellish/shellish-0.1.4.ebuild b/dev-haskell/shellish/shellish-0.1.4.ebuild
index 86f421a07c2b..f93d8797cc7a 100644
--- a/dev-haskell/shellish/shellish-0.1.4.ebuild
+++ b/dev-haskell/shellish/shellish-0.1.4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -24,3 +24,7 @@ RDEPEND="dev-haskell/mtl[profile?]
>=dev-lang/ghc-6.10.1"
DEPEND="${RDEPEND}
>=dev-haskell/cabal-1.6"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-ghc-7.10.patch
+}